xpidl doesn't work using gecko 1.8b1

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

xpidl doesn't work using gecko 1.8b1

crayne
I have an xpcom, currently running in Firefox 1.5 on Windows and in Firefox
1.07on Linux Fedora Core 3.  On Windows I compiled with Gecko 1.8b1, and on
Fedora I compiled for Firefox 1.07 with a previous Gecko (don't know the
version, but it works).  Now I am trying to build a version on Linux that
will work with Firefox 1.5, so I am using the Linux version of Gecko 1.8b1.
Here is the command line:

./xpidl -v -m header -I gecko-sdk-linux-1.8b1/idl nsISpeakIt.idl

I get this error:

./xpidl: error while loading shared libraries:  libIDL-0.6.so.0:  cannot
open shared object file:  No such file or library

Can anyone tell me what's wrong here?  Thanks.


_______________________________________________
dev-tech-xpcom mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xpcom
Reply | Threaded
Open this post in threaded view
|

Re: xpidl doesn't work using gecko 1.8b1

Christian Biesinger
Susan Crayne wrote:
> ./xpidl: error while loading shared libraries:  libIDL-0.6.so.0:  cannot
> open shared object file:  No such file or library
>
> Can anyone tell me what's wrong here?  Thanks.

You need to install libIDL 1. On Fedora, that's part of ORBit.i386.
_______________________________________________
dev-tech-xpcom mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xpcom
Reply | Threaded
Open this post in threaded view
|

Re: xpidl doesn't work using gecko 1.8b1

crayne
In reply to this post by crayne
Do you know where I can get this -- it is not on my system (Fedora Core 3)?
"Christian Biesinger" <[hidden email]> wrote in message
news:[hidden email]...
> Susan Crayne wrote:
> > ./xpidl: error while loading shared libraries:  libIDL-0.6.so.0:  cannot
> > open shared object file:  No such file or library
> >
> > Can anyone tell me what's wrong here?  Thanks.
>
> You need to install libIDL 1. On Fedora, that's part of ORBit.i386.


_______________________________________________
dev-tech-xpcom mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xpcom
Reply | Threaded
Open this post in threaded view
|

Re: xpidl doesn't work using gecko 1.8b1

Christian Biesinger
Susan Crayne wrote:
> Do you know where I can get this -- it is not on my system (Fedora Core 3)?

With "yum install ORBit".
_______________________________________________
dev-tech-xpcom mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xpcom
Reply | Threaded
Open this post in threaded view
|

Re: xpidl doesn't work using gecko 1.8b1

crayne
In reply to this post by crayne
Thanks.

"Christian Biesinger" <[hidden email]> wrote in message
news:[hidden email]...
> Susan Crayne wrote:
> > Do you know where I can get this -- it is not on my system (Fedora Core
3)?
>
> With "yum install ORBit".


_______________________________________________
dev-tech-xpcom mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xpcom