xpidl crashes on nsIConsoleListener.idl

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

xpidl crashes on nsIConsoleListener.idl

sg-3
I am trying to build the latest mozilla sources on
windows XP.
I get the following build error(xpidl crashes):

nsIConsoleListener.idl
/cygdrive/c/mozilla/LatestMozilla/mozilla/build/cygwin-wrapper
../../dist/bin/xpidl.exe -m header -w
 -I/cygdrive/c/mozilla/LatestMozilla/mozilla/xpcom/base
-I../../dist/idl -o _xpidlgen/nsIConsoleList
ener
/cygdrive/c/mozilla/LatestMozilla/mozilla/xpcom/base/nsIConsoleListener.idl


Please help!!

Thanks in advance,
sg

_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds
Reply | Threaded
Open this post in threaded view
|

Re: xpidl crashes on nsIConsoleListener.idl

Benjamin Smedberg
sg wrote:

> I am trying to build the latest mozilla sources on
> windows XP.
> I get the following build error(xpidl crashes):
>
> nsIConsoleListener.idl
> /cygdrive/c/mozilla/LatestMozilla/mozilla/build/cygwin-wrapper
> ../../dist/bin/xpidl.exe -m header -w
>  -I/cygdrive/c/mozilla/LatestMozilla/mozilla/xpcom/base
> -I../../dist/idl -o _xpidlgen/nsIConsoleList
> ener
> /cygdrive/c/mozilla/LatestMozilla/mozilla/xpcom/base/nsIConsoleListener.idl

See the mozilla build FAQ. You're ending up using the wrong copy of
libidl/glib. On trunk and 1.8branch you shouldn't need any package except
the moztools-static package. On the 1.8.0 branch (for Firefox 1.5.0.x) you
will need a copy of the specific libIDL that goes with your compiler (MSVC6,
7, 8). This is all documented at
http://developer.mozilla.org/en/docs/Windows_Build_Prerequisites and
http://developer.mozilla.org/en/docs/Windows_Build_Prerequisites_on_the_1.7_and_1.8_Branches

--BDS
_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds