undefined hidden symbol ... GetTRRMode

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

undefined hidden symbol ... GetTRRMode

Ian Pilcher
I am trying to build Thunderbird from source, so that I can bisect an
issue (https://bugzilla.mozilla.org/show_bug.cgi?id=1526765).  I'm
following the instructions here:

 
https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Simple_Thunderbird_build

The build is failing with "undefined hidden symbol" linker errors, all
of which seem to ultimately refer to GetTRRMode or SetTRRMode, e.g.:

  ld.lld: error: undefined hidden symbol: non-virtual thunk to
nsPgpMimeProxy::GetTRRMode(nsIRequest::TRRMode*)
  ...
  ld.lld: error: undefined hidden symbol:
nsNntpMockChannel::SetTRRMode(nsIRequest::TRRMode)

Any hints on how to get this build working are appreciated.

Thanks!

--
========================================================================
                  In Soviet Russia, Google searches you!
========================================================================
_______________________________________________
dev-apps-thunderbird mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-thunderbird
Reply | Threaded
Open this post in threaded view
|

Re: undefined hidden symbol ... GetTRRMode

Jörg Knobloch
On 09 Jan 2020 16:06, Ian Pilcher wrote:
> Any hints on how to get this build working are appreciated.

Refresh your M-C and C-C repositories and your build will succeed. This
was so-called bustage that has already been fixed.

_______________________________________________
dev-apps-thunderbird mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-thunderbird