testserevr.pl fails on fedora 12

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

testserevr.pl fails on fedora 12

Banani Banerjee
Hi!
I installed bugzilla 3.4.5 on fedora 12.
The #./testserver.pl http://localhost/bugzilla/ gives the following error:

TEST-OK Webserver is running under group id in $webservergroup.
TEST-FAILED Fetch of images/padlock.png failed
Your web server could not fetch http://localhost/bugzilla/images/padlock.png.
Check your web server configuration and try again.

The User and Group are apache, apache in httpd.conf file.

One thing I noticed  ls -l of /var/www/html/bugzilla following listing
-rwxr-x---.  1 root apache  5852 2009-06-03 03:53 editvalues.cgi
-rwxr-x---.  1 root apache  6318 2008-01-27 15:14 editversions.cgi
-rwxr-x---.  1 root apache 18524 2008-08-27 16:26 editwhines.cgi
-rwxr-x---.  1 root apache  5193 2008-07-02 12:10 editworkflow.cgi
-rwxr-x---.  1 root apache 15085 2009-04-28 13:27 email_in.pl
-rwxr-x---.  1 root apache 25535 2009-11-16 03:21 enter_bug.cgi
drwxr-x---.  4 root apache  4096 2010-01-31 17:38 extensions
drwxrwx---.  2 root apache  4096 2010-03-09 06:08 graphs
drwxr-x---.  3 root apache  4096 2010-01-31 17:38 images
-rwxr-x---.  1 root apache 51819 2009-04-10 15:28 importxml.pl
-rwxr-x---.  1 root apache  2956 2009-03-01 15:42 index.cgi
-rwx------.  1 root apache  4955 2009-09-16 02:45 install-module.pl

What might be the problem of this failure? Please give me some
clue to sort this out.
Thanks.
Banani



     
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: TEST-FAILED Fetch of images/padlock.png failed

Banani Banerjee
Hi!
I installed bugzilla 3.4.5 on fedora 12.
The #./testserver.pl http://localhost/bugzilla/ gives the following error:

TEST-OK Webserver is running under group id in $webservergroup.
TEST-FAILED Fetch of images/padlock.png failed
Your web server could not fetch http://localhost/bugzilla/images/padlock.png.
Check your web server configuration and try again.

The User and Group are apache, apache in httpd.conf file.

One thing I noticed  ls -l of /var/www/html/bugzilla following tpye of listing with dot(.) in each line
-rwxr-x---.  1 root apache  5852 2009-06-03 03:53 editvalues.cgi
-rwxr-x---.  1 root apache  6318 2008-01-27 15:14 editversions.cgi
-rwxr-x---.  1 root apache 18524 2008-08-27 16:26 editwhines.cgi
-rwxr-x---.  1 root apache  5193 2008-07-02 12:10 editworkflow.cgi
-rwxr-x---.  1 root apache 15085 2009-04-28 13:27 email_in.pl
-rwxr-x---.  1 root apache 25535 2009-11-16 03:21 enter_bug.cgi
drwxr-x---.  4 root apache  4096 2010-01-31 17:38 extensions
drwxrwx---.  2 root apache  4096 2010-03-09 06:08 graphs
drwxr-x---.  3 root apache  4096 2010-01-31 17:38 images
-rwxr-x---.  1 root apache 51819 2009-04-10 15:28 importxml.pl
-rwxr-x---.  1 root apache  2956 2009-03-01 15:42 index.cgi
-rwx------.  1 root apache  4955 2009-09-16 02:45 install-module.pl
Is the dot anyway responsible for this failure?

What might be the problem of this failure? Please help.
Thanks.
Banani


--- On Tue, 3/9/10, Banani Banerjee <[hidden email]> wrote:

> From: Banani Banerjee <[hidden email]>
> Subject: testserevr.pl fails on fedora 12
> To: [hidden email]
> Date: Tuesday, March 9, 2010, 10:51 PM
> Hi!
> I installed bugzilla 3.4.5 on fedora 12.
> The #./testserver.pl http://localhost/bugzilla/ gives the
> following error:
>
> TEST-OK Webserver is running under group id in
> $webservergroup.
> TEST-FAILED Fetch of images/padlock.png failed
> Your web server could not fetch http://localhost/bugzilla/images/padlock.png.
> Check your web server configuration and try again.
>
> The User and Group are apache, apache in httpd.conf file.
>
> One thing I noticed  ls -l of /var/www/html/bugzilla
> following listing
> -rwxr-x---.  1 root apache  5852 2009-06-03 03:53
> editvalues.cgi
> -rwxr-x---.  1 root apache  6318 2008-01-27 15:14
> editversions.cgi
> -rwxr-x---.  1 root apache 18524 2008-08-27 16:26
> editwhines.cgi
> -rwxr-x---.  1 root apache  5193 2008-07-02 12:10
> editworkflow.cgi
> -rwxr-x---.  1 root apache 15085 2009-04-28 13:27
> email_in.pl
> -rwxr-x---.  1 root apache 25535 2009-11-16 03:21
> enter_bug.cgi
> drwxr-x---.  4 root apache  4096 2010-01-31 17:38
> extensions
> drwxrwx---.  2 root apache  4096 2010-03-09 06:08 graphs
> drwxr-x---.  3 root apache  4096 2010-01-31 17:38 images
> -rwxr-x---.  1 root apache 51819 2009-04-10 15:28
> importxml.pl
> -rwxr-x---.  1 root apache  2956 2009-03-01 15:42
> index.cgi
> -rwx------.  1 root apache  4955 2009-09-16 02:45
> install-module.pl
>
> What might be the problem of this failure? Please give me
> some
> clue to sort this out.
> Thanks.
> Banani
>
>
>
>      
> _______________________________________________
> support-bugzilla mailing list
> [hidden email]
> https://lists.mozilla.org/listinfo/support-bugzilla
> PLEASE put [hidden email]
> in the To: field when you reply.
>


     
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: testserevr.pl fails on fedora 12

Steve Wendt
In reply to this post by Banani Banerjee
On 3/9/2010 10:51 PM, Banani Banerjee wrote:

> I installed bugzilla 3.4.5 on fedora 12.
> The #./testserver.pl http://localhost/bugzilla/ gives the following error:
>
> TEST-OK Webserver is running under group id in $webservergroup.
> TEST-FAILED Fetch of images/padlock.png failed
> Your web server could not fetch http://localhost/bugzilla/images/padlock.png.
> Check your web server configuration and try again.
>
> What might be the problem of this failure? Please give me some
> clue to sort this out.

If SELinux is enabled, that could be causing you trouble.  You may also
find some clues in the Apache error log.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: testserevr.pl fails on fedora 12

Banani Banerjee
Thanks. Steve.

When I restart httpd, Apache errorlog shows
[Wed Mar 10 05:22:37 2010] [notice] caught SIGTERM, shutting down
[Wed Mar 10 05:22:37 2010] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
[Wed Mar 10 05:22:37 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Wed Mar 10 05:22:37 2010] [notice] Digest: generating secret for digest authentication ...
[Wed Mar 10 05:22:37 2010] [notice] Digest: done
[Wed Mar 10 05:22:37 2010] [warn] ./mod_dnssd.c: No services found to register
[Wed Mar 10 05:22:37 2010] [notice] Apache/2.2.14 (Unix) DAV/2 configured -- resuming normal operations

And also following error log, when I run .testserver.pl,
[Wed Mar 10 05:24:09 2010] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /var/www/html/bugzilla

Banani


--- On Wed, 3/10/10, Steve Wendt <[hidden email]> wrote:

> From: Steve Wendt <[hidden email]>
> Subject: Re: testserevr.pl fails on fedora 12
> To: [hidden email]
> Date: Wednesday, March 10, 2010, 10:36 AM
> On 3/9/2010 10:51 PM, Banani Banerjee
> wrote:
>
> > I installed bugzilla 3.4.5 on fedora 12.
> > The #./testserver.pl http://localhost/bugzilla/ gives the following error:
> >
> > TEST-OK Webserver is running under group id in
> $webservergroup.
> > TEST-FAILED Fetch of images/padlock.png failed
> > Your web server could not fetch http://localhost/bugzilla/images/padlock.png.
> > Check your web server configuration and try again.
> >
> > What might be the problem of this failure? Please give
> me some
> > clue to sort this out.
>
> If SELinux is enabled, that could be causing you
> trouble.  You may also
> find some clues in the Apache error log.
> _______________________________________________
> support-bugzilla mailing list
> [hidden email]
> https://lists.mozilla.org/listinfo/support-bugzilla
> PLEASE put [hidden email]
> in the To: field when you reply.
>


     
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: testserevr.pl fails on fedora 12

Steve Wendt
In reply to this post by Banani Banerjee
On 3/10/2010 11:32 AM, Banani Banerjee wrote:

> [Wed Mar 10 05:22:37 2010] [notice] SELinux policy enabled; httpd running as context unconfined_u:system_r:httpd_t:s0
> [Wed Mar 10 05:22:37 2010] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)

That may or may not be a problem...

> [Wed Mar 10 05:24:09 2010] [error] [client 127.0.0.1] Symbolic link not allowed or link target not accessible: /var/www/html/bugzilla

... but this is.  Something here (or others via Google) might help:

http://httpd.apache.org/docs/2.2/urlmapping.html#outside
http://www.linuxquestions.org/questions/linux-server-73/apache-2-error-symbolic-link-not-allowed-706605/
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: testserevr.pl fails on fedora 12

Banani Banerjee
These following lines are there in httpd.conf file

Alias /bugzilla/ /var/www/html/bugzilla/>
<Directory /var/www/html/bugzilla/>
    AddHandler cgi-script .cgi
    Options +Indexes +ExecCGI
    DirectoryIndex index.cgi
    AllowOverride Limit
    </Directory>
still get the error  
"link target not accessible: /var/www/html/bugzilla"

Thanks. I will look into the sites you mentioned.
Banani

--- On Wed, 3/10/10, Steve Wendt <[hidden email]> wrote:

> From: Steve Wendt <[hidden email]>
> Subject: Re: testserevr.pl fails on fedora 12
> To: [hidden email]
> Date: Wednesday, March 10, 2010, 11:39 AM
> On 3/10/2010 11:32 AM, Banani
> Banerjee wrote:
>
> > [Wed Mar 10 05:22:37 2010] [notice] SELinux policy
> enabled; httpd running as context
> unconfined_u:system_r:httpd_t:s0
> > [Wed Mar 10 05:22:37 2010] [notice] suEXEC mechanism
> enabled (wrapper: /usr/sbin/suexec)
>
> That may or may not be a problem...
>
> > [Wed Mar 10 05:24:09 2010] [error] [client 127.0.0.1]
> Symbolic link not allowed or link target not accessible:
> /var/www/html/bugzilla
>
> ... but this is.  Something here (or others via
> Google) might help:
>
> http://httpd.apache.org/docs/2.2/urlmapping.html#outside
> http://www.linuxquestions.org/questions/linux-server-73/apache-2-error-symbolic-link-not-allowed-706605/
> _______________________________________________
> support-bugzilla mailing list
> [hidden email]
> https://lists.mozilla.org/listinfo/support-bugzilla
> PLEASE put [hidden email]
> in the To: field when you reply.
>


     
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: testserevr.pl fails on fedora 12

Banani Banerjee
In reply to this post by Steve Wendt
When I disable ELinux with
/usr/sbin/setenforce 0 ,
./testserver.pl workeed properly.
Thanks.
Banani

--- On Wed, 3/10/10, Steve Wendt <[hidden email]> wrote:

> From: Steve Wendt <[hidden email]>
> Subject: Re: testserevr.pl fails on fedora 12
> To: [hidden email]
> Date: Wednesday, March 10, 2010, 11:39 AM
> On 3/10/2010 11:32 AM, Banani
> Banerjee wrote:
>
> > [Wed Mar 10 05:22:37 2010] [notice] SELinux policy
> enabled; httpd running as context
> unconfined_u:system_r:httpd_t:s0
> > [Wed Mar 10 05:22:37 2010] [notice] suEXEC mechanism
> enabled (wrapper: /usr/sbin/suexec)
>
> That may or may not be a problem...
>
> > [Wed Mar 10 05:24:09 2010] [error] [client 127.0.0.1]
> Symbolic link not allowed or link target not accessible:
> /var/www/html/bugzilla
>
> ... but this is.  Something here (or others via
> Google) might help:
>
> http://httpd.apache.org/docs/2.2/urlmapping.html#outside
> http://www.linuxquestions.org/questions/linux-server-73/apache-2-error-symbolic-link-not-allowed-706605/
> _______________________________________________
> support-bugzilla mailing list
> [hidden email]
> https://lists.mozilla.org/listinfo/support-bugzilla
> PLEASE put [hidden email]
> in the To: field when you reply.
>


     
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: TEST-FAILED Fetch of images/padlock.png failed

punchedrock
In reply to this post by Banani Banerjee
I have the same error. Did you find any solution?
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: TEST-FAILED Fetch of images/padlock.png failed

gorgeous65
In reply to this post by Banani Banerjee
Hello,

same error.

Any solution?

Thanks



On Wednesday, 10 March 2010 17:42:35 UTC, Banani Banerjee  wrote:

> Hi!
> I installed bugzilla 3.4.5 on fedora 12.
> The #./testserver.pl http://localhost/bugzilla/ gives the following error:
>
> TEST-OK Webserver is running under group id in $webservergroup.
> TEST-FAILED Fetch of images/padlock.png failed
> Your web server could not fetch http://localhost/bugzilla/images/padlock.png.
> Check your web server configuration and try again.
>
> The User and Group are apache, apache in httpd.conf file.
>
> One thing I noticed  ls -l of /var/www/html/bugzilla following tpye of listing with dot(.) in each line
> -rwxr-x---.  1 root apache  5852 2009-06-03 03:53 editvalues.cgi
> -rwxr-x---.  1 root apache  6318 2008-01-27 15:14 editversions.cgi
> -rwxr-x---.  1 root apache 18524 2008-08-27 16:26 editwhines.cgi
> -rwxr-x---.  1 root apache  5193 2008-07-02 12:10 editworkflow.cgi
> -rwxr-x---.  1 root apache 15085 2009-04-28 13:27 email_in.pl
> -rwxr-x---.  1 root apache 25535 2009-11-16 03:21 enter_bug.cgi
> drwxr-x---.  4 root apache  4096 2010-01-31 17:38 extensions
> drwxrwx---.  2 root apache  4096 2010-03-09 06:08 graphs
> drwxr-x---.  3 root apache  4096 2010-01-31 17:38 images
> -rwxr-x---.  1 root apache 51819 2009-04-10 15:28 importxml.pl
> -rwxr-x---.  1 root apache  2956 2009-03-01 15:42 index.cgi
> -rwx------.  1 root apache  4955 2009-09-16 02:45 install-module.pl
> Is the dot anyway responsible for this failure?
>
> What might be the problem of this failure? Please help.
> Thanks.
> Banani
>
>
> --- On Tue, 3/9/10, Banani Banerjee <[hidden email]> wrote:
>
> > From: Banani Banerjee <[hidden email]>
> > Subject: testserevr.pl fails on fedora 12
> > To: [hidden email]
> > Date: Tuesday, March 9, 2010, 10:51 PM
> > Hi!
> > I installed bugzilla 3.4.5 on fedora 12.
> > The #./testserver.pl http://localhost/bugzilla/ gives the
> > following error:
> >
> > TEST-OK Webserver is running under group id in
> > $webservergroup.
> > TEST-FAILED Fetch of images/padlock.png failed
> > Your web server could not fetch http://localhost/bugzilla/images/padlock.png.
> > Check your web server configuration and try again.
> >
> > The User and Group are apache, apache in httpd.conf file.
> >
> > One thing I noticed  ls -l of /var/www/html/bugzilla
> > following listing
> > -rwxr-x---.  1 root apache  5852 2009-06-03 03:53
> > editvalues.cgi
> > -rwxr-x---.  1 root apache  6318 2008-01-27 15:14
> > editversions.cgi
> > -rwxr-x---.  1 root apache 18524 2008-08-27 16:26
> > editwhines.cgi
> > -rwxr-x---.  1 root apache  5193 2008-07-02 12:10
> > editworkflow.cgi
> > -rwxr-x---.  1 root apache 15085 2009-04-28 13:27
> > email_in.pl
> > -rwxr-x---.  1 root apache 25535 2009-11-16 03:21
> > enter_bug.cgi
> > drwxr-x---.  4 root apache  4096 2010-01-31 17:38
> > extensions
> > drwxrwx---.  2 root apache  4096 2010-03-09 06:08 graphs
> > drwxr-x---.  3 root apache  4096 2010-01-31 17:38 images
> > -rwxr-x---.  1 root apache 51819 2009-04-10 15:28
> > importxml.pl
> > -rwxr-x---.  1 root apache  2956 2009-03-01 15:42
> > index.cgi
> > -rwx------.  1 root apache  4955 2009-09-16 02:45
> > install-module.pl
> >
> > What might be the problem of this failure? Please give me
> > some
> > clue to sort this out.
> > Thanks.
> > Banani
> >
> >
> >
> >      
> > _______________________________________________
> > support-bugzilla mailing list
> > [hidden email]
> > https://lists.mozilla.org/listinfo/support-bugzilla
> > PLEASE put [hidden email]
> > in the To: field when you reply.
> >

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.