single instance XULRunner applications

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

single instance XULRunner applications

JanakiRam
Hi All,

        I'm developing a XULRunner application on Windows. My
Application should have only Single Instance running at a time i.e
like Single Document Applcation(SDI). But when i click my app's EXE ,
it launches new App everytime.

       I've searched the mozilla site for  this , found a link
containing the singletonWindowType preference. I tried the same with
my app , but it didn't work.(http://developer.mozilla.org/en/docs/
toolkit.singletonWindowType)

        I'm using XULRunner 1.8.0.9 version for this application.

        For Clarity I'm providing the Code i've written.

application.ini
---------------------
[App]
Vendor=E
Name=xulrunnerSingleInstance
Version=1.0
BuildID=20060101
Copyright=Copyright (c) 2006 E Inc.
ID=[hidden email]

[Gecko]
MinVersion=1.8
MaxVersion=1.9

defaults/pref.js
---------------------

pref("toolkit.defaultChromeURI", "chrome://xulrunnersingleinstance/
content/xulrunnerSingleInstance.xul");
pref("toolkit.singletonWindowType", "xulmines");


xulrunnerSingleInstance.xul
------------------------------------------
<?xml version="1.0"?>
<?xml-stylesheet href="chrome://global/skin/" type="text/css"?>

<window id="main-window" windowtype="xulmine"
title="xulrunnerSingleInstance"  xmlns="http://www.mozilla.org/
keymaster/gatekeeper/there.is.only.xul" width="500" height="600">

</window>


chrome/chrome.manifest
-----------------------------------
content xulrunnersingleinstance file:content/


I've seen a bug raised in mozilla bugbase - (https://
bugzilla.mozilla.org/show_bug.cgi?id=317811). Is this bug any way
related to  my requirement ?


Please provide some pointers to solve this issue.  Thanks in Advance.


-JanakiRam

_______________________________________________
dev-tech-xpinstall mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xpinstall
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: single instance XULRunner applications

Mark Finkle
Notice the difference? "xulmines" vs "xulmine"

pref("toolkit.singletonWindowType", "xulmines");
<window id="main-window" windowtype="xulmine"

Unless it was just retyped incorrectly

On May 17, 10:57 am, JanakiRam <[hidden email]> wrote:

> Hi All,
>
>         I'm developing a XULRunner application on Windows. My
> Application should have only Single Instance running at a time i.e
> like Single Document Applcation(SDI). But when i click my app's EXE ,
> it launches new App everytime.
>
>        I've searched the mozilla site for  this , found a link
> containing the singletonWindowType preference. I tried the same with
> my app , but it didn't work.(http://developer.mozilla.org/en/docs/
> toolkit.singletonWindowType)
>
>         I'm using XULRunner 1.8.0.9 version for this application.
>
>         For Clarity I'm providing the Code i've written.
>
> application.ini
> ---------------------
> [App]
> Vendor=E
> Name=xulrunnerSingleInstance
> Version=1.0
> BuildID=20060101
> Copyright=Copyright (c) 2006 E Inc.
> [hidden email]
>
> [Gecko]
> MinVersion=1.8
> MaxVersion=1.9
>
> defaults/pref.js
> ---------------------
>
> pref("toolkit.defaultChromeURI", "chrome://xulrunnersingleinstance/
> content/xulrunnerSingleInstance.xul");
> pref("toolkit.singletonWindowType", "xulmines");
>
> xulrunnerSingleInstance.xul
> ------------------------------------------
> <?xml version="1.0"?>
> <?xml-stylesheet href="chrome://global/skin/" type="text/css"?>
>
> <window id="main-window" windowtype="xulmine"
> title="xulrunnerSingleInstance"  xmlns="http://www.mozilla.org/
> keymaster/gatekeeper/there.is.only.xul" width="500" height="600">
>
> </window>
>
> chrome/chrome.manifest
> -----------------------------------
> content xulrunnersingleinstance file:content/
>
> I've seen a bug raised in mozilla bugbase - (https://
> bugzilla.mozilla.org/show_bug.cgi?id=317811). Is this bug any way
> related to  my requirement ?
>
> Please provide some pointers to solve this issue.  Thanks in Advance.
>
> -JanakiRam


_______________________________________________
dev-tech-xpinstall mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xpinstall
Loading...