"Different"(?) 403 Forbidden Error

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

"Different"(?) 403 Forbidden Error

ordbkr
I've installed Bugzilla 2.18.1 on a RH EL 4 system.  All of the perl
modules listed in the install instructions have been isntalled.  I've
run checksetup.pl many times.

The main web server page can be accessed, but I get a 403 error when I
try to access "localhost/bugzilla".

"testserver.pl" reports that it can fetch "ant.jpg":

[root@pcHome1 bugzilla]# ./testserver.pl http://localhost/bugzilla
TEST-OK Webserver is running under group id in $webservergroup.
TEST-FAILED Fetch of ant.jpg failed
Your webserver could not fetch http://localhost/bugzilla/ant.jpg.
Check your webserver configuration and try again.
[root@pcHome1 bugzilla]#


I have looked at the httpd/errors.log and it reports that it can't open
the .htaccess file:

[Fri Jun 10 22:30:17 2005] [crit] [client 127.0.0.1] (13)Permission
denied: /var/www/html/bugzilla/.htaccess pcfg_openfile: unable to check
htaccess file, ensure it is readable
[Fri Jun 10 22:30:17 2005] [error] [client 127.0.0.1] File does not
exist: /var/www/html/favicon.ico


I changed the permission on The files in the /var/www/html/bugzilla
directory to 755 , but that did not corrrect the problem.

I am sure that this is a permissions problem, but don't know where else
to look.

_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: "Different"(?) 403 Forbidden Error

Max Kanat-Alexander
On Fri, 2005-06-10 at 15:43 -0700, [hidden email] wrote:
> I've installed Bugzilla 2.18.1 on a RH EL 4 system.  All of the perl
> modules listed in the install instructions have been isntalled.  I've
> run checksetup.pl many times.

        My best guess is that you've set the $webservergroup incorrectly in the
localconfig file. For RHEL4, it should be "apache", unless you've
somehow modified your RHEL4 so that Apache doesn't run as the "apache"
group.

        -Max
--
http://www.everythingsolved.com/
Everything Solved: Experts at Bugzilla... and everything else, too.

_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: "Different"(?) 403 Forbidden Error

ordbkr
In reply to this post by ordbkr
Max,

Thank you for the hint.  The $webservergroup was set to "apache", as
well as the User and Group variables in the httpd.conf.  I copied the
entire bugzilla directory into /var/www/html/bugzilla (instead of using
a soft link) and that seems to have corrected that problem.

I can now get the index.cgi to display the main page.  Now I get the
following error when I try to login or select one of the links:

Software error:
Error in tempfile() using data/versioncache.XXXXX: Parent directory
(data/) is not writable
 at globals.pl line 241

For help, please send mail to the webmaster (root@localhost), giving
this error message and the time and date of the error.

I have looked at the "globals.pl" script and found where $datadir
references a tmp file.

Where and how is $datadir setup?  It is not in the localconfig file and
it is not mentioned in the documentation.

Thanks,

Don

_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: "Different"(?) 403 Forbidden Error

Max Kanat-Alexander-2
On Tue, 2005-06-14 at 11:10 -0700, Don wrote:
> Where and how is $datadir setup?  It is not in the localconfig file and
> it is not mentioned in the documentation.

        It's set up by checksetup.pl. If you don't mind losing your parameters
(which are usually easy to set again), you can just delete the entire
directory and re-run checksetup.pl to have it be created again with the
correct permissions.

        -Max
--
http://www.everythingsolved.com/
Everything Solved: Complete Computer Management

_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: "Different"(?) 403 Forbidden Error

Max Kanat-Alexander
In reply to this post by ordbkr
On Tue, 2005-06-14 at 11:10 -0700, Don wrote:
> Where and how is $datadir setup?  It is not in the localconfig file and
> it is not mentioned in the documentation.

        It's set up by checksetup.pl. If you don't mind losing your parameters
(which are usually easy to set again), you can just delete the entire
directory and re-run checksetup.pl to have it be created again with the
correct permissions.

        -Max
--
http://www.everythingsolved.com/
Everything Solved: Experts at Bugzilla... and everything else, too.

_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: "Different"(?) 403 Forbidden Error

ordbkr
In reply to this post by ordbkr
Thank you.  I found the directory.  I had to change the permissions on
the directory.  Now it is working.  I have created products, some
groups and some users.

I have a "problem" with Group administration, but I have not searched
through existing posts yet to see if my question has already been
answered.

Thanks again.

Don

_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools