problem installing extensions on linux

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

problem installing extensions on linux

Peter Santoro
I originally posted this message to mozilla.support.thunderbird and it
was suggested I repost to this group.  Since my original post, I think I
figured out the solution to my problem (see below), but I would
appreciate verification.

Background:

I'm using slackware 10.2 with updates.  The script I use to build my
thunderbird package is very similar to the official slackbuild script
which uses the official mozilla thunderbird linux binary.

As of release 1.5.0.5, I added a couple of xpi files (enigmail, new mail
icon) to my package in the extensions directory.  After installing the
package, I ran thunderbird as root (first time only) and it asked me if
I wanted to install the extensions.  That worked as expected and the
extensions were installed correctly, but I never used any extensions
before that.

Problem:

I just built my 1.5.0.7 thunderbird package and discovered the following
after installing the slackware package via upgradepkg:

1) run tb as root
2) tb prompts user to install extensions
3) user selects install
4) tb window comes up
5) the extensions were not installed and the extensions are deleted from
the extensions directory

Removing the thunderbird package via removepkg and re-installing it via
installpkg produces the same results.  However, if I reinstall the
package via "upgradepkg --reinstall" and rerun steps 1-4, the extensions
are indeed installed.

*** Extensions appear to be only installed every other time, if you've
already installed them with a previous thunderbird release. ***

A workaround appears to be run upgradepkg, do above steps 1-4, run
upgradepkg --reinstall, and redo steps 1-4.  I would prefer to fix the
problem.

Notes:

I noticed that the user's (in this case, root) extensions.cache,
extensions.ini, extensions.rdf files are updated during steps 1-4 above.
 I also noticed that when theses files did not contain any old
references to the extensions listed in step 2, that the extensions
installed fine, otherwise the installation of extensions failed.  When
the installation of the extensions failed, these extensions files
appeared to be "cleaned up".


Questions:

1) Am I packaging extensions incorrectly?
2) Do I need to "clean up" or delete some or all of root's thunderbird
extensions files (cache, ini, rdf) at install time before thunderbird is
first run?
3) What is the correct way to package extensions with a release of
thunderbird that works correctly during thunderbird updates?


My Potential Solution:

I updated my thunderbird slackware package's doinst.sh to remove root's
thunderbird extensions.* files (if present) and the extensions install now.


Thank you,

Peter
_______________________________________________
dev-tech-xpinstall mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xpinstall