mozilla-xremote-client

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

mozilla-xremote-client

Tim Kornhammar
I'm using Ubuntu linux 5.10 and have checked all dependecies but still
getting an error
with xremoteclient.. I bet there is an easy solution but I just can't
figure out what is missing!


//////////////////////////
// mozilla/.mozconfig
//////////////////////////

# This file specifies the build flags for Firefox.  You can use it by
adding:
#  . $topsrcdir/browser/config/mozconfig
# to the top of your mozconfig file.

mk_add_options MOZ_CO_PROJECT=browser
ac_add_options --enable-application=browser
ac_add_options --enable-optimize
ac_add_options --disable-debug
ac_add_options --enable-default-toolkit=gtk2
ac_add_options --disable-tests


//////////////////////////
// mozilla$ make -f client.mk build
//////////////////////////

make[3]: Leaving directory
`/home/tim/breezy/mozilla/toolkit/components'
make[3]: Entering directory
`/home/tim/breezy/mozilla/widget/src/xremoteclient'
c++ -o mozilla-xremote-client  -fno-rtti -fno-exceptions -Wall
-Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth
-Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic
-fshort-wchar -pthread -pipe  -DNDEBUG -DTRIMMED -O
mozilla-xremote-client.o XRemoteClient_standalone.o
-L../../../dist/bin -L../../../dist/lib -L../../../dist/lib -lplds4
-lplc4 -lnspr4 -lpthread -ldl   -ldl -lm
XRemoteClient_standalone.o: I funktionen "XRemoteClient::Init()":
XRemoteClient.cpp:(.text+0xae): undefined reference to `XOpenDisplay'
XRemoteClient.cpp:(.text+0xdc): undefined reference to `XInternAtoms'
XRemoteClient_standalone.o: I funktionen "XRemoteClient::Shutdown()":
...
...
...
XRemoteClient_standalone.o: I funktionen
"XRemoteClient::SendCommand(char const*, char const*, char const*, char
const*, char**, int*)":
XRemoteClient.cpp:(.text+0xf45): undefined reference to `XSelectInput'
collect2: ld returned 1 exit status
make[3]: *** [mozilla-xremote-client] Fel 1
make[3]: Leaving directory
`/home/tim/breezy/mozilla/widget/src/xremoteclient'
make[2]: *** [tier_50] Fel 2
make[2]: Leaving directory `/home/tim/breezy/mozilla'
make[1]: *** [default] Fel 2
make[1]: Leaving directory `/home/tim/breezy/mozilla'
make: *** [build] Fel 2

_______________________________________________
mozilla-builds mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-builds
Reply | Threaded
Open this post in threaded view
|

Re: mozilla-xremote-client

Andrew Schultz-2
[hidden email] wrote:
> I'm using Ubuntu linux 5.10 and have checked all dependecies but still
> getting an error
> with xremoteclient.. I bet there is an easy solution but I just can't
> figure out what is missing!

You're not the first person to hit this:
http://groups.google.com/group/netscape.public.mozilla.builds/browse_frm/thread/833405af4e49fd1e/b7676d74244cfcfb#b7676d74244cfcfb
I don't recall if/how HÃ¥kan got it to build properly.

--
Andrew Schultz
[hidden email]
http://www.sens.buffalo.edu/~ajs42/
_______________________________________________
mozilla-builds mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-builds
Reply | Threaded
Open this post in threaded view
|

Re: mozilla-xremote-client

Tim Kornhammar
Thanks for the response, I thought I'd searched through all posts...

I tried adding:
LIBS            = \
                 $(NSPR_LIBS) \
                 $(XLDFLAGS) $(XLIBS)
to the bottom of Makefile.in and found that it was in the Makefile
during 'make' but still got the same error..

_______________________________________________
mozilla-builds mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-builds
Reply | Threaded
Open this post in threaded view
|

Re: mozilla-xremote-client

Tim Kornhammar
Never mind what I wrote, it worked by inserting those lines. But why
need to do something like that everytime to compile and it doesn't say
so in any of the mozilla documentation?


scuba skrev:

> Thanks for the response, I thought I'd searched through all posts...
>
> I tried adding:
> LIBS            = \
>                  $(NSPR_LIBS) \
>                  $(XLDFLAGS) $(XLIBS)
> to the bottom of Makefile.in and found that it was in the Makefile
> during 'make' but still got the same error..

_______________________________________________
mozilla-builds mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-builds
Reply | Threaded
Open this post in threaded view
|

Re: mozilla-xremote-client

Andrew Schultz-2
scuba wrote:
> Never mind what I wrote, it worked by inserting those lines. But why
> need to do something like that everytime to compile and it doesn't say
> so in any of the mozilla documentation?

You shouldn't need to do what you did.  The rest of the world doesn't
have to do it.  I don't know what the real problem.  I suspect it's in
your system.

--
Andrew Schultz
[hidden email]
http://www.sens.buffalo.edu/~ajs42/
_______________________________________________
mozilla-builds mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-builds