Quantcast

mod_version has to be loaded in Apache

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

mod_version has to be loaded in Apache

Rui Rosado
Hi everybody,

I would like to point out a lack (IMHO) in the Bugzilla instructions for installling Apache on Windows (3.5.2. Apache on Windows#3.5.2.1. Installing)
This paragraph lacks the instruction to uncomment the line 'LoadModule version_module modules/mod_version.so' in ./conf/httpd.conf (Apache)
If I *do not* uncomment that line our Bugzilla's main page will show up without any 'decoration': just plain text links and edit-boxes.

The reason is that all the .htaccess files under \bugzilla directory and its subdirectories contain: <IfModule mod_version.c>, so they are referring to mod_version.so
If mod_version.so is not made available, all the lines in the .htaccess files with 'Deny from all' or 'Allow from all' will cause erros to be logged in Apache's error.log file.

After making mod_version.so available to Apache everything works great for us.

I am not an Apache or Bugzilla expert, and therefore I do not know if this is the only (right) solution. But if it is mentioned in the installation instruction, it could prevent people pulling out their hairs.

Regards,
Rui Rosado


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Corrections in .htaccess for Apache 2.4

Rui Rosado
Hi again,

To complete my previous post ('mod_version has to be loaded in Apache'):

Th directives in the .htaccess of all directories in the /bugzilla directory tree do not conform to the new format for Apache 2.4. Please refer to this page about 'Upgrading to 2.4 from 2.2' on the Apache website (paragraph 'Run-Time Configuration Changes'):

https://httpd.apache.org/docs/2.4/upgrading.html

It boils down to replacing all:

  <IfVersion < 2.4>
       Deny from all
  </IfVersion>
  <IfVersion >= 2.4>
       Deny from all
  </IfVersion>
by
  <IfVersion < 2.4>
       Deny from all
  </IfVersion>
  <IfVersion >= 2.4>
       Require all denied
  </IfVersion>

and all
    <IfVersion < 2.4>
         Allow from all
    </IfVersion>
    <IfVersion >= 2.4>
         Allow from all
    </IfVersion>
by
    <IfVersion < 2.4>
         Allow from all
    </IfVersion>
    <IfVersion >= 2.4>
         Require all granted
    </IfVersion>

in all .htaccess files (11x).
Note: the elements <IfVersion < 2.4> are OK because they conform to the Apache 2.2 syntax.

Best regards,
Rui Rosado

-------- Doorgestuurd bericht --------
Onderwerp: mod_version has to be loaded in Apache
Datum: Mon, 6 Feb 2017 12:48:25 +0100
Van: Rui Rosado [hidden email]
Organisatie: Rosado Beheer BV
Aan: [hidden email]


Hi everybody,

I would like to point out a lack (IMHO) in the Bugzilla instructions for installling Apache on Windows (3.5.2. Apache on Windows#3.5.2.1. Installing)
This paragraph lacks the instruction to uncomment the line 'LoadModule version_module modules/mod_version.so' in ./conf/httpd.conf (Apache)
If I *do not* uncomment that line our Bugzilla's main page will show up without any 'decoration': just plain text links and edit-boxes.

The reason is that all the .htaccess files under \bugzilla directory and its subdirectories contain: <IfModule mod_version.c>, so they are referring to mod_version.so
If mod_version.so is not made available, all the lines in the .htaccess files with 'Deny from all' or 'Allow from all' will cause erros to be logged in Apache's error.log file.

After making mod_version.so available to Apache everything works great for us.

I am not an Apache or Bugzilla expert, and therefore I do not know if this is the only (right) solution. But if it is mentioned in the installation instruction, it could prevent people pulling out their hairs.

Regards,
Rui Rosado


Loading...