l10n dashboard shows missing strings but Pontoon doesn't

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

l10n dashboard shows missing strings but Pontoon doesn't

Eduardo Trápani
Hi,

For Firefox Beta https://l10n.mozilla.org/teams/eo shows missing strings
[1] in profile/bookmarks.inc and nsserrors.properties  but Pontoon shows
them as completed [2][3].

For Firefox Central there are also missing strings[4].

I'm not sure if this is related to Pontoon, or compare-locales.


[1] https://l10n.mozilla.org/dashboard/compare?run=897561
[2]
https://pontoon.mozilla.org/eo/firefox/browser/profile/bookmarks.inc/?string=79122
[3]
https://pontoon.mozilla.org/eo/firefox/security/manager/chrome/pipnss/nsserrors.properties/?string=70818
[4] https://l10n.mozilla.org/dashboard/compare?run=898355
_______________________________________________
dev-l10n mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-l10n
Reply | Threaded
Open this post in threaded view
|

Re: l10n dashboard shows missing strings but Pontoon doesn't

Francesco Lodolo [:flod]

> Hi,
>
> For Firefox Beta https://l10n.mozilla.org/teams/eo shows missing
> strings [1] in profile/bookmarks.inc and nsserrors.properties  but
> Pontoon shows them as completed [2][3].
profile/bookmarks.inc is indeed missing them, looks like Pontoon didn't
export them to Mercurial
https://hg.mozilla.org/l10n-central/eo/file/default/browser/profile/bookmarks.inc

same for the other string
https://transvision.mozfr.org/?recherche=MOZILLA_PKIX_ERROR_EMPTY_ISSUER_NAME&repo=gecko_strings&sourcelocale=en-US&locale=eo&search_type=strings_entities

> For Firefox Central there are also missing strings[4].
2 of them are still in quarantine, so that's expected (they landed this
morning in mozilla-central)

_______________________________________________
dev-l10n mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-l10n
Reply | Threaded
Open this post in threaded view
|

Re: l10n dashboard shows missing strings but Pontoon doesn't

Eduardo Trápani
>> For Firefox Beta https://l10n.mozilla.org/teams/eo shows missing
>> strings [1] in profile/bookmarks.inc and nsserrors.properties  but
>> Pontoon shows them as completed [2][3].
> profile/bookmarks.inc is indeed missing them, looks like Pontoon didn't
> export them to Mercurial
> https://hg.mozilla.org/l10n-central/eo/file/default/browser/profile/bookmarks.inc  >
>
> same for the other string
> https://transvision.mozfr.org/?recherche=MOZILLA_PKIX_ERROR_EMPTY_ISSUER_NAME&repo=gecko_strings&sourcelocale=en-US&locale=eo&search_type=strings_entities 

Thanks Flod. Any idea on what that might have happened? I just noticed
it because of your message on plural forms. I wasn't actually checking
the dashboard (kind of trusted Pontoon on that).

Should I file a bug to Pontoon to trace the problem?

Eduardo.
_______________________________________________
dev-l10n mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-l10n
Reply | Threaded
Open this post in threaded view
|

Re: l10n dashboard shows missing strings but Pontoon doesn't

Francesco Lodolo [:flod]
Il 23/01/18 14.31, Eduardo Trápani ha scritto:

>>> For Firefox Beta https://l10n.mozilla.org/teams/eo shows missing
>>> strings [1] in profile/bookmarks.inc and nsserrors.properties  but
>>> Pontoon shows them as completed [2][3].
>> profile/bookmarks.inc is indeed missing them, looks like Pontoon
>> didn't export them to Mercurial
>> https://hg.mozilla.org/l10n-central/eo/file/default/browser/profile/bookmarks.inc 
>> >
>>
>> same for the other string
>> https://transvision.mozfr.org/?recherche=MOZILLA_PKIX_ERROR_EMPTY_ISSUER_NAME&repo=gecko_strings&sourcelocale=en-US&locale=eo&search_type=strings_entities 
>
>
> Thanks Flod. Any idea on what that might have happened? I just noticed
> it because of your message on plural forms. I wasn't actually checking
> the dashboard (kind of trusted Pontoon on that).
>
> Should I file a bug to Pontoon to trace the problem?
Matjaz is looking into it.

I think I've seen this happening before for serious Sync failures, but
those strings are also quite old, so I'm not sure if things improved in
the meantime regarding error recovery.

Francesco
_______________________________________________
dev-l10n mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-l10n
Reply | Threaded
Open this post in threaded view
|

Re: l10n dashboard shows missing strings but Pontoon doesn't

Matjaz Horvat-2
Eduardo,

The files have been pushed a minute ago:
https://hg.mozilla.org/l10n-central/eo/rev/a9b3f128b0ad

I'm not exactly sure what happened, but it's likely a sync failure
from the past we didn't notice. Sorry for the trouble and thanks for
reporting.

Let us know if there's anything else we can help you with!

-Matjaž

On Tue, Jan 23, 2018 at 2:34 PM, Francesco Lodolo [:flod]
<[hidden email]> wrote:

> Il 23/01/18 14.31, Eduardo Trápani ha scritto:
>>>>
>>>> For Firefox Beta https://l10n.mozilla.org/teams/eo shows missing strings
>>>> [1] in profile/bookmarks.inc and nsserrors.properties  but Pontoon shows
>>>> them as completed [2][3].
>>>
>>> profile/bookmarks.inc is indeed missing them, looks like Pontoon didn't
>>> export them to Mercurial
>>>
>>> https://hg.mozilla.org/l10n-central/eo/file/default/browser/profile/bookmarks.inc
>>> >
>>>
>>> same for the other string
>>>
>>> https://transvision.mozfr.org/?recherche=MOZILLA_PKIX_ERROR_EMPTY_ISSUER_NAME&repo=gecko_strings&sourcelocale=en-US&locale=eo&search_type=strings_entities
>>
>>
>>
>> Thanks Flod. Any idea on what that might have happened? I just noticed it
>> because of your message on plural forms. I wasn't actually checking the
>> dashboard (kind of trusted Pontoon on that).
>>
>> Should I file a bug to Pontoon to trace the problem?
>
> Matjaz is looking into it.
>
> I think I've seen this happening before for serious Sync failures, but those
> strings are also quite old, so I'm not sure if things improved in the
> meantime regarding error recovery.
>
> Francesco
>
> _______________________________________________
> dev-l10n mailing list
> [hidden email]
> https://lists.mozilla.org/listinfo/dev-l10n
_______________________________________________
dev-l10n mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-l10n
Reply | Threaded
Open this post in threaded view
|

Re: l10n dashboard shows missing strings but Pontoon doesn't

Eduardo Trápani
On 23/01/18 10:42, Matjaz Horvat wrote:

> The files have been pushed a minute ago:
> https://hg.mozilla.org/l10n-central/eo/rev/a9b3f128b0ad

Thanks Matjaž. That was quick!

> I'm not exactly sure what happened, but it's likely a sync failure
> from the past we didn't notice.
Maybe there are other locales with a similar issue. Maybe you can check
with tools you have at hand if the dashboard and Pontoon agree.

I tried to do it by parsing https://l10n.mozilla.org/shipping/api/status 
with jq but didn't get very far ...
_______________________________________________
dev-l10n mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-l10n