jsd would not restart

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

jsd would not restart

gp-6
Too often (almost always), the debugger will not restart after I closed
it.
I need to restart my computer in order for the jsd to work again.
- windows XP pro ver5.1 SP2
- firefox 1.5.0.9
- jsd 0.9.87

Maybe I don't close it correctly? Is there another way to close it
besides closing the window (which, closes all other firefox windows as
well)
Thank you
Guy

_______________________________________________
dev-apps-js-debugger mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-js-debugger
Reply | Threaded
Open this post in threaded view
|

Re: jsd would not restart

Gijs Kruitbosch ("Hannibal")
gp wrote:

> Too often (almost always), the debugger will not restart after I closed
> it.
> I need to restart my computer in order for the jsd to work again.
> - windows XP pro ver5.1 SP2
> - firefox 1.5.0.9
> - jsd 0.9.87
>
> Maybe I don't close it correctly? Is there another way to close it
> besides closing the window (which, closes all other firefox windows as
> well)
> Thank you
> Guy
>
You can, I believe, suffice with restarting Firefox. And this is a known
bug, yes, but it's not a bug in Venkman - it works fine on Firefox
'trunk' (ie, development) builds, and in Firefox 1.0. Somehow it
regressed in Firefox, and then went back to working again. There is a
bug on file about it, I believe. You can look in
https://bugzilla.mozilla.org for it, if you're interested.

~ Gijs
_______________________________________________
dev-apps-js-debugger mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-js-debugger
Reply | Threaded
Open this post in threaded view
|

Re: jsd would not restart

gp-6
Restarting firefox is not suffice.
I think I've found a matching bug report -
https://bugzilla.mozilla.org/show_bug.cgi?id=358313
Guy

Gijs Kruitbosch ("Hannibal") wrote:

> gp wrote:
> > Too often (almost always), the debugger will not restart after I closed
> > it.
> > I need to restart my computer in order for the jsd to work again.
> > - windows XP pro ver5.1 SP2
> > - firefox 1.5.0.9
> > - jsd 0.9.87
> >
> > Maybe I don't close it correctly? Is there another way to close it
> > besides closing the window (which, closes all other firefox windows as
> > well)
> > Thank you
> > Guy
> >
> You can, I believe, suffice with restarting Firefox. And this is a known
> bug, yes, but it's not a bug in Venkman - it works fine on Firefox
> 'trunk' (ie, development) builds, and in Firefox 1.0. Somehow it
> regressed in Firefox, and then went back to working again. There is a
> bug on file about it, I believe. You can look in
> https://bugzilla.mozilla.org for it, if you're interested.
>
> ~ Gijs

_______________________________________________
dev-apps-js-debugger mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-js-debugger
Reply | Threaded
Open this post in threaded view
|

Re: jsd would not restart

Gijs Kruitbosch ("Hannibal")
gp wrote:
> Restarting firefox is not suffice.
> I think I've found a matching bug report -
> https://bugzilla.mozilla.org/show_bug.cgi?id=358313
> Guy

Actually, that's not the one I meant. It's a dupe of the original, look
at the bug again (I just set the duplicate thing).

Also, after closing Firefox, double-triple-check that the process
(firefox.exe, assuming you're on Windows) has died. If it hasn't, kill
it if it doesn't die within about 10 seconds. Then try again. I'm pretty
sure that will do fine.

~ Gijs
_______________________________________________
dev-apps-js-debugger mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-js-debugger
Reply | Threaded
Open this post in threaded view
|

Re: jsd would not restart

gp-6
Gijs,
I'm used to close firefox with the 'X' and indeed the process is not
fully terminated. Once I killed it, restarting firefox and jsd was ok.
Closing firefox with the File->Exit seems like doing a better job in
terminating the process, though for Darren on
https://bugzilla.mozilla.org/show_bug.cgi?id=338581#c4 it didn't help,
so if the problem persist, terminating the process explicitely is the
answer as you suggested.
Thanks,
Guy

Gijs Kruitbosch ("Hannibal") wrote:

> gp wrote:
> > Restarting firefox is not suffice.
> > I think I've found a matching bug report -
> > https://bugzilla.mozilla.org/show_bug.cgi?id=358313
> > Guy
>
> Actually, that's not the one I meant. It's a dupe of the original, look
> at the bug again (I just set the duplicate thing).
>
> Also, after closing Firefox, double-triple-check that the process
> (firefox.exe, assuming you're on Windows) has died. If it hasn't, kill
> it if it doesn't die within about 10 seconds. Then try again. I'm pretty
> sure that will do fine.
>
> ~ Gijs

_______________________________________________
dev-apps-js-debugger mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-js-debugger