couldn't load xul.dll

classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

couldn't load xul.dll

os24u
 Installing successive Firefox versions, 17 functions, 24.8 and 31.8 fail with:

couldn't load xul.dll

 Have gcccore 1.3.1, extra mozilla dll zip, mozconfig runtime and appears all required
dll files.

 Using Pmdll.exe reports firefox.exe as startable, plugin-containers.exe as can not find
xul.dll in libpath.

 Created test.cmd file with:

set MOZ_CONSOLE_LOG=1
firefox.exe  2>&1 1>console.log

 Nothing in console.log

 Machine is Intel P4 2gb ram, kernel is W4 single core, using ECS 2.1
have: VIRTUALADDRESSLIMIT=2048 in config.sys, no other Mozilla apps.

 Online search usually indicates missing dll but all seem to be in place. Since version
17 operates correctly, something else must be needed for later version.

        Suggestions?

  Cal




_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: couldn't load xul.dll

Steve Wendt
On 01/21/2018 04:48 PM, [hidden email] wrote:

>   Have gcccore 1.3.1, extra mozilla dll zip, mozconfig runtime and appears all required
> dll files.

How old is your "extra mozilla dll zip"?  Each successive version has
added additional requirements.  The mozsupport package I put together
was last updated in October:
http://os2news.warpstock.org/Warpzilla.html
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: couldn't load xul.dll

Dave Yeo-3
In reply to this post by os24u
On 01/21/18 04:48 PM, [hidden email] wrote:
> Using Pmdll.exe reports firefox.exe as startable, plugin-containers.exe as can not find
> xul.dll in libpath.

Try running PMDLL on xul.dll. And as Steve mentioned, sometimes it is a
newer version of a DLL needed, eg the SM I built yesterday needs a libc
that hasn't been released.
Also check popuplog.os2.
Dave
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: couldn't load xul.dll

Barbara-46
In reply to this post by Steve Wendt
On Mon, 22 Jan 2018 01:09:37 UTC, Steve Wendt <[hidden email]> wrote:

> On 01/21/2018 04:48 PM, [hidden email] wrote:
>
> >   Have gcccore 1.3.1, extra mozilla dll zip, mozconfig runtime and appears all required
> > dll files.
>
> How old is your "extra mozilla dll zip"?  Each successive version has
> added additional requirements.  The mozsupport package I put together
> was last updated in October:
> http://os2news.warpstock.org/Warpzilla.html

I don't see anything on that page called "mozsupport package".  What's it
called?


--
Barbara
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: couldn't load xul.dll

Barbara-46
In reply to this post by os24u
On Mon, 22 Jan 2018 01:28:00 UTC, Dave Yeo <[hidden email]> wrote:

> On 01/21/18 04:48 PM, [hidden email] wrote:
> > Using Pmdll.exe reports firefox.exe as startable, plugin-containers.exe as can not find
> > xul.dll in libpath.
>
> Try running PMDLL on xul.dll. And as Steve mentioned, sometimes it is a
> newer version of a DLL needed, eg the SM I built yesterday needs a libc
> that hasn't been released.
> Also check popuplog.os2.
> Dave

I'm having the same problem trying to install FF 45.9.0-2

"Couldn't load xul.dll (os2 error2, faulty module=ICUIN"

I installed Arca Noae Package Manager, updated and filled up my boot drive with
everything under the sun that it found needing newer versions.  That didn't help
much.

Last Firefix I've been able to run is 31.  My eCS version is 2.2b2.

I ran pmdll on xul.dll but don't know how to interpret.  It found two red
things, are these bad?  They are
MOZALLOC.DLL AND MOZSQLT3.DLL.


--
Barbara
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: couldn't load xul.dll

Steve Wendt
In reply to this post by Barbara-46
On 1/22/2018 2:21 PM, Barbara wrote:

>> How old is your "extra mozilla dll zip"?  Each successive version has
>> added additional requirements.  The mozsupport package I put together
>> was last updated in October:
>> http://os2news.warpstock.org/Warpzilla.html
>
> I don't see anything on that page called "mozsupport package".  What's it
> called?

If you are looking in the "Test Versions" column, the link text is
"cairo/pango/icu".
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: couldn't load xul.dll

Steve Wendt
In reply to this post by Barbara-46
On 1/22/2018 2:36 PM, Barbara wrote:

> "Couldn't load xul.dll (os2 error2, faulty module=ICUIN"

That (new feature!) is telling you the DLL it can't find (error 2 is
file not found).  It's part of the ICU package, and there has been some
unfortunate history with that one; I'll spare you the details, but if
you are using the latest mozsupport package, it should have it?

Alternatively, if you are using the RPM packages, you may need to
manually install the "right" one.
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: couldn't load xul.dll

Barbara-46
In reply to this post by Steve Wendt
On Mon, 22 Jan 2018 23:24:26 UTC, Steve Wendt <[hidden email]> wrote:

> On 1/22/2018 2:21 PM, Barbara wrote:
>
> >> How old is your "extra mozilla dll zip"?  Each successive version has
> >> added additional requirements.  The mozsupport package I put together
> >> was last updated in October:
> >> http://os2news.warpstock.org/Warpzilla.html
> >
> > I don't see anything on that page called "mozsupport package".  What's it
> > called?
>
> If you are looking in the "Test Versions" column, the link text is
> "cairo/pango/icu".

Of course...  :)   I'll find it.  Thanks


--
Barbara
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: couldn't load xul.dll

Barbara-46
In reply to this post by Barbara-46
On Mon, 22 Jan 2018 22:36:57 UTC, "Barbara" <[hidden email]> wrote:

> On Mon, 22 Jan 2018 01:28:00 UTC, Dave Yeo <[hidden email]> wrote:
>
> > On 01/21/18 04:48 PM, [hidden email] wrote:
> > > Using Pmdll.exe reports firefox.exe as startable, plugin-containers.exe as can not find
> > > xul.dll in libpath.
> >
> > Try running PMDLL on xul.dll. And as Steve mentioned, sometimes it is a
> > newer version of a DLL needed, eg the SM I built yesterday needs a libc
> > that hasn't been released.
> > Also check popuplog.os2.
> > Dave
>
> I'm having the same problem trying to install FF 45.9.0-2
>
> "Couldn't load xul.dll (os2 error2, faulty module=ICUIN"
>
> I installed Arca Noae Package Manager, updated and filled up my boot drive with
> everything under the sun that it found needing newer versions.  That didn't help
> much.
>
> Last Firefix I've been able to run is 31.  My eCS version is 2.2b2.
>
> I ran pmdll on xul.dll but don't know how to interpret.  It found two red
> things, are these bad?  They are
> MOZALLOC.DLL AND MOZSQLT3.DLL.
>
>

I figured it out, so don't bother explaining pmdll.  Incidentally I ran pmdll on
the wrong xul.dll.  Old one.  Installed firefox 31.8.0 via Warpin to D: and
unzipped firefox 45.9.0-2 on J:.  Thus xul's all over the place.

I'll see if I can find missing dll's.

--
Barbara
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: couldn't load xul.dll

Dave Yeo-3
In reply to this post by Barbara-46
On 01/22/18 02:36 PM, Barbara wrote:
 > On Mon, 22 Jan 2018 01:28:00 UTC, Dave Yeo <[hidden email]> wrote:
 >
 >> On 01/21/18 04:48 PM, [hidden email] wrote:
 >>> Using Pmdll.exe reports firefox.exe as startable,
plugin-containers.exe as can not find
 >>> xul.dll in libpath.
 >> Try running PMDLL on xul.dll. And as Steve mentioned, sometimes it is a
 >> newer version of a DLL needed, eg the SM I built yesterday needs a libc
 >> that hasn't been released.
 >> Also check popuplog.os2.
 >> Dave
 > I'm having the same problem trying to install FF 45.9.0-2
 >
 > "Couldn't load xul.dll (os2 error2, faulty module=ICUIN"

You need libicu, you probably have the older icu package installed. They
can both be installed without conflicts.

 >
 > I installed Arca Noae Package Manager, updated and filled up my boot
drive with
 > everything under the sun that it found needing newer versions.  That
didn't help
 > much.
 >
 > Last Firefix I've been able to run is 31.  My eCS version is 2.2b2.
 >
 > I ran pmdll on xul.dll but don't know how to interpret.  It found two red
 > things, are these bad?  They are
 > MOZALLOC.DLL AND MOZSQLT3.DLL.

This just shows they're not on the LIBPATH, which is correct as Firefox
looks in its program directory for these.
Hopefully the RPM version of Firefox will be released for wider
availability, currently it is just available for Arcaos beta testers.
Dave
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: couldn't load xul.dll

Barbara-46
In reply to this post by os24u
On Mon, 22 Jan 2018 23:52:51 UTC, Dave Yeo <[hidden email]> wrote:

> On 01/22/18 02:36 PM, Barbara wrote:
>  > On Mon, 22 Jan 2018 01:28:00 UTC, Dave Yeo <[hidden email]> wrote:
>  >
>  >> On 01/21/18 04:48 PM, [hidden email] wrote:
>  >>> Using Pmdll.exe reports firefox.exe as startable,
> plugin-containers.exe as can not find
>  >>> xul.dll in libpath.
>  >> Try running PMDLL on xul.dll. And as Steve mentioned, sometimes it is a
>  >> newer version of a DLL needed, eg the SM I built yesterday needs a libc
>  >> that hasn't been released.
>  >> Also check popuplog.os2.
>  >> Dave
>  > I'm having the same problem trying to install FF 45.9.0-2
>  >
>  > "Couldn't load xul.dll (os2 error2, faulty module=ICUIN"
>
> You need libicu, you probably have the older icu package installed. They
> can both be installed without conflicts.
>
>  >
>  > I installed Arca Noae Package Manager, updated and filled up my boot
> drive with
>  > everything under the sun that it found needing newer versions.  That
> didn't help
>  > much.
>  >
>  > Last Firefix I've been able to run is 31.  My eCS version is 2.2b2.
>  >
>  > I ran pmdll on xul.dll but don't know how to interpret.  It found two red
>  > things, are these bad?  They are
>  > MOZALLOC.DLL AND MOZSQLT3.DLL.
>
> This just shows they're not on the LIBPATH, which is correct as Firefox
> looks in its program directory for these.
> Hopefully the RPM version of Firefox will be released for wider
> availability, currently it is just available for Arcaos beta testers.
> Dave



--
Barbara
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2