checksetup.pl reporting "sysread() is deprecated on :utf8 handls at ...Slurp.pm" after upgrading ActivePerl 5.22 to 5.24.

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

checksetup.pl reporting "sysread() is deprecated on :utf8 handls at ...Slurp.pm" after upgrading ActivePerl 5.22 to 5.24.

eirens
Hi, folks.

I upgraded ActiveState ActivePerl from 5.22 to 5.24 today. c:\bugzilla\checksetup.pl gives me this new message now:

...
Checking for            DBD-mysql (v4.001)    ok: found v4.033

sysread() is deprecated on :utf8 handles at C:/Perl64/site/lib/File/Slurp.pm lin
e 225, <DATA> chunk 755.
sysread() is deprecated on :utf8 handles at C:/Perl64/site/lib/File/Slurp.pm lin
e 225, <DATA> chunk 755.
sysread() is deprecated on :utf8 handles at C:/Perl64/site/lib/File/Slurp.pm lin
e 225.
sysread() is deprecated on :utf8 handles at C:/Perl64/site/lib/File/Slurp.pm lin
e 225.
syswrite() is deprecated on :utf8 handles at C:/Perl64/site/lib/File/Slurp.pm li
ne 506.
Removing existing compiled templates...
Precompiling templates...sysread() is deprecated on :utf8 handles at C:/Perl64/s
ite/lib/File/Slurp.pm line 225.
sysread() is deprecated on :utf8 handles at C:/Perl64/site/lib/File/Slurp.pm lin
e 225.
done.
END OF QUOTE

Could someone please tell me more about this? I don't want to go back to 5.22 as I'm trying to keep things fairly up to date on this server. But I don't know how to handle this error.

Thanks for any help.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: checksetup.pl reporting "sysread() is deprecated on :utf8 handls at ...Slurp.pm" after upgrading ActivePerl 5.22 to 5.24.

eirens
Omitted info:

I'm running an non-patched Bugzilla 5.0.3 from git.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: checksetup.pl reporting "sysread() is deprecated on :utf8 handls at ...Slurp.pm" after upgrading ActivePerl 5.22 to 5.24.

eirens
In reply to this post by eirens
And I have the latest version of File-Slurp installed (9999.19). To wit:

Checking for           File-Slurp (v9999.13)  ok: found v9999.19
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: checksetup.pl reporting "sysread() is deprecated on :utf8 handls at ...Slurp.pm" after upgrading ActivePerl 5.22 to 5.24.

eirens
In reply to this post by eirens
Thank you, Mr. Schöning. I'll stick with ActivePerl 5.24 then and just ignore this.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.