checksetup.pl not authenticating with MySQL

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

checksetup.pl not authenticating with MySQL

Justin-8
Hello,

I have MySQL 4.2 running on FreeBSD 5.4 and am trying to install Bugzilla. I
have followed the setup instructions for Bugzilla but for some reason it
can't authenticate with MySQL. I have edited localconfig and added the
password and I have added the correct user, bugs, to MySQL. Here is the
exact error when running checksetup.pl

"DBI connect(';localhost;3306','bugs',...) failed: Access denied for user:
'bugs@localhost' (Using password: YES) at checksetup.pl line 1460 Can't
connect to the mysql database. Is the database installed and running? Do you
have the correct username and password selected in localconfig?"

I have triple checked the username & pass ( is there a way to login to mysql
using the bugs username & pass myself to see if it autheticates?) and Im
sure mysql is up and running as I've used mysql to add the correct user. Do
I need to manualy creat the bugs database before running this? I didn't see
anything about it in the instructions.

Any help is greatly apreciated.

-Justin


_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

RE: checksetup.pl not authenticating with MySQL

Benton, Kevin
4.2?  I don't see 4.1 on the MySQL web site.

---
Kevin Benton
Perl/Bugzilla Developer
Advanced Micro Devices
 
The opinions stated in this communication do not necessarily reflect the
view of Advanced Micro Devices and have not been reviewed by management.
This communication may contain sensitive and/or confidential and/or
proprietary information.  Distribution of such information is strictly
prohibited without prior consent of Advanced Micro Devices.  This
communication is for the intended recipient(s) only.  If you have
received this communication in error, please notify the sender, then
destroy any remaining copies of this communication.
 
 

> -----Original Message-----
> From: [hidden email] [mailto:mozilla-webtools-
> [hidden email]] On Behalf Of Justin
> Sent: Friday, June 24, 2005 12:03 PM
> To: [hidden email]
> Subject: checksetup.pl not authenticating with MySQL
>
> Hello,
>
> I have MySQL 4.2 running on FreeBSD 5.4 and am trying to install
Bugzilla.
> I
> have followed the setup instructions for Bugzilla but for some reason
it
> can't authenticate with MySQL. I have edited localconfig and added the
> password and I have added the correct user, bugs, to MySQL. Here is
the
> exact error when running checksetup.pl
>
> "DBI connect(';localhost;3306','bugs',...) failed: Access denied for
user:
> 'bugs@localhost' (Using password: YES) at checksetup.pl line 1460
Can't
> connect to the mysql database. Is the database installed and running?
Do
> you
> have the correct username and password selected in localconfig?"
>
> I have triple checked the username & pass ( is there a way to login to
> mysql
> using the bugs username & pass myself to see if it autheticates?) and
Im
> sure mysql is up and running as I've used mysql to add the correct
user.
> Do
> I need to manualy creat the bugs database before running this? I
didn't

> see
> anything about it in the instructions.
>
> Any help is greatly apreciated.
>
> -Justin
>
>
> _______________________________________________
> mozilla-webtools mailing list
> [hidden email]
> http://mail.mozilla.org/listinfo/mozilla-webtools



_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: checksetup.pl not authenticating with MySQL

Justin-8
In reply to this post by Justin-8
Actualy it's 4.0.33, sorry I was confused.

"Benton, Kevin" <[hidden email]> wrote in message
news:[hidden email]...

> 4.2?  I don't see 4.1 on the MySQL web site.
>
> ---
> Kevin Benton
> Perl/Bugzilla Developer
> Advanced Micro Devices
>
> The opinions stated in this communication do not necessarily reflect the
> view of Advanced Micro Devices and have not been reviewed by management.
> This communication may contain sensitive and/or confidential and/or
> proprietary information.  Distribution of such information is strictly
> prohibited without prior consent of Advanced Micro Devices.  This
> communication is for the intended recipient(s) only.  If you have
> received this communication in error, please notify the sender, then
> destroy any remaining copies of this communication.
>
>
>
>> -----Original Message-----
>> From: [hidden email] [mailto:mozilla-webtools-
>> [hidden email]] On Behalf Of Justin
>> Sent: Friday, June 24, 2005 12:03 PM
>> To: [hidden email]
>> Subject: checksetup.pl not authenticating with MySQL
>>
>> Hello,
>>
>> I have MySQL 4.2 running on FreeBSD 5.4 and am trying to install
> Bugzilla.
>> I
>> have followed the setup instructions for Bugzilla but for some reason
> it
>> can't authenticate with MySQL. I have edited localconfig and added the
>> password and I have added the correct user, bugs, to MySQL. Here is
> the
>> exact error when running checksetup.pl
>>
>> "DBI connect(';localhost;3306','bugs',...) failed: Access denied for
> user:
>> 'bugs@localhost' (Using password: YES) at checksetup.pl line 1460
> Can't
>> connect to the mysql database. Is the database installed and running?
> Do
>> you
>> have the correct username and password selected in localconfig?"
>>
>> I have triple checked the username & pass ( is there a way to login to
>> mysql
>> using the bugs username & pass myself to see if it autheticates?) and
> Im
>> sure mysql is up and running as I've used mysql to add the correct
> user.
>> Do
>> I need to manualy creat the bugs database before running this? I
> didn't
>> see
>> anything about it in the instructions.
>>
>> Any help is greatly apreciated.
>>
>> -Justin
>>
>>
>> _______________________________________________
>> mozilla-webtools mailing list
>> [hidden email]
>> http://mail.mozilla.org/listinfo/mozilla-webtools
>
>
>


_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

RE: checksetup.pl not authenticating with MySQL

Benton, Kevin
In reply to this post by Justin-8
Justin - you may want to look at the current attachment to bug 297672 at
http://bugzilla.mozilla.org/show_bug.cgi?id=297672
Along with the associated comments...

---
Kevin Benton
Perl/Bugzilla Developer
Advanced Micro Devices
 
The opinions stated in this communication do not necessarily reflect the
view of Advanced Micro Devices and have not been reviewed by management.
This communication may contain sensitive and/or confidential and/or
proprietary information.  Distribution of such information is strictly
prohibited without prior consent of Advanced Micro Devices.  This
communication is for the intended recipient(s) only.  If you have
received this communication in error, please notify the sender, then
destroy any remaining copies of this communication.
 
 

> -----Original Message-----
> From: [hidden email] [mailto:mozilla-webtools-
> [hidden email]] On Behalf Of Justin
> Sent: Friday, June 24, 2005 1:27 PM
> To: [hidden email]
> Subject: Re: checksetup.pl not authenticating with MySQL
>
> Actualy it's 4.0.33, sorry I was confused.
>
> "Benton, Kevin" <[hidden email]> wrote in message
> news:[hidden email]...
> > 4.2?  I don't see 4.1 on the MySQL web site.
> >
> > ---
> > Kevin Benton
> > Perl/Bugzilla Developer
> > Advanced Micro Devices
> >
> > The opinions stated in this communication do not necessarily reflect
the
> > view of Advanced Micro Devices and have not been reviewed by
management.
> > This communication may contain sensitive and/or confidential and/or
> > proprietary information.  Distribution of such information is
strictly

> > prohibited without prior consent of Advanced Micro Devices.  This
> > communication is for the intended recipient(s) only.  If you have
> > received this communication in error, please notify the sender, then
> > destroy any remaining copies of this communication.
> >
> >
> >
> >> -----Original Message-----
> >> From: [hidden email] [mailto:mozilla-webtools-
> >> [hidden email]] On Behalf Of Justin
> >> Sent: Friday, June 24, 2005 12:03 PM
> >> To: [hidden email]
> >> Subject: checksetup.pl not authenticating with MySQL
> >>
> >> Hello,
> >>
> >> I have MySQL 4.2 running on FreeBSD 5.4 and am trying to install
> > Bugzilla.
> >> I
> >> have followed the setup instructions for Bugzilla but for some
reason
> > it
> >> can't authenticate with MySQL. I have edited localconfig and added
the
> >> password and I have added the correct user, bugs, to MySQL. Here is
> > the
> >> exact error when running checksetup.pl
> >>
> >> "DBI connect(';localhost;3306','bugs',...) failed: Access denied
for
> > user:
> >> 'bugs@localhost' (Using password: YES) at checksetup.pl line 1460
> > Can't
> >> connect to the mysql database. Is the database installed and
running?
> > Do
> >> you
> >> have the correct username and password selected in localconfig?"
> >>
> >> I have triple checked the username & pass ( is there a way to login
to
> >> mysql
> >> using the bugs username & pass myself to see if it autheticates?)
and

> > Im
> >> sure mysql is up and running as I've used mysql to add the correct
> > user.
> >> Do
> >> I need to manualy creat the bugs database before running this? I
> > didn't
> >> see
> >> anything about it in the instructions.
> >>
> >> Any help is greatly apreciated.
> >>
> >> -Justin
> >>
> >>
> >> _______________________________________________
> >> mozilla-webtools mailing list
> >> [hidden email]
> >> http://mail.mozilla.org/listinfo/mozilla-webtools
> >
> >
> >
>
>
> _______________________________________________
> mozilla-webtools mailing list
> [hidden email]
> http://mail.mozilla.org/listinfo/mozilla-webtools



_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: checksetup.pl not authenticating with MySQL

Marc Schumann
In reply to this post by Justin-8
Justin,

2005/6/24, Justin <[hidden email]>:

> "DBI connect(';localhost;3306','bugs',...) failed: Access denied for user:
> 'bugs@localhost' (Using password: YES) at checksetup.pl line 1460 Can't
> connect to the mysql database. Is the database installed and running? Do you
> have the correct username and password selected in localconfig?"
>
> I have triple checked the username & pass ( is there a way to login to mysql
> using the bugs username & pass myself to see if it autheticates?) and Im
> sure mysql is up and running as I've used mysql to add the correct user. Do
> I need to manualy creat the bugs database before running this? I didn't see
> anything about it in the instructions.

you're saying you're using MySQL 4.2, so maybe
http://dev.mysql.com/doc/mysql/en/old-client.html applies to you.

   Regards
      Marc

--
http://wurblzap.net/
Bugzilla hosting and professional support

_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools