checksetup.pl fails with a sql error

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

checksetup.pl fails with a sql error

Mike Petersen

I am trying to install Bugzilla and get the same error from multiple versions of Bugzilla. I found the error addressed here:

https://bugzilla.mozilla.org/show_bug.cgi?id=1424043

but no solution was given. I tried each of the Bugzilla versions
Bugzilla 5.0.4
Bugzilla 5.1.2
Bugzilla 4.4.13
And got the same error with different line numbers.

Is there a solution or a workarouond? Maybe a simple sql script to complete the schema creation?

Here is the error output from 4.4.13

DBD::mysql::db do failed: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'groups (
        id      mediumint auto_increment PRIMARY KEY NOT NULL,
        name    varchar(255) N' at line 1 [for Statement "CREATE TABLE groups (
        id      mediumint auto_increment PRIMARY KEY NOT NULL,
        name    varchar(255) NOT NULL,
        description     mediumtext NOT NULL,
        isbuggroup      tinyint NOT NULL,
        userregexp      tinytext DEFAULT '' NOT NULL,
        isactive        tinyint DEFAULT 1 NOT NULL,
        icon_url        tinytext
) ENGINE = InnoDB CHARACTER SET utf8"] at Bugzilla/DB.pm line 808.
        Bugzilla::DB::_bz_add_table_raw(Bugzilla::DB::Mysql=HASH(0x5616b30), "groups", HASH(0xb10cf28)) called at Bugzilla/DB.pm line 767
        Bugzilla::DB::bz_add_table(Bugzilla::DB::Mysql=HASH(0x5616b30), "groups", HASH(0xb10cf28)) called at Bugzilla/DB.pm line 480
        Bugzilla::DB::bz_setup_database(Bugzilla::DB::Mysql=HASH(0x5616b30)) called at Bugzilla/DB/Mysql.pm line 535
        Bugzilla::DB::Mysql::bz_setup_database(Bugzilla::DB::Mysql=HASH(0x5616b30)) called at checksetup.pl line 119

Thanks,  
MIke
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.