attempting to build NSS 3.38 Win10 x64 and VS2017 latest update.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

attempting to build NSS 3.38 Win10 x64 and VS2017 latest update.

Will Barnz
I've also got Cygwin and MinGW(code::Blocks) installed on my system.
I want to target the VS2017 C++ compiler directly.

however when I run the script in the MozillaBuild environment this is what I see:

$ make nss_build_all
expr: syntax error
expr: syntax error
expr: syntax error
mkdir -p ./../nspr/WIN954.0_DBG.OBJ
cd ./../nspr/WIN954.0_DBG.OBJ ; \
        CC=cl CXX=cl sh ../configure \
        --enable-win32-target=WIN95 \
        --with-dist-prefix='$(topsrcdir)/../dist/WIN954.0_DBG.OBJ' \
        --with-dist-includedir='$(topsrcdir)/../dist/WIN954.0_DBG.OBJ/include'
checking build system type... i686-pc-mingw32
checking host system type... i686-pc-mingw32
checking target system type... i686-pc-mingw32
checking for cl... cl
checking for whoami... /c/WINDOWS/System32/whoami
checking whether the C compiler works... no
configure: error: in `/c/nss-3.38/nspr/WIN954.0_DBG.OBJ':
configure: error: C compiler cannot create executables
See `config.log' for more details
make: *** [../nspr/WIN954.0_DBG.OBJ/config.status] Error 77

Any insights?
--
dev-tech-crypto mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-crypto