XULRunner 1.8.1.3 problems with libxpt

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

XULRunner 1.8.1.3 problems with libxpt

mixit
I have downloaded PyXPCOM XRPySample.zip from:
http://developer.mozilla.org/en/docs/Building_XULRunner_with_Python
and OSX XULRunner 1.8.1.3 from:
http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/1.8.1.3/contrib/mac/

When I try to install the sample app using the instructions on:
http://developer.mozilla.org/en/docs/XULRunner_1.8.0.4_Release_Notes
and the quoted command:
/Library/Frameworks/XUL.framework/xulrunner-bin --install-app ~/
Desktop/XRPySample.zip

I get the following error 3 times and a failure to install:
libxpt: bad magic header in input file; found '', expected 'XPCOM
\nTypeLib\r\n\032'

Has 1.8.1.3 changed something in xpt that worked in 1.8.0.4 other than
becoming a Universal build?

Can anyone advise me a way forwards please?

best regards
s

_______________________________________________
dev-embedding mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-embedding
Reply | Threaded
Open this post in threaded view
|

Re: XULRunner 1.8.1.3 problems with libxpt

Mark Finkle
On Jul 20, 9:16 am, mixit <[hidden email]> wrote:

> I have downloaded PyXPCOM XRPySample.zip from:http://developer.mozilla.org/en/docs/Building_XULRunner_with_Python
> and OSX XULRunner 1.8.1.3 from:http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/1.8.1....
>
> When I try to install the sample app using the instructions on:http://developer.mozilla.org/en/docs/XULRunner_1.8.0.4_Release_Notes
> and the quoted command:
> /Library/Frameworks/XUL.framework/xulrunner-bin --install-app ~/
> Desktop/XRPySample.zip
>
> I get the following error 3 times and a failure to install:
> libxpt: bad magic header in input file; found '', expected 'XPCOM
> \nTypeLib\r\n\032'
>
> Has 1.8.1.3 changed something in xpt that worked in 1.8.0.4 other than
> becoming a Universal build?
>
> Can anyone advise me a way forwards please?
>
> best regards
> s

XULRunner 1.8.1.3 has problems running on OSX. Please try using
1.8.1.2pre found here:
http://ftp.mozilla.org/pub/mozilla.org/xulrunner/nightly/contrib/2007-02-02-1.8.1.2pre/

_______________________________________________
dev-embedding mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-embedding
Reply | Threaded
Open this post in threaded view
|

Re: XULRunner 1.8.1.3 problems with libxpt

mixit
On Jul 22, 3:46 am, [hidden email] wrote:

> On Jul 20, 9:16 am, mixit <[hidden email]> wrote:
>
>
>
> > I have downloaded PyXPCOM XRPySample.zip from:http://developer.mozilla.org/en/docs/Building_XULRunner_with_Python
> > and OSX XULRunner 1.8.1.3 from:http://releases.mozilla.org/pub/mozilla.org/xulrunner/releases/1.8.1....
>
> > When I try to install the sample app using the instructions on:http://developer.mozilla.org/en/docs/XULRunner_1.8.0.4_Release_Notes
> > and the quoted command:
> > /Library/Frameworks/XUL.framework/xulrunner-bin --install-app ~/
> > Desktop/XRPySample.zip
>
> > I get the following error 3 times and a failure to install:
> > libxpt: bad magic header in input file; found '', expected 'XPCOM
> > \nTypeLib\r\n\032'
>
> > Has 1.8.1.3 changed something in xpt that worked in 1.8.0.4 other than
> > becoming a Universal build?
>
> > Can anyone advise me a way forwards please?
>
> > best regards
> > s
>
> XULRunner 1.8.1.3 has problems running on OSX. Please try using
> 1.8.1.2pre found here:http://ftp.mozilla.org/pub/mozilla.org/xulrunner/nightly/contrib/2007...
many thanks, mate - I shall go get this immediately.

_______________________________________________
dev-embedding mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-embedding