XForms and XBL: div vs span in content (one works, the other doesn't)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

XForms and XBL: div vs span in content (one works, the other doesn't)

Klotz, Leigh
I've found that I can reliably get custom form controls as described in
http://developer.mozilla.org/en/docs/XForms:Custom_Controls
to work only if the content is an xhtml:div, but not if the content is
an xhtml:span.

If I specify a div for the content in the XBL and then use CSS to style
the XForms element itself as a display:block, then it works as well.

Attached are two examples, span.xhtml showing the sensitivity to
xf|output styling, and div.xhtml showing no problems at all when the XBL
uses div as the container.

I've searched a it about XBL and found a few examples of people using
span (http://webfx.eae.net/dhtml/xblmarquee/implementation.html) so it
looks like it's supposed to work.

I'm hoping from some help here, so I can make inline custom controls
work.

Thank you,
Leigh.

_______________________________________________
dev-tech-xforms mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xforms
Reply | Threaded
Open this post in threaded view
|

Re: XForms and XBL: div vs span in content (one works, the other doesn't)

Aaron Reed
Hey Leigh,

I don't see any attachments.

--Aaron

On Sep 24, 1:03 pm, "Klotz, Leigh" <[hidden email]> wrote:

> I've found that I can reliably get custom form controls as described inhttp://developer.mozilla.org/en/docs/XForms:Custom_Controls
> to work only if the content is an xhtml:div, but not if the content is
> an xhtml:span.
>
> If I specify a div for the content in the XBL and then use CSS to style
> the XForms element itself as a display:block, then it works as well.
>
> Attached are two examples, span.xhtml showing the sensitivity to
> xf|output styling, and div.xhtml showing no problems at all when the XBL
> uses div as the container.
>
> I've searched a it about XBL and found a few examples of people using
> span (http://webfx.eae.net/dhtml/xblmarquee/implementation.html) so it
> looks like it's supposed to work.
>
> I'm hoping from some help here, so I can make inline custom controls
> work.
>
> Thank you,
> Leigh.


_______________________________________________
dev-tech-xforms mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xforms