Using a ".disabled" CSS cue to prevent the deletion of the last node

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Using a ".disabled" CSS cue to prevent the deletion of the last node

gandrewsms
Does the method below of using a ".disabled" CSS cue to prevent the
deletion of the last node of an instance work in the current version of
Mozilla XForms?  It does not appear to work for me, and am not sure
whether it is my bug or this feature is not implemented?  This method is
illustrated in Listing 11 at:  
http://www.ibm.com/developerworks/xml/library/x-xformsrepeats/

<xf:model>
   <xf:bind model="default"
nodeset="instance('inst-rs')/u:table_row[count(instance('inst-rs')/u:table)]"
relevant="false" />
</xf:model>
<style type="text/css">
     @namespace xforms url("http://www.w3.org/2002/xforms");
     xforms|*:disabled { display: none; }
</style>
_______________________________________________
dev-tech-xforms mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xforms
Reply | Threaded
Open this post in threaded view
|

Re: Using a ".disabled" CSS cue to prevent the deletion of the last node

gandrewsms
I indeed had a bug in my XForms XML.  The technique described below
works.  Are there plans to implement the XForms 1.1 way of solving this
problem?

glenn andrews wrote:

> Does the method below of using a ".disabled" CSS cue to prevent the
> deletion of the last node of an instance work in the current version
> of Mozilla XForms?  It does not appear to work for me, and am not sure
> whether it is my bug or this feature is not implemented?  This method
> is illustrated in Listing 11 at:  
> http://www.ibm.com/developerworks/xml/library/x-xformsrepeats/
>
> <xf:model>
>   <xf:bind model="default"
> nodeset="instance('inst-rs')/u:table_row[count(instance('inst-rs')/u:table)]"
> relevant="false" />
> </xf:model>
> <style type="text/css">
>     @namespace xforms url("http://www.w3.org/2002/xforms");
>     xforms|*:disabled { display: none; }
> </style>
>

_______________________________________________
dev-tech-xforms mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xforms
Reply | Threaded
Open this post in threaded view
|

Re: Using a ".disabled" CSS cue to prevent the deletion of the last node

Aaron Reed
In reply to this post by gandrewsms
Hi Glenn,

The XForms 1.1 way to solve this problem?  Give me a section of the 1.1
spec to look at and I'll let you know which bug you should monitor.

Thanks,
--Aaron


glenn andrews wrote:

> I indeed had a bug in my XForms XML.  The technique described below
> works.  Are there plans to implement the XForms 1.1 way of solving this
> problem?
>
> glenn andrews wrote:
>
>> Does the method below of using a ".disabled" CSS cue to prevent the
>> deletion of the last node of an instance work in the current version
>> of Mozilla XForms?  It does not appear to work for me, and am not sure
>> whether it is my bug or this feature is not implemented?  This method
>> is illustrated in Listing 11 at:  
>> http://www.ibm.com/developerworks/xml/library/x-xformsrepeats/
>>
>> <xf:model>
>>   <xf:bind model="default"
>> nodeset="instance('inst-rs')/u:table_row[count(instance('inst-rs')/u:table)]"
>> relevant="false" />
>> </xf:model>
>> <style type="text/css">
>>     @namespace xforms url("http://www.w3.org/2002/xforms");
>>     xforms|*:disabled { display: none; }
>> </style>
>>
>
_______________________________________________
dev-tech-xforms mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xforms
Reply | Threaded
Open this post in threaded view
|

Re: Using a ".disabled" CSS cue to prevent the deletion of the last node

gandrewsms
In reply to this post by gandrewsms
Hi Aaron:

At the link below:

   http://www.ibm.com/developerworks/xml/library/x-xformsrepeats/

Take a look at the paragraph beneath "Listing 11 -- Data with two-deep
nesting". A reference is made:

       ".... there is help on the horizon. The XForms 1.1 specification
will address this and other shortcomings with the insert and delete
actions"

Thanks
Glenn


Aaron Reed wrote:

> Hi Glenn,
>
> The XForms 1.1 way to solve this problem?  Give me a section of the
> 1.1 spec to look at and I'll let you know which bug you should monitor.
>
> Thanks,
> --Aaron
>
>
> glenn andrews wrote:
>  
>
>> I indeed had a bug in my XForms XML.  The technique described below
>> works.  Are there plans to implement the XForms 1.1 way of solving
>> this problem?
>>
>> glenn andrews wrote:
>>
>>  
>>
>>> Does the method below of using a ".disabled" CSS cue to prevent the
>>> deletion of the last node of an instance work in the current version
>>> of Mozilla XForms?  It does not appear to work for me, and am not
>>> sure whether it is my bug or this feature is not implemented?  This
>>> method is illustrated in Listing 11 at:  
>>> http://www.ibm.com/developerworks/xml/library/x-xformsrepeats/
>>>
>>> <xf:model>
>>>  <xf:bind model="default"
>>> nodeset="instance('inst-rs')/u:table_row[count(instance('inst-rs')/u:table)]"
>>> relevant="false" />
>>> </xf:model>
>>> <style type="text/css">
>>>    @namespace xforms url("http://www.w3.org/2002/xforms");
>>>    xforms|*:disabled { display: none; }
>>> </style>
>>>
>>>    
>>
> _______________________________________________
> dev-tech-xforms mailing list
> [hidden email]
> https://lists.mozilla.org/listinfo/dev-tech-xforms
>
>  
>



_______________________________________________
dev-tech-xforms mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-xforms