Using Active Directory as LDAP for Bugzilla 2.8.1

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Using Active Directory as LDAP for Bugzilla 2.8.1

Tony-8
I have successfully built Bugzilla V 2.8.1 on a Windows 2003 server
following the great set of instruction provided by Byron Jones at
http://www.bugzilla.org/docs/win32install.html

Now I'm trying to set it up to use our active directory for
authentication using the instruction at:
http://groups-beta.google.com/group/netscape.public.mozilla.webtools/browse_thread/thread/fa2e09a01a7e9618/75e55cc6b4aabc96?q=LDAP&rnum=7#75e55cc6b4aabc96
and section 2.3.5 of the Bugzilla Guide - 2.18.1 Release.

I'm now getting the following error in my browser:

Can't locate Net/LDAP.pm in @INC (@INC contains: . c:/Perl/lib
c:/Perl/site/lib) at Bugzilla/Auth/LDAP.pm line 36.
BEGIN failed--compilation aborted at Bugzilla/Auth/LDAP.pm line 36.
Compilation failed in require at Bugzilla/Auth.pm line 38.
BEGIN failed--compilation aborted at Bugzilla/Auth.pm line 42.
Compilation failed in require at Bugzilla.pm line 27.
BEGIN failed--compilation aborted at Bugzilla.pm line 27.
Compilation failed in require at CGI.pl line 417.
BEGIN failed--compilation aborted at CGI.pl line 417.

Please help if you can.

Thanks to all for the great documentation :)

_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: Using Active Directory as LDAP for Bugzilla 2.8.1

Tony-8
Sorry I forgot to include my settings from my data/params files:

'LDAPBaseDN' =>
'CN=testuser,CN=Users,DC=edp,DC=dolir,DC=state,DC=mo,DC=us:password
'LDAPbinddn' => 'CN=Users,DC=edp,DC=dolir,DC=state,DC=mo,DC=us',
'LDAPmailattribute' => 'mail',
'LDAPserver' => 'yellowpages.edp.dolir.state.mo.us',
'LDAPuidattribute' => 'sAMAccountName',
'loginmethod' => 'LDAP',

_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: Using Active Directory as LDAP for Bugzilla 2.8.1

Bernd Eckenfels-4
On Wed, Jun 08, 2005 at 06:45:49AM -0700, Tony wrote:
> 'LDAPBaseDN' =>
> 'CN=testuser,CN=Users,DC=edp,DC=dolir,DC=state,DC=mo,DC=us:password
> 'LDAPbinddn' => 'CN=Users,DC=edp,DC=dolir,DC=state,DC=mo,DC=us',

I think you need to reverse those two, however your problem looks more like
a missing perl module.

Gruss
Bernd
--
  (OO)      -- Bernd_Eckenfels@Mörscher_Strasse_8.76185Karlsruhe.de --
 ( .. )      ecki@{inka.de,linux.de,debian.org}  http://www.eckes.org/
  o--o     1024D/E383CD7E  eckes@IRCNet  v:+497211603874  f:+49721151516129
(O____O)  When cryptography is outlawed, bayl bhgynjf jvyy unir cevinpl!
_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools