Unable to access the rest apis of bugzilla

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Unable to access the rest apis of bugzilla

Sujeeth Kamath
Hello experts

I am trying to install and configure bugzilla on windows. the version is
5.0.4

i followed all the steps given here.

https://bugzilla.readthedocs.io/en/5.0/installing/iis.html. I followed all
the steps which are given

everything is working fine and i am able to access the bugzilla. I am able
to create the  bugs.

However where I am facing issue is when i try access the rest webserrvices
i am getting the error " The document is not found or moved". I am not sure
what could be wrong or how i can debug this

Regards,

sujeeth
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Unable to access the rest apis of bugzilla

Sujeeth Kamath
Thanks for the response. I am seeing that the mandatory modules are all
installed. The optional modules are also installed but the checksetup.pl
fials to recognize few of them. I am attaching the screenshot of the
checksetup.pl response. I am successfully able to access , login bugzilla ,
however unable to access any rest.cgi resources

Regards,

sujeeth

On Sat, Jun 23, 2018 at 7:16 AM Thorsten Schöning <[hidden email]>
wrote:

> Guten Tag Sujeeth Kamath,
> am Samstag, 23. Juni 2018 um 05:53 schrieben Sie:
>
> > However where I am facing issue is when i try access the rest
> webserrvices
> > i am getting the error " The document is not found or moved". I am not
> sure
> > what could be wrong or how i can debug this
>
> Make sure that you have all necessary "optional" modules installed so
> that the REST-API can work at all, which is JSON-RPC and Test-Taint.
> Have a look at the output of checksetup.pl.
>
> Additionally, have a look at the access and/or error log of your web
> server and provide some example requests you are doing. Those might
> simply be wrong.
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow
>
> _______________________________________________
> support-bugzilla mailing list
> [hidden email]
> https://lists.mozilla.org/listinfo/support-bugzilla
> PLEASE put [hidden email] in the To: field when you
> reply.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Unable to access the rest apis of bugzilla

Sujeeth Kamath
Hello

Thanks for the response. I moved away from the 5.0.4 version and installed
5.1.1 version. It clearly showed me that the rest webservices are enabled
when I run the checksetup.pl. Now I am able to access the rest webservices

Regards

sujeeth






On Tue, Jun 26, 2018 at 3:05 AM Thorsten Schöning <[hidden email]>
wrote:

> Guten Tag Sujeeth Kamath,
> am Montag, 25. Juni 2018 um 22:17 schrieben Sie:
>
> > The optional modules are also installed but the
> > checksetup.plfials to recognize few of them.
>
> Some of those optional modules are known to not be available for
> Windows, so I doubt you have installed all of them. The ones you need
> for REST seem to be available, though.
>
> > I am attaching the
> > screenshot of the checksetup.plresponse.
>
> Please don't attach screenshots for such things next time, you could
> have easily copied the text itself. That is far better for search
> engines and stuff, more readable and this list normally removes most
> attachments anyway.
>
> > I am successfully able to
> > access , login bugzilla , however unable to access any rest.cgi resources
>
> Did you have a look at your error and access log? You have been asked
> to provide example requests to the API as well.
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow
>
> _______________________________________________
> support-bugzilla mailing list
> [hidden email]
> https://lists.mozilla.org/listinfo/support-bugzilla
> PLEASE put [hidden email] in the To: field when you
> reply.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Unable to access the rest apis of bugzilla

Sujeeth Kamath
hI,

i was mentioning to the following entries which checksetup.pl  shows for
5.1.1 , which I did not see for 5.0.4 kindly see the attached picture
(checksetup.jpg)

I am facing a peculiar issue now. The bugzilla page loads fine. However
when I try to login it throws error that password is invalid. I tried all
the options. when I run the checksetup.pl i passed in the admin user id as
admin and provided a simple password. checksetup.pl completed without any
error. However admin login is failing. I tried installing the db serveral
times but the result is the same.

any help to resolve this will be qppreciated. I am not sure why te rror is
coming

Regards,

sujeeth

On Wed, Jun 27, 2018 at 3:00 AM Thorsten Schöning <[hidden email]>
wrote:

> Guten Tag Sujeeth Kamath,
> am Mittwoch, 27. Juni 2018 um 01:47 schrieben Sie:
>
> > Thanks for the response. I moved away from the 5.0.4 version and
> installed
> > 5.1.1 version.
>
> That is an unstable development version not intended for production
> use, anything can change and gow rong any time.
>
> > It clearly showed me that the rest webservices are enabled
> > when I run the checksetup.pl. Now I am able to access the rest
> webservices
>
> To which lines of checksetup.pl are you referring exactly? Because in
> general the API should work on 5.0 as well, so there might be some
> difference between the new and old installation not related to
> Bugzilla itself.
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow
>
> _______________________________________________
> support-bugzilla mailing list
> [hidden email]
> https://lists.mozilla.org/listinfo/support-bugzilla
> PLEASE put [hidden email] in the To: field when you
> reply.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.