Thebes code is re-compiled during 'make install'

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Thebes code is re-compiled during 'make install'

walt-2
There are also other large sections of code which
are unnecessarily compiled for a second time during
'make install', but it seems to be only thebes which
actually causes me trouble:

I always do the 'make -f client.mk' as an ordinary
user and then do 'make -f client.mk install' as root.

The problem occurs during the *next* build when the
thebes object files are owned by root and can't be
over-written.  This started happening only about a
week or so ago.

Could someone take a look at it?

Thanks!
_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds
Reply | Threaded
Open this post in threaded view
|

Re: Thebes code is re-compiled during 'make install'

Benjamin Smedberg
walt wrote:

> There are also other large sections of code which
> are unnecessarily compiled for a second time during
> 'make install', but it seems to be only thebes which
> actually causes me trouble:
>
> I always do the 'make -f client.mk' as an ordinary
> user and then do 'make -f client.mk install' as root.
>
> The problem occurs during the *next* build when the
> thebes object files are owned by root and can't be
> over-written.  This started happening only about a
> week or so ago.
>
> Could someone take a look at it?

This is not a good forum for bug reports, please file this at
bugzilla.mozilla.org with detailed steps to reproduce (with all the relevant
information like what sources you're using).

--BDS
_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds