Testopia- prerequisites, versions and install as painless as possible-?

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Testopia- prerequisites, versions and install as painless as possible-?

Cindi Adams- QA FDA
Running 3.6.9 going Directly to 4.2.4 Bugzilla.  Interested in Using Testopia (a NEW install).  

1)Does Testopia 2.5 run with Bugzilla 4.2.4 (has it been tested with it yet?).

2) Order of installs,  Bugzilla upgrade first then New Testopia.

3) How do I check if Testopia required Perl Modules are installed:
Additional Perl Modules: Text::CSV XML::Schema Validator XML::Schema::Parser (for importer) and JSON 2.10  (platform Linux 2.6.18-308* & Perl 5.8.8).

4)The latest JSON is 2.53 on http://search.cpan.org/~makamaka/JSON-1.14/.  JSON 2.10 is not listed.  What version is stable with Testopia 2.5?
Use the 2.53 L&G?

5) another page recommends JSON::XS too.
" Testopia 2.0 and above NOW REQUIRES JSON 2.10 You will need to update to the latest version of JSON from CPAN. Also recommended is JSON::XS which will boost performance".  I don't see JSON::XS on the cpan link above. ?

6) What is the best Link to report bugs and enhancement request for Testopia 2.5 ?

7)When was Testopia 2.5 released?  Is 2.6 or 3.0 coming soon?

8) Thank you.  I hope I am in the right place for these questions.
 
_______________________________________________
support-webtools mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-webtools
Reply | Threaded
Open this post in threaded view
|

Re: Testopia- prerequisites, versions and install as painless as possible-?

Gregary Hendricks-2
On Thu, Nov 15, 2012 at 8:41 AM, Cindi Adams- QA FDA <
[hidden email]> wrote:

> Running 3.6.9 going Directly to 4.2.4 Bugzilla.  Interested in Using
> Testopia (a NEW install).
>
> 1)Does Testopia 2.5 run with Bugzilla 4.2.4 (has it been tested with it
> yet?).
>

Yes, is runs with 4.2.x though I have not tested with 4.2.4 specifically.

>
> 2) Order of installs,  Bugzilla upgrade first then New Testopia.
>

Yes, upgrade Bugzilla as you would normally, then install Testopia.


>
> 3) How do I check if Testopia required Perl Modules are installed:
> Additional Perl Modules: Text::CSV XML::Schema Validator
> XML::Schema::Parser (for importer) and JSON 2.10  (platform Linux
> 2.6.18-308* & Perl 5.8.8).
>

After unzipping the Testopia files in the bugzilla install directly, run
checksetup and it will tell you what modules are needed and offer to
install them (same as for Bugzilla)


>
> 4)The latest JSON is 2.53 on http://search.cpan.org/~makamaka/JSON-1.14/.
>  JSON 2.10 is not listed.  What version is stable with Testopia 2.5?
> Use the 2.53 L&G?
>
>
Hmmm, I am not sure what JSON is doing these days. If that is not out
there, the latest JSON should still work hopefully.


> 5) another page recommends JSON::XS too.
> " Testopia 2.0 and above NOW REQUIRES JSON 2.10 You will need to update to
> the latest version of JSON from CPAN. Also recommended is JSON::XS which
> will boost performance".  I don't see JSON::XS on the cpan link above. ?
>
> 6) What is the best Link to report bugs and enhancement request for
> Testopia 2.5 ?
>

Find the Testopia product on http://bugzilla.mozilla.org under "Other
Products"

>
> 7)When was Testopia 2.5 released?  Is 2.6 or 3.0 coming soon?
>

Good question. I have had very limited time to work on it lately. I am
trying to keep it up with each Bugzilla release. I can't promise when a
newer version will be available though.

>
> 8) Thank you.  I hope I am in the right place for these questions.
>

This is the right place. Thanks for posting them.


>
> _______________________________________________
> support-webtools mailing list
> [hidden email]
> https://lists.mozilla.org/listinfo/support-webtools
>
_______________________________________________
support-webtools mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-webtools