SVG Image Element and XBL

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

SVG Image Element and XBL

James A. Overton
    I've seen the impressive samples of SVG+XBL
(http://www.croczilla.com/svg/samples/), and want to use these tools in
a project. However I've run into a snag, which may be a bug. I thought
I'd ask here first.
    I can make most of the SVG elements I need work within an XBL
binding, but the "image" element just isn't showing up. For example,
<binding id="someelement">
        <content>
                <svg:svg height="600px" width="400px">
                        <svg:rect  x="50" y="100" width="150" height="200"/>
                        <svg:image xlink:href="image.jpg" width="300" height="500"/>
                </svg:svg>
        </content>
</binding>
I see the SVG box (the "canvas") and the rectangle, and everything
shows up properly in the DOM inspector, but I don't see an image. The
svg and xlink namespaces have been properly defined. The same SVG code
works for me when it isn't inside an XBL binding. My platform is
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8)
Gecko/20051025 Firefox/1.5
    I'd appreciate any help. Thanks very much,

James

_______________________________________________
Mozilla-svg mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-svg
Reply | Threaded
Open this post in threaded view
|

Re: SVG Image Element and XBL

Boris Zbarsky
James A. Overton wrote:
> <svg:image xlink:href="image.jpg" width="300" height="500"/>

Is your binding in the same directory as the file you're binding to?  If not,
which directory is image.jpg in?

-Boris
_______________________________________________
Mozilla-svg mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-svg