Re: mozilla build showing error

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: mozilla build showing error

internal
On Wednesday, December 14, 2016 at 6:03:34 PM UTC+11, harshit jain wrote:

> I am a newbie and hope to start contributing to mozilla. So, according to instructions on this page https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Windows_Prerequisites I downloaded mozilla build and source code but when I tried to build the source code using mach build it is showing error
>
> $ ./mach build
>  0:02.36 c:\mozilla-build\mozmake\mozmake.EXE -f client.mk -s configure
>  0:08.99 cd c:/mozilla-source/mozilla-central/obj-i686-pc-mingw32
>  0:09.04 c:/mozilla-source/mozilla-central/configure
>  0:09.82 Reexecuting in the virtualenv
>  0:11.08 checking for a shell... C:/mozilla-build/msys/bin/sh.exe
>  0:12.02 checking for host system type... i686-pc-mingw32
>  0:12.02 checking for target system type... i686-pc-mingw32
>  0:12.02 checking whether cross compiling... no
>  0:12.06 checking for the target C compiler...
>  0:12.06 DEBUG: _cc: Trying cl
>  0:12.06 ERROR: GetShortPathName returned a long path name. Are 8dot3 filenames
> disabled?
>  0:12.12 *** Fix above errors and then restart with\
>  0:12.12                "c:/mozilla-build/mozmake/mozmake.EXE -f client.mk build
> "
>  0:12.13 client.mk:375: recipe for target 'configure' failed
>  0:12.13 mozmake.EXE: *** [configure] Error 1
> 2
>
> Please help me to build the code for my machine.
> I am on windows 7, Intel code i3(3rd gen), 4gb RAM, 64 bit operating system.
> My mozconfig file is default, I have not made any change to it.

Hi, did you ever get this working? Could you share how you got it to work?
_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: mozilla build showing error

Gregory Szorc-3
On Fri, Aug 4, 2017 at 10:13 AM, <[hidden email]> wrote:
On Wednesday, December 14, 2016 at 6:03:34 PM UTC+11, harshit jain wrote:
> I am a newbie and hope to start contributing to mozilla. So, according to instructions on this page https://developer.mozilla.org/en-US/docs/Mozilla/Developer_guide/Build_Instructions/Windows_Prerequisites I downloaded mozilla build and source code but when I tried to build the source code using mach build it is showing error
>
> $ ./mach build
>  0:02.36 c:\mozilla-build\mozmake\mozmake.EXE -f client.mk -s configure
>  0:08.99 cd c:/mozilla-source/mozilla-central/obj-i686-pc-mingw32
>  0:09.04 c:/mozilla-source/mozilla-central/configure
>  0:09.82 Reexecuting in the virtualenv
>  0:11.08 checking for a shell... C:/mozilla-build/msys/bin/sh.exe
>  0:12.02 checking for host system type... i686-pc-mingw32
>  0:12.02 checking for target system type... i686-pc-mingw32
>  0:12.02 checking whether cross compiling... no
>  0:12.06 checking for the target C compiler...
>  0:12.06 DEBUG: _cc: Trying cl
>  0:12.06 ERROR: GetShortPathName returned a long path name. Are 8dot3 filenames
> disabled?
>  0:12.12 *** Fix above errors and then restart with\
>  0:12.12                "c:/mozilla-build/mozmake/mozmake.EXE -f client.mk build
> "
>  0:12.13 client.mk:375: recipe for target 'configure' failed
>  0:12.13 mozmake.EXE: *** [configure] Error 1
> 2
>
> Please help me to build the code for my machine.
> I am on windows 7, Intel code i3(3rd gen), 4gb RAM, 64 bit operating system.
> My mozconfig file is default, I have not made any change to it.

Hi, did you ever get this working? Could you share how you got it to work?

The Firefox build system currently requires 8dot3 filename support on Windows. More info at https://bugzilla.mozilla.org/show_bug.cgi?id=1323381.

_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds
Loading...