Re: default skin install css and images not loading in browser

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Re: default skin install css and images not loading in browser

darragh.blake
On Friday, February 5, 2016 at 11:13:38 AM UTC, Scott Bickford wrote:

> I am finishing up  a grueling install on RedHat 7 of Bugzilla 5.0.2.
>
> On the default skin, the css files get ok in the browser, but the images do
> not load in the browse.
>
> On Fiddler, I can see a 200 status code on for example two
> http://mybox/bugzilla/data/assets/2f5735cf3abd04bddc8e363a8613a9f5.css and
> two js files.
>
> There is nothing else after these two gets.
>
> So, some content in one of them is :
>
> #help      { background: url(../../skins/standard/index/help.png)
>
> That file is located in /var/www/html/bugzilla/data/assets
>
> I was thinking of doing a symlink for /var/www/skins, but was wondering if
> there's another way to fix this?  I came across a link for someone else who
> had similar problems, but it was with version 3.
Hello,

I had the same issue on Oracle Linux.

I have solved by the following command

sudo mv /var/www/html/bugzilla/data/assets/.htaccess /var/www/html/bugzilla/data/assets/ORIG_htaccess

sudo systemctl restart httpd


Now all CSS and JS loads.

Regards,
Darragh
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: default skin install css and images not loading in browser

darragh.blake
Hello Thorsten,

Thanks for your response, I have moved checksetup.pl to a different name,
to avoid any accidental executions of that script.

I could see originally it generated the .htaccess file. Now everything
seems fine, I will repost if that status changes.

Cheers,
Darragh

On Thu, Sep 13, 2018 at 1:15 PM, Thorsten Schöning <[hidden email]>
wrote:

> Guten Tag [hidden email],
> am Donnerstag, 13. September 2018 um 13:12 schrieben Sie:
>
> > sudo mv /var/www/html/bugzilla/data/assets/.htaccess
> > /var/www/html/bugzilla/data/assets/ORIG_htaccess
>
> The file you have moved is recreated by checksetup.pl, so depending on
> what your actual problem was, you might have worked around it only
> temporarily. There have been problems in the past with updating
> .htaccess-files, so run checksetup.pl now and see if things still work
> with a newly generated file. If not, you further need to debug your
> problem.
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow
>
>


--
Kind regards,

*Darragh Blake* | Software Development Engineer
ADAPT Centre
O'Reilly Building
Trinity College Dublin
Dublin 2 e: [hidden email]
Ireland www.adaptcentre.ie
<https://twitter.com/adaptcentre>
<https://www.facebook.com/ADAPTCentre?fref=ts>
<https://www.youtube.com/channel/UC9--qVutTtyLyhZCJR7rY5g>
<https://www.linkedin.com/company/adapt-centre>
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: default skin install css and images not loading in browser

darragh.blake
In reply to this post by darragh.blake
On Friday, February 5, 2016 at 11:13:38 AM UTC, Scott Bickford wrote:

> I am finishing up  a grueling install on RedHat 7 of Bugzilla 5.0.2.
>
> On the default skin, the css files get ok in the browser, but the images do
> not load in the browse.
>
> On Fiddler, I can see a 200 status code on for example two
> http://mybox/bugzilla/data/assets/2f5735cf3abd04bddc8e363a8613a9f5.css and
> two js files.
>
> There is nothing else after these two gets.
>
> So, some content in one of them is :
>
> #help      { background: url(../../skins/standard/index/help.png)
>
> That file is located in /var/www/html/bugzilla/data/assets
>
> I was thinking of doing a symlink for /var/www/skins, but was wondering if
> there's another way to fix this?  I came across a link for someone else who
> had similar problems, but it was with version 3.

Hello Thorsten,

Thanks for your response, I have moved checksetup.pl to a different name, to avoid any accidental executions of that script.

I could see originally it generated the .htaccess file. Now everything seems fine, I will repost if that status changes.

Cheers,
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: default skin install css and images not loading in browser

darragh.blake
Hello,

Its only running on an internal machine on a private network, I wont
require updates. I only need Bugzilla for a couple of weeks, hence when I
am not spending time troubleshooting the bug.

Cheers,
Darragh

On Thu, Sep 13, 2018 at 1:52 PM, Thorsten Schöning <[hidden email]>
wrote:

> Guten Tag [hidden email],
> am Donnerstag, 13. September 2018 um 14:23 schrieben Sie:
>
> > Thanks for your response, I have moved checksetup.pl to a different
> > name, to avoid any accidental executions of that script.
>
> Which is the wrong thing to do, because you are simply breaking
> your Bugzilla further: Your renamed .htaccess e.g. cared about
> security of that folder by disabling directory listings, which might
> or might not be the case anymore. Additionally, checksetup.pl itself
> is needed in case of template customizations, adding extensions and
> for upgrades. So unless you plan to not fix any security bugs anymore,
> you are going to execute it anyway and might or might not remember the
> problem with the .htaccess at that time.
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow
>
>


--
Kind regards,

*Darragh Blake* | Software Development Engineer
ADAPT Centre
O'Reilly Building
Trinity College Dublin
Dublin 2 e: [hidden email]
Ireland www.adaptcentre.ie
<https://twitter.com/adaptcentre>
<https://www.facebook.com/ADAPTCentre?fref=ts>
<https://www.youtube.com/channel/UC9--qVutTtyLyhZCJR7rY5g>
<https://www.linkedin.com/company/adapt-centre>
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.