Proposal: Bump the minimum version of node to 8.12.0 and npm to 6.4.1

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Proposal: Bump the minimum version of node to 8.12.0 and npm to 6.4.1

Mark Banner-4
I'd like to bump the minimum version of node to 8.12.0 (from 8.11.0) and
npm to 6.4.1 (from 5.6.0).

The reason is that we are seeing occasional issues when we update our
in-tree ESLint versions that mean that especially Windows users can get
into a broken state and need to remove the node_modules directory before
continuing.

npm version 6.x has support for the `npm ci` command which automatically
removes node_modules and installs to match with `package-lock.json`.

At the moment, if we detect > 6.x, then we automatically use the `npm
ci` command. However, most installs have just 5.6.0, so I'd like to bump
both the version downloaded to .mozbuild, and the minimum requirement.

At some stage we should consider node 10 (the current LTS), but we may
want to do a review of Linux distributions to see how it affects them.

If there's any feedback, please respond here or direct to me. If I've
not heard anything in a week or so, I'll start making it happen.

Mark

_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds
Reply | Threaded
Open this post in threaded view
|

Re: Proposal: Bump the minimum version of node to 8.12.0 and npm to 6.4.1

Nicholas Alexander


On Wed, Apr 17, 2019 at 6:54 AM Mark Banner <[hidden email]> wrote:
I'd like to bump the minimum version of node to 8.12.0 (from 8.11.0) and
npm to 6.4.1 (from 5.6.0).

The reason is that we are seeing occasional issues when we update our
in-tree ESLint versions that mean that especially Windows users can get
into a broken state and need to remove the node_modules directory before
continuing.

npm version 6.x has support for the `npm ci` command which automatically
removes node_modules and installs to match with `package-lock.json`.

At the moment, if we detect > 6.x, then we automatically use the `npm
ci` command. However, most installs have just 5.6.0, so I'd like to bump
both the version downloaded to .mozbuild, and the minimum requirement.

At some stage we should consider node 10 (the current LTS), but we may
want to do a review of Linux distributions to see how it affects them.

If there's any feedback, please respond here or direct to me. If I've
not heard anything in a week or so, I'll start making it happen.

As somebody who is trying to add new things that look like `npm ci` in the happy case and have to do the same machinations as ESLint does in the unhappy case, I'm all for bumping our minimum version of NPM.

The thing I worry about is releasing a new MozillaBuild version.  Is that easy?  (I hope the answer is yes.)

Thanks for driving this!
Nick

_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds
Reply | Threaded
Open this post in threaded view
|

Re: Proposal: Bump the minimum version of node to 8.12.0 and npm to 6.4.1

Mike Hommey
In reply to this post by Mark Banner-4
On Wed, Apr 17, 2019 at 02:54:25PM +0100, Mark Banner wrote:

> I'd like to bump the minimum version of node to 8.12.0 (from 8.11.0) and npm
> to 6.4.1 (from 5.6.0).
>
> The reason is that we are seeing occasional issues when we update our
> in-tree ESLint versions that mean that especially Windows users can get into
> a broken state and need to remove the node_modules directory before
> continuing.
>
> npm version 6.x has support for the `npm ci` command which automatically
> removes node_modules and installs to match with `package-lock.json`.
>
> At the moment, if we detect > 6.x, then we automatically use the `npm ci`
> command. However, most installs have just 5.6.0, so I'd like to bump both
> the version downloaded to .mozbuild, and the minimum requirement.
>
> At some stage we should consider node 10 (the current LTS), but we may want
> to do a review of Linux distributions to see how it affects them.

Bumping to 8.12 instead of 8.11 already would affect Linux
distributions. But there are two detached things that require node: the
build, and developer workflow things (like eslint). Is there really a
need to bump the version for the former or is it only needed for the
latter?

Mike
_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds
Reply | Threaded
Open this post in threaded view
|

Re: Proposal: Bump the minimum version of node to 8.12.0 and npm to 6.4.1

Dan Mosedale-4
In reply to this post by Nicholas Alexander
On Wednesday, April 17, 2019 at 9:30:18 AM UTC-7, Nicholas Alexander wrote:

> On Wed, Apr 17, 2019 at 6:54 AM Mark Banner <[hidden email]> wrote:
>
>> At the moment, if we detect > 6.x, then we automatically use the `npm
>> ci` command. However, most installs have just 5.6.0, so I'd like to bump
>> both the version downloaded to .mozbuild, and the minimum requirement.
>
> As somebody who is trying to add new things that look like `npm ci` in the happy case and have to do the same machinations as ESLint does in the unhappy case, I'm all for bumping our minimum version of NPM.
>
>
> The thing I worry about is releasing a new MozillaBuild version.  Is that easy?  (I hope the answer is yes.)

npm and node don't come from MozillaBuild (they come from .mozbuild, having been placed there by "mach bootstrap"), so it's not clear to me what the intent of this question is... Am I missing something?

Dan
_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds
Reply | Threaded
Open this post in threaded view
|

Re: Proposal: Bump the minimum version of node to 8.12.0 and npm to 6.4.1

Nicholas Alexander


On Tue, Apr 30, 2019 at 8:30 AM <[hidden email]> wrote:
On Wednesday, April 17, 2019 at 9:30:18 AM UTC-7, Nicholas Alexander wrote:
> On Wed, Apr 17, 2019 at 6:54 AM Mark Banner <[hidden email]> wrote:
>
>> At the moment, if we detect > 6.x, then we automatically use the `npm
>> ci` command. However, most installs have just 5.6.0, so I'd like to bump
>> both the version downloaded to .mozbuild, and the minimum requirement.
>
> As somebody who is trying to add new things that look like `npm ci` in the happy case and have to do the same machinations as ESLint does in the unhappy case, I'm all for bumping our minimum version of NPM.
>
>
> The thing I worry about is releasing a new MozillaBuild version.  Is that easy?  (I hope the answer is yes.)

npm and node don't come from MozillaBuild (they come from .mozbuild, having been placed there by "mach bootstrap"), so it's not clear to me what the intent of this question is... Am I missing something?

Is that true?  On my Windows box, I thought I got them with MozillaBuild... but now I see https://hg.mozilla.org/mozilla-build/rev/9ff8fbbd3d90c177a6c6754c8f7329ff418c819a removing them from MozillaBuild.  So you are not missing something but instead I was missing something.  Roll on!

Nick


_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds