Problems with mySQL database connection

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with mySQL database connection

Fabio Batalha C Santos
Hi everybody,

I'm having problems to do the connection with mysql works.
I always receive this message when I do run the checksetup.pl

Checking perl modules ...
Checking for       AppConfig (v1.52)   ok: found v1.52
Checking for             CGI (v2.93)   ok: found v3.04
Checking for    Data::Dumper (any)     ok: found v2.121
Checking for    Date::Format (v2.21)   ok: found v2.22
Checking for             DBI (v1.36)   ok: found v1.43
Checking for      DBD::mysql (v2.1010) ok: found v2.9002
Checking for      File::Spec (v0.82)   ok: found v0.87
Checking for      File::Temp (any)     ok: found v0.14
Checking for        Template (v2.08)   ok: found v2.13
Checking for      Text::Wrap (v2001.0131) ok: found v2001.09291

The following Perl modules are optional:
Checking for              GD (v1.20)   ok: found v2.07
Checking for     Chart::Base (v1.0)    ok: found v2.3
Checking for     XML::Parser (any)     ok: found v2.34
Checking for       GD::Graph (any)     ok: found v1.43
Checking for GD::Text::Align (any)     ok: found v1.18
Checking for     PatchReader (any)     ok: found v0.9.5

Most ActivePerl modules are available at Apache's ppm repository.
A list of mirrors is available at
    http://www.apache.org/dyn/closer.cgi/perl/win32-bin/ppms/
You can add the repository with the following command:
    ppm rep add apache http://www.apache.org/dist/perl/win32-bin/ppms/

Checking user setup ...
Removing existing compiled templates ...
Precompiling templates ...
DBI connect(';localhost;3306','bugs',...) failed: Client does not support
authentication protoco
Can't connect to the mysql database. Is the database installed and
up and running?  Do you have the correct username and password selected in
localconfig?


I already customized the localconfig file and create the database bugs in
mySQL.


_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: Problems with mySQL database connection

byron jones
> DBI connect(';localhost;3306','bugs',...) failed: Client does not support
> authentication protoco

http://www.bugzilla.org/docs/tip/html/trbl-passwd-encryption.html

begin-base64 644 signature.gif
R0lGODlhbQAHAIAAAABPo////ywAAAAAbQAHAAACfAxuGAnch+Bibkn7FL1p
XgVl4Ig1jjlZRoqybgun2Cur5uOunq7u/Ipq7WIyIc7XG9JquEgumPzdlhTf
h0O83kDJaXEm8mRHwXKJy5sac7qYOpT+gtv0n+0ujQOfdqh16caWt0foBViH
N1PRMXimiLUGt3ElVimlgbllWAAAOw==
====

_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: Problems with mySQL database connection

A. Karl Kornel
In reply to this post by Fabio Batalha C Santos
In article <d849dc$[hidden email]>,
 "Fabio Batalha C Santos" <[hidden email]> wrote:

> <<<snip>>>
> DBI connect(';localhost;3306','bugs',...) failed: Client does not support
> authentication protoco
> Can't connect to the mysql database. Is the database installed and
> up and running?  Do you have the correct username and password selected in
> localconfig?
>
>
> I already customized the localconfig file and create the database bugs in
> mySQL.

   Did you already change the admin password to the old password format?  
Head over to <http://www.bugzilla.org/docs/win32install.html>, search
for "OLD_PASSWORD" (without quotes), and tell me if that fixes the
problem.

   Good luck!
--
=============================
|   Alfred Karl Kornel
|   -- [hidden email]
|   Member- Europa Research Group
|   UNIX / RESOLVE Consultant
=============================

----== Posted via Newsfeeds.Com - Unlimited-Uncensored-Secure Usenet News==----
http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
----= East and West-Coast Server Farms - Total Privacy via Encryption =----
_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: Problems with mySQL database connection

Fabio Batalha C Santos
In reply to this post by Fabio Batalha C Santos
Now the problem is another, everything runs ok until I try to call the URL
to run the bugzilla first page.
This error occurs:

-------------------------
Internal Server Error
The server encountered an internal error or misconfiguration and was unable
to complete your request.
Please contact the server administrator, [hidden email] and inform them of
the time the error occurred, and anything you might have done that may have
caused the error.
More information about this error may be available in the server error log.
Apache/1.3.29 Server at fir-fabio Port 8040
-----------------------------

I think, I don?t have permission to run cgi files. The Bugzilla was setup on
Apache httpd.conf with this lines above.

#----------------------------#
# BUGZILLA                      #
#----------------------------#
Listen 127.0.0.1:8040
<VirtualHost 127.0.0.1:8040>
    ServerAdmin [hidden email]
    DocumentRoot "C:/bugzilla/"
    ErrorLog "logs/bvssp-error_log"
    CustomLog "logs/bvssp-access_log" common
    <Directory "C:/bugzilla">
        AllowOverride None
        Options All
        Order deny,allow
        Allow from all
    </Directory>
    DirectoryIndex index.html index.htm index.php
    ScriptAlias /cgi-bin/ "C:/bugzilla/"
    <Directory "C:/bugzilla">
 AddHandler cgi-script .cgi
 Options +Indexes +ExecCGI +FollowSymLinks
 DirectoryIndex index.cgi
 AllowOverride Limit
    </Directory>
</VirtualHost>


"Fabio Batalha C Santos" <[hidden email]> wrote in message
news:d849dc$[hidden email]...

> Hi everybody,
>
> I'm having problems to do the connection with mysql works.
> I always receive this message when I do run the checksetup.pl
>
> Checking perl modules ...
> Checking for       AppConfig (v1.52)   ok: found v1.52
> Checking for             CGI (v2.93)   ok: found v3.04
> Checking for    Data::Dumper (any)     ok: found v2.121
> Checking for    Date::Format (v2.21)   ok: found v2.22
> Checking for             DBI (v1.36)   ok: found v1.43
> Checking for      DBD::mysql (v2.1010) ok: found v2.9002
> Checking for      File::Spec (v0.82)   ok: found v0.87
> Checking for      File::Temp (any)     ok: found v0.14
> Checking for        Template (v2.08)   ok: found v2.13
> Checking for      Text::Wrap (v2001.0131) ok: found v2001.09291
>
> The following Perl modules are optional:
> Checking for              GD (v1.20)   ok: found v2.07
> Checking for     Chart::Base (v1.0)    ok: found v2.3
> Checking for     XML::Parser (any)     ok: found v2.34
> Checking for       GD::Graph (any)     ok: found v1.43
> Checking for GD::Text::Align (any)     ok: found v1.18
> Checking for     PatchReader (any)     ok: found v0.9.5
>
> Most ActivePerl modules are available at Apache's ppm repository.
> A list of mirrors is available at
>     http://www.apache.org/dyn/closer.cgi/perl/win32-bin/ppms/
> You can add the repository with the following command:
>     ppm rep add apache http://www.apache.org/dist/perl/win32-bin/ppms/
>
> Checking user setup ...
> Removing existing compiled templates ...
> Precompiling templates ...
> DBI connect(';localhost;3306','bugs',...) failed: Client does not support
> authentication protoco
> Can't connect to the mysql database. Is the database installed and
> up and running?  Do you have the correct username and password selected in
> localconfig?
>
>
> I already customized the localconfig file and create the database bugs in
> mySQL.
>
>


_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: Problems with mySQL database connection

A. Karl Kornel
In article <d84nhf$[hidden email]>,
 "Fabio Batalha C Santos" <[hidden email]> wrote:

> Now the problem is another, everything runs ok until I try to call the URL
> to run the bugzilla first page.
> This error occurs:
>
> -------------------------
> Internal Server Error
> The server encountered an internal error or misconfiguration and was unable
> to complete your request.
> Please contact the server administrator, [hidden email] and inform them of
> the time the error occurred, and anything you might have done that may have
> caused the error.
> More information about this error may be available in the server error log.
> Apache/1.3.29 Server at fir-fabio Port 8040
> -----------------------------

   Can you take a look at the error logs and tell me what entries appear
in the log when this message appears?

>
> #----------------------------#
> # BUGZILLA                      #
> #----------------------------#
> Listen 127.0.0.1:8040
> <VirtualHost 127.0.0.1:8040>
>     ServerAdmin [hidden email]
>     DocumentRoot "C:/bugzilla/"
>     ErrorLog "logs/bvssp-error_log"
>     CustomLog "logs/bvssp-access_log" common
>     <Directory "C:/bugzilla">
>         AllowOverride None
>         Options All
>         Order deny,allow
>         Allow from all
>     </Directory>
>     DirectoryIndex index.html index.htm index.php
>     ScriptAlias /cgi-bin/ "C:/bugzilla/"
>     <Directory "C:/bugzilla">
>  AddHandler cgi-script .cgi
>  Options +Indexes +ExecCGI +FollowSymLinks
>  DirectoryIndex index.cgi
>  AllowOverride Limit
>     </Directory>
> </VirtualHost>
>
> <<<snip>>>

   You have two <Directory> blocks that refer to the same thing; you can
probably combine them into one.

   Thanks!
--
=============================
|   Alfred Karl Kornel
|   -- [hidden email]
|   Member- Europa Research Group
|   UNIX / RESOLVE Consultant
=============================

----== Posted via Newsfeeds.Com - Unlimited-Uncensored-Secure Usenet News==----
http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
----= East and West-Coast Server Farms - Total Privacy via Encryption =----
_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Problems with mySQL database connection

vrayudu
In reply to this post by Fabio Batalha C Santos
Hi All,
Can any one tell me how to solve this problem????

DBI connect('host=localhost;database=bugs;port=3306','bugs',...) failed:
Can't connect to local MySQL server through socket
'/var/lib/mysql/mysql.sock' (2) at
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/DBI.pm line 609
        DBI::__ANON__('undef', 'undef') called at
/usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi/DBI.pm line 666
        DBI::connect('DBI', 'DBI:mysql:host=localhost;database=bugs;port=3306', '',
'', 'HASH(0x9ee0f98)') called at Bugzilla/DB.pm line 146
        Bugzilla::DB::_connect('DBI:mysql:host=localhost;database=bugs;port=3306')
called at Bugzilla/DB.pm line 138
        Bugzilla::DB::connect_main() called at Bugzilla.pm line 143
        Bugzilla::dbh('Bugzilla') called at Bugzilla/DB.pm line 60
        Bugzilla::DB::SendSQL('SELECT 1 FROM group_control_map WHERE entry != 0
LIMIT 1') called at globals.pl line 447
        main::AnyEntryGroups() called at /var/www/html/bugzilla/enter_bug.cgi line
60
 at Bugzilla/DB.pm line 146


Thanks in Advance,
Vijay Rayudu.


_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

RE: Problems with mySQL database connection

vrayudu
Hi All,

I got this error after running. /checksetup.pl,

Precompiling templates ...
DBI connect(';localhost;3306','bugs',...) failed: Can't connect to local
MySQL server through socket '/var/lib/mysql/mysql.sock' (2) at
./checksetup.pl line 1460
Can't connect to the mysql database. Is the database installed and
up and running?  Do you have the correct username and password selected in
localconfig?



If I have to run mysql database  how to run the database server on linux
machine.

Tomorrow I have to setup my bugzill...please help. Any  URL  shows how to
solve this problem would be fine.

Regards,
Vijay.


_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

RE: Problems with mySQL database connection

Igor Sereda
In reply to this post by Fabio Batalha C Santos
Hello Vijay,

> Can't connect to the mysql database. Is the database installed and
> up and running?  Do you have the correct username and password
> selected in
> localconfig?
> If I have to run mysql database  how to run the database server on
> linux machine.

You might want to check

http://dev.mysql.com/doc/mysql/en/installing.html  -  that's about how to
install mySQL;

http://www.bugzilla.org/docs/tip/html/installing-bugzilla.html - Bugzilla
installation guide.

Yes, you have to have mySQL ready when you install Bugzilla.

Good luck.

Best regards,
Igor

---------------------------
Igor Sereda
http://deskzilla.com
Bugzilla Desktop Client
---------------------------


_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

RE: Problems with mySQL database connection

hobbitmage
In reply to this post by vrayudu


Hi Fabio,

find / -name mysql -print will give you all of the directories/files named
mysql.

in something similar to /usr/local/mysql/bin you'll find either safe_mysql
or mysql_safe.  This is a shell script which will start mysql.  Yes, you
need to run mysql for bugzilla to work.

Regards,

Marc

ps. I hope you're on linux or unix, because I have no idea how to make it
work under windows.

<br><br><br>&gt;From: &quot;Vijay Rayudu&quot;
&lt;[hidden email]&gt;<br>&gt;To: &quot;Fabio Batalha C Santos&quot;
&lt;[hidden email]&gt;,  
&lt;[hidden email]&gt;<br>&gt;Subject: RE: Problems with mySQL
database connection<br>&gt;Date: Tue, 14 Jun 2005 20:40:29
+0530<br>&gt;<br>&gt;Hi All,<br>&gt;<br>&gt;I got this error after running.
/checksetup.pl,<br>&gt;<br>&gt;Precompiling templates ...<br>&gt;DBI
connect(';localhost;3306','bugs',...) failed: Can't connect to
local<br>&gt;MySQL server through socket '/var/lib/mysql/mysql.sock' (2)
at<br>&gt;./checksetup.pl line 1460<br>&gt;Can't connect to the mysql
database. Is the database installed and<br>&gt;up and running?  Do you have
the correct username and password selected
in<br>&gt;localconfig?<br>&gt;<br>&gt;<br>&gt;<br>&gt;If I have to run mysql
database  how to run the database server on
linux<br>&gt;machine.<br>&gt;<br>&gt;Tomorrow I have to setup my
bugzill...please help. Any  URL  shows how to<br>&gt;solve this problem
would be
fine.<br>&gt;<br>&gt;Regards,<br>&gt;Vijay.<br>&gt;<br>&gt;<br>&gt;_______________________________________________<br>&gt;mozilla-webtools
mailing
list<br>&gt;[hidden email]<br>&gt;http://mail.mozilla.org/listinfo/mozilla-webtools<br>


_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools