Problem building on OS X

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem building on OS X

Richard-70
I'm getting the following error when I try to build on the mac, I have the
latest version of glib2, libidl,etc from darwinports

dyld: Library not loaded: /opt/local/lib/libglib-2.0.0.dylib

  Referenced from: /opt/local/lib/libIDL-2.0.dylib

  Reason: Incompatible library version: libIDL-2.0.dylib requires version
1001.0


Thanks,
--Richard


_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds
Reply | Threaded
Open this post in threaded view
|

Re: Problem building on OS X

steve lu
Richard wrote:

> I'm getting the following error when I try to build on the mac, I have the
> latest version of glib2, libidl,etc from darwinports
>
> dyld: Library not loaded: /opt/local/lib/libglib-2.0.0.dylib
>
>   Referenced from: /opt/local/lib/libIDL-2.0.dylib
>
>   Reason: Incompatible library version: libIDL-2.0.dylib requires version
> 1001.0
>
>
> Thanks,
> --Richard
>
>
> _______________________________________________
> dev-builds mailing list
> [hidden email]
> https://lists.mozilla.org/listinfo/dev-builds
>
>
>  
I had the similar issue...
Then it went away when I built it with the super_user_id who
downloaded/installed those libraries.
Also make sure you user "sudo make" not just "make".

Steve

_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds