Problem Building - contents.rdf doesn't exist

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem Building - contents.rdf doesn't exist

gettier
I have the latest from the 1.0.7 version of mozilla, and am trying to
run make -f client.mk build.  I am on Win 2003 server with the Dev
Studio 6.0 SP5

Here are my options:

mk_add_options MOZ_CO_PROJECT=browser
ac_add_options --enable-application=browser
mk_add_options MOZ_OBJDIR=$TOPSRCDIR/Objects

Here is the error I am getting:

make[4]: Entering directory
`/cygdrive/c/mozilla/Objects/netwerk/resources'
+++ making chrome /cygdrive/c/mozilla/Objects/netwerk/resources  =>
../../dist/bin/chrome/comm.jar
+++ adding chrome ../../dist/bin/chrome/installed-chrome.txt
+++
content,install,url,jar:resource:/chrome/comm.jar!/content/necko/
        zip warning: ../comm.jar not found or empty
  adding: content/necko/redirect_loop.xul (stored 0%)
+++ overriding content/necko/contents.rdf
  adding: content/necko/contents.rdf (stored 0%)
+++ making chrome /cygdrive/c/mozilla/Objects/netwerk/resources  =>
../../dist/bin/chrome/en-US.jar
error: file
'/cygdrive/c/mozilla/toolkit/locales/en-US/chrome/necko/contents.rdf'
doesn't exist at /cygdrive/c/mozilla/config/make-jars.pl line 418,
<STDIN> line 9.
make[4]: *** [libs] Error 2
make[4]: Leaving directory
`/cygdrive/c/mozilla/Objects/netwerk/resources'
make[3]: *** [libs] Error 2
make[3]: Leaving directory `/cygdrive/c/mozilla/Objects/netwerk'
make[2]: *** [tier_9] Error 2
make[2]: Leaving directory `/cygdrive/c/mozilla/Objects'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/cygdrive/c/mozilla/Objects'
make: *** [build] Error 2


_______________________________________________
mozilla-builds mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-builds
Reply | Threaded
Open this post in threaded view
|

Re: Problem Building - contents.rdf doesn't exist

Benjamin Smedberg
Al Gettier wrote:
> I have the latest from the 1.0.7 version of mozilla, and am trying to
> run make -f client.mk build.  I am on Win 2003 server with the Dev
> Studio 6.0 SP5
>
> Here are my options:
>
> mk_add_options MOZ_CO_PROJECT=browser
> ac_add_options --enable-application=browser
> mk_add_options MOZ_OBJDIR=$TOPSRCDIR/Objects

Please read the build FAQ at
http://developer.mozilla.org/en/docs/Mozilla_Build_FAQ

You must source the browser/config/mozconfig file from your own mozconfig to
get the proper configuration.

--BDS
_______________________________________________
mozilla-builds mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-builds