Package libreswan fails on mips and mipsel due to undefined ABI

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Package libreswan fails on mips and mipsel due to undefined ABI

Radovan Birdic
Hi,

Package libreswan fails on Debian for mips32 architectures(mips and
mipsel) with an error:

 > In file included from /usr/include/nspr/prtypes.h:26:0,
 >                  from /usr/include/nss/seccomon.h:17,
 >                  from /usr/include/nss/nss.h:34,
 >                  from /«PKGBUILDDIR»/lib/libswan/base64_rsa_pubkey.c:21:
 > /usr/include/nspr/prcpucfg.h:511:18: error: "_ABI64" is not defined
[-Werror=undef]
 >  #if _MIPS_SIM == _ABI64

This issue can be resolved with appropriate changes in nspr package.
I proposed a solution for this on Debian:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=854472

Could you please take a look?

Regards,
Radovan

_______________________________________________
dev-tech-nspr mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-nspr