Missing an inline graphics if I forward it (without composing HTML message): A feature or a bug?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing an inline graphics if I forward it (without composing HTML message): A feature or a bug?

ISHIKAWA,chiaki
I experienced this scenario.

Someone sent me an e-mail with an inline graphics.

I forward it to somebody else thinking that inline graphics will remain
intact. Unfortunately, I did not enable HTML mail composition.
The inline graphics is gone while other text blocks were present at
least character wise.

So the recipient did not receive the graphics.
Which caused us a lost day.


I checked that if I enabled the HTML composition the forward e-mail
correctly contains the inline graphics.

My problem was amplified since I enabled HTML composition in general but
for this particular user, I disabled the HTML composition (i.e.,
specified TEXT format in address book).
So, for other e-mail receivers, I did not experience this missing inline
graphics issue often,
and only yesterday I was made aware of this subtle issue.

What do people think of this?

Is this a feature or a bug?

It would be great if TB can warn the user with a big red flag that
you are missing the inline graphics in the forwarded e-mail when you do
not enable the HTML e-mail composition, or better still
replaces the inline graphics with, say, "graphics aaabbbcccdddeee was
here" and attach the graphics file as an attachment after warning the
user as in "Inline graphics was (were) found, and replaced with
filenames of the attachments.", etc.

TIA

_______________________________________________
dev-apps-thunderbird mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-thunderbird
Reply | Threaded
Open this post in threaded view
|

Re: Missing an inline graphics if I forward it (without composing HTML message): A feature or a bug?

Jörg Knobloch
On 09/06/2017 20:56, ISHIKAWA,chiaki wrote:
> Is this a feature or a bug?

First we need to understand what the problem is.

If you do a plain text forward you'll get a plain text composition and
you'll see that the picture is missing. In fact, it gets replaced by its
alt text.

If you do a HTML forward, then the picture will be included, but you're
saying that the reply was downgraded to plain text since the recipient
was set to plain text in the address book.

That can happen and there's been a lot of work invested in this issue
here: https://bugzilla.mozilla.org/show_bug.cgi?id=1222176. In the end
the bug didn't go ahead.

Jörg.

_______________________________________________
dev-apps-thunderbird mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-thunderbird
Reply | Threaded
Open this post in threaded view
|

Re: Missing an inline graphics if I forward it (without composing HTML message): A feature or a bug?

ISHIKAWA,chiaki
On 2017/06/10 5:32, Jörg Knobloch wrote:

> On 09/06/2017 20:56, ISHIKAWA,chiaki wrote:
>> Is this a feature or a bug?
>
> First we need to understand what the problem is.
>
> If you do a plain text forward you'll get a plain text composition and
> you'll see that the picture is missing. In fact, it gets replaced by its
> alt text.
>
> If you do a HTML forward, then the picture will be included, but you're
> saying that the reply was downgraded to plain text since the recipient
> was set to plain text in the address book.
>
> That can happen and there's been a lot of work invested in this issue
> here: https://bugzilla.mozilla.org/show_bug.cgi?id=1222176. In the end
> the bug didn't go ahead.
>
> Jörg.
>

Thank you. I will take a look at
https://bugzilla.mozilla.org/show_bug.cgi?id=1222176

Maybe a next target of patch submission.

I wish we can spend time on "feature improvement" instead of being
clueless regarding build bustage :-(


_______________________________________________
dev-apps-thunderbird mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-thunderbird
Reply | Threaded
Open this post in threaded view
|

Re: Missing an inline graphics if I forward it (without composing HTML message): A feature or a bug?

ISHIKAWA,chiaki
In reply to this post by Jörg Knobloch
On 2017年06月10日 11:07, ISHIKAWA,chiaki wrote:
> On 2017/06/10 5:32, Jörg Knobloch wrote:
>> On 09/06/2017 20:56, ISHIKAWA,chiaki wrote:
>>> Is this a feature or a bug?
>>
>> First we need to understand what the problem is.

Basically, I want TB to warn the user if the user tries to forward a message
with inline graphics to a recipient whose address book setting would force
the sending of plain text message file, which would lose the graphics.

I have looked at the bug

> https://bugzilla.mozilla.org/show_bug.cgi?id=1222176

and it may not be exactly what my problem is.
But I think it would be a start.

TIA

>>
>> If you do a plain text forward you'll get a plain text composition and
>> you'll see that the picture is missing. In fact, it gets replaced by its
>> alt text.
>>
>> If you do a HTML forward, then the picture will be included, but you're
>> saying that the reply was downgraded to plain text since the recipient was
>> set to plain text in the address book.
>>
>> That can happen and there's been a lot of work invested in this issue
>> here: https://bugzilla.mozilla.org/show_bug.cgi?id=1222176. In the end the
>> bug didn't go ahead.
>>
>> Jörg.
>>
>
> Thank you. I will take a look at
> https://bugzilla.mozilla.org/show_bug.cgi?id=1222176
>
> Maybe a next target of patch submission.
>
> I wish we can spend time on "feature improvement" instead of being clueless
> regarding build bustage :-(
>
>

_______________________________________________
dev-apps-thunderbird mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-thunderbird