Mandatory fields are making problems while customising bugzilla

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Mandatory fields are making problems while customising bugzilla

kiranweinad1
Hi,
I am using Bugzilla 5.0 i will explain my customization requirement  and the problems I am facing here.

I have a product called product_1

i have 4 Custom drop down namely cf_1(values 1,2) cf_2(values 3,4) cf_3(values 5,6) and cf_4(values 7,8)

There are two fields cf_1.1 and cf_1.2 which will be enabled when select value 1 in cf_1.
 
cf_1, cf_2,cf_1.1 and cf_1.2 are mandatory fields
cf_3 and cf_4 are non-mandatory fields but "Can be set on bug creation" is on.

Now the problems are

1. The fields cf_3 and cf_4 are not displayed while creating a bug.
2. Unable to Submit the bug after selecting cf_1 as 2 while submitting it shows an error in the console as "field value cf_1.1 cannot be focused" and field value cf_1.2 cannot be focused.

can someone help me out to get the data.

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Mandatory fields are making problems while customising bugzilla

kiranweinad1
On Monday, June 25, 2018 at 4:03:42 PM UTC+5:30, Thorsten Schöning wrote:

> Guten Tag [hidden email],
> am Montag, 25. Juni 2018 um 12:00 schrieben Sie:
>
> > 1. The fields cf_3 and cf_4 are not displayed while creating a bug.
>
> Check their settings, there surely is some difference compared to cf_1
> etc., especially regarding "Field only appears when:".
>
> > 2. Unable to Submit the bug after selecting cf_1 as 2 while
> > submitting it shows an error in the console as "field value cf_1.1
> > cannot be focused" and field value cf_1.2 cannot be focused.
>
> This is because your fields are treated as mandatory by your browser
> but invisible at the same time. It would be helpful if you could
> provide the HTML for your test case using your browser tools at the
> time you get the console message and more details about the browser
> you use. There have been bugs in the past where browsers seem to
> behaved wrongly:
>
> https://bugzilla.mozilla.org/show_bug.cgi?id=1188414
>
> Additionally, have a look at the following file yourself to see how
> custom fields are rendered and what might go wrong in your case:
>
> > bugzilla\template\en\default\bug\field.html.tmpl
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow



On Monday, June 25, 2018 at 4:03:42 PM UTC+5:30, Thorsten Schöning wrote:

> Guten Tag [hidden email],
> am Montag, 25. Juni 2018 um 12:00 schrieben Sie:
>
> > 1. The fields cf_3 and cf_4 are not displayed while creating a bug.
>
> Check their settings, there surely is some difference compared to cf_1
> etc., especially regarding "Field only appears when:".
>
> > 2. Unable to Submit the bug after selecting cf_1 as 2 while
> > submitting it shows an error in the console as "field value cf_1.1
> > cannot be focused" and field value cf_1.2 cannot be focused.
>
> This is because your fields are treated as mandatory by your browser
> but invisible at the same time. It would be helpful if you could
> provide the HTML for your test case using your browser tools at the
> time you get the console message and more details about the browser
> you use. There have been bugs in the past where browsers seem to
> behaved wrongly:
>
> https://bugzilla.mozilla.org/show_bug.cgi?id=1188414
>
> Additionally, have a look at the following file yourself to see how
> custom fields are rendered and what might go wrong in your case:
>
> > bugzilla\template\en\default\bug\field.html.tmpl
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

Hi
Thanks a lot for for the response

1. The fields cf_3 and cf_4 are not displayed while creating a bug.
> >Check their settings, there surely is some difference compared to cf_1
  etc., especially regarding "Field only appears when:".

There is no option "Field only appears when:" enables for cf_3 and cf_4.
It is displayed when I make it mandatory field. But i want it as non Mandatory.

>>This is because your fields are treated as mandatory by your browser
Yes all the fields are made mandatory otherwise it will not displayed to the user(same as issue 1)

>>It would be helpful if you could
 provide the HTML for your test case using your browser tools at the
 time you get the console message and more details about the browser
 you use.

Yes i will provide you soon.


regards
Kiran Antony
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.