Kompozer revisited

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Kompozer revisited

Dave Yeo-3
Someone asked me to build Kompozer 0.8b3 as the 0.8b4pre was unstable.
Anyways I tried with my current environment, libc065 and GCC 4.4.6, and
ran into problems. First was a function declared inline void in the
header and just void in the cpp file. This was discussed here a couple
of years back. Then other problems like order of constructor against the
define. Eventually the build died while linking xpcom.dll with 600+
unresolved symbols for no good reason. Trying GCC 3.3.5 caused 700+
unresolved symbols. Trying GCC 4.4.1 the linking worked fine, just
wasn't happy with some of the C++ code in os2*.* This is the old method
of using emxexp to generate the def file which looked fine.
Eventually I reverted to libc063 and the corresponding GCC 3.3.5 and the
build went smooth besides some missing ICO and BMP files for the
installer and an EOL issue in a REXX script. At the end the installer
was not correctly built but kompozer seems to work. The example
.mozconfig did have the installer disabled.
Does anyone remember how to link the xpt files to make a release?
Dave
http://old.nabble.com/Building-Komposer-td28078325.html
http://old.nabble.com/Firefox-compile-Problems...-td28648173.html
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: Kompozer revisited

Dave Yeo-3
Dave Yeo wrote:
> Someone asked me to build Kompozer 0.8b3

If anyone is interested I uploaded kompozer.08b3.zip to netlabs.
Requires libc063 and it is just a zip of bin as the installer didn't build.
Dave
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: Kompozer revisited

Bob-351
Thanks Dave, much appreciated.

Bob

Dave Yeo wrote:
> Dave Yeo wrote:
>> Someone asked me to build Kompozer 0.8b3
>
> If anyone is interested I uploaded kompozer.08b3.zip to netlabs.
> Requires libc063 and it is just a zip of bin as the installer didn't build.
> Dave
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: Kompozer revisited

Barbara-46
In reply to this post by Dave Yeo-3
On Sun, 2 Sep 2012 18:45:42 UTC, Dave Yeo <[hidden email]>
wrote:

> Dave Yeo wrote:
> > Someone asked me to build Kompozer 0.8b3
>
> If anyone is interested I uploaded kompozer.08b3.zip to netlabs.
> Requires libc063 and it is just a zip of bin as the installer didn't build.
> Dave

Thanks, Dave!!!


Is there any concern over losing colored text in 8b3 source view? (It
does show up in split view)

Crude photo available here:

http://i49.tinypic.com/4vfdj4.jpg

Top code snippet is from Kompozer 071

Bottom (same) code snippet is from Kompozer 8b3

--
Barbara
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: Kompozer revisited

Dave Yeo-3
Barbara wrote:

> On Sun, 2 Sep 2012 18:45:42 UTC, Dave Yeo<[hidden email]>
> wrote:
>
>> Dave Yeo wrote:
>>> Someone asked me to build Kompozer 0.8b3
>>
>> If anyone is interested I uploaded kompozer.08b3.zip to netlabs.
>> Requires libc063 and it is just a zip of bin as the installer didn't build.
>> Dave
>
> Thanks, Dave!!!
>
>
> Is there any concern over losing colored text in 8b3 source view? (It
> does show up in split view)
>
> Crude photo available here:
>
> http://i49.tinypic.com/4vfdj4.jpg
>
> Top code snippet is from Kompozer 071
>
> Bottom (same) code snippet is from Kompozer 8b3
>

Doesn't surprise me. It is a beta and all I did was compile it. Quickly
testing, 8b4pre isn't much better, showing the coloured text at the
beginning of a page then losing it a dozen or two lines down.
If I get ambitous I might try to fix the code so it'll compile with
newer GCC's and try a debug build to see if anything jumps out,
assertions and such.
Dave
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2
Reply | Threaded
Open this post in threaded view
|

Re: Kompozer revisited

Barbara-46
On Wed, 5 Sep 2012 02:52:23 UTC, Dave Yeo <[hidden email]>
wrote:

> Barbara wrote:
> > On Sun, 2 Sep 2012 18:45:42 UTC, Dave Yeo<[hidden email]>
> > wrote:
> >
> >> Dave Yeo wrote:
> >>> Someone asked me to build Kompozer 0.8b3
> >>
> >> If anyone is interested I uploaded kompozer.08b3.zip to netlabs.
> >> Requires libc063 and it is just a zip of bin as the installer didn't build.
> >> Dave
> >
> > Thanks, Dave!!!
> >
> >
> > Is there any concern over losing colored text in 8b3 source view? (It
> > does show up in split view)
> >
> > Crude photo available here:
> >
> > http://i49.tinypic.com/4vfdj4.jpg
> >
> > Top code snippet is from Kompozer 071
> >
> > Bottom (same) code snippet is from Kompozer 8b3
> >
>
> Doesn't surprise me. It is a beta and all I did was compile it. Quickly
> testing, 8b4pre isn't much better, showing the coloured text at the
> beginning of a page then losing it a dozen or two lines down.
> If I get ambitous I might try to fix the code so it'll compile with
> newer GCC's and try a debug build to see if anything jumps out,
> assertions and such.
> Dave

I did a little searching and read that there were "problems" with
source view colored text and line numbers in the 8xx versions, so they
were just left out.   ???

Not a big deal, so put it on the bottom of your "todo" list. I usually
only use Kompozer for editing, updating and not serious site
construction.

--
Barbara
_______________________________________________
dev-ports-os2 mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-ports-os2