Image magic error in Bugzilla

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Image magic error in Bugzilla

Akhil-6
Hi,

Please help me in this problem after complete installation of all
modules. Its showing error -:


Checking perl modules...
Checking for              CGI.pm (v3.21)   ok: found v3.42
Checking for            TimeDate (v2.21)   ok: found v2.22
Checking for           PathTools (v0.84)   ok: found v3.12
Checking for                 DBI (v1.41)   ok: found v1.52
Checking for    Template-Toolkit (v2.15)   ok: found v2.20
Checking for          Email-Send (v2.00)   ok: found v2.194
Checking for          Email-MIME (v1.861)  ok: found v1.863
Checking for Email-MIME-Modifier (v1.442)  ok: found v1.443

Checking available perl DBD modules...
Checking for              DBD-Pg (v1.45)   ok: found v1.49
Checking for           DBD-mysql (v4.00)   ok: found v4.010
Checking for          DBD-Oracle (v1.19)    not found

The following Perl modules are optional:
Checking for                  GD (v1.20)   ok: found v2.41
Checking for               Chart (v1.0)    ok: found v2.4.1
Checking for         Template-GD (any)     ok: found v1.56
Checking for          GDTextUtil (any)     ok: found v0.86
Checking for             GDGraph (any)     ok: found v1.44
Checking for            XML-Twig (any)     ok: found v3.26
Checking for          MIME-tools (v5.406)  ok: found v5.427
Checking for         libwww-perl (any)     ok: found v2.033
Checking for         PatchReader (v0.9.4)  ok: found v0.9.5
Checking for          PerlMagick (any)     ok: found v6.4.9
Checking for           perl-ldap (any)     ok: found v0.33
Checking for         Authen-SASL (any)     ok: found v2.12
Checking for          RadiusPerl (any)     ok: found v0.13
Checking for           SOAP-Lite (any)     ok: found v0.710.08
Checking for         HTML-Parser (v3.40)   ok: found v3.55
Checking for       HTML-Scrubber (any)     ok: found v0.08
Checking for Email-MIME-Attachment-Stripper (any)     ok: found
v1.316
Checking for         Email-Reply (any)     ok: found v1.202
Checking for            mod_perl (v1.999022) ok: found v2.000002
&Image::Magick::constant not defined. The required ImageMagick
libraries are not installed or not installed properly.
END failed--call queue aborted, <DATA> line 225.


Regards
Akhil Bhardwaj
_______________________________________________
dev-apps-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-bugzilla
-
To view or change your list settings, click here:
<http://bugzilla.org/cgi-bin/mj_wwwusr?user=lists@...>
Reply | Threaded
Open this post in threaded view
|

Re: Image magic error in Bugzilla

Dave Miller
Akhil wrote on 2/27/09 1:05 AM:
> Please help me in this problem after complete installation of all
> modules. Its showing error -:

You're on the wrong newsgroup.  You should post this on
mozilla.support.bugzilla instead.

--
Dave Miller                                   http://www.justdave.net/
System Administrator, Mozilla Corporation      http://www.mozilla.com/
Project Leader, Bugzilla Bug Tracking System  http://www.bugzilla.org/
-
To view or change your list settings, click here:
<http://bugzilla.org/cgi-bin/mj_wwwusr?user=lists@...>
Reply | Threaded
Open this post in threaded view
|

Re: Image magic error in Bugzilla

Jean-Marc Desperrier
In reply to this post by Akhil-6
David Miller wrote:
> Akhil wrote on 2/27/09 1:05 AM:
>> Please help me in this problem after complete installation of all
>> modules. Its showing error -:
>
> You're on the wrong newsgroup. You should post this on
> mozilla.support.bugzilla instead.

OK, so what about turning this into a question that's right for this
newsgroup.

What about making it a *priority* to remove the Image magic dependence
in bugzilla ?

- Image magic is probably the most complex component to install in
bugzilla. It's not by default in most distribution, and can not be
installed only by compiling a perl module.

- It's usefulness is incredibly low

- I can't help thinking it *must* be possible to replace it with
something that causes less problems.

At least, a first solution would be to make it really optionnal, and
remove it from the list of modules that "install-module.pl --all" installs.

Another good thing while talking about "install-module.pl --all" :
- it should ask which db you want to use (or except it's name as an
option) and only install the components related to it.

A last good thing would be to make the installation instruction in
Bugzilla-Guide.txt much more streamlined when aiming non-root users
using install-module.pl.
_______________________________________________
dev-apps-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-bugzilla
-
To view or change your list settings, click here:
<http://bugzilla.org/cgi-bin/mj_wwwusr?user=lists@...>
Reply | Threaded
Open this post in threaded view
|

Re: Image magic error in Bugzilla

Frédéric Buclin
Le 27. 02. 09 11:36, Jean-Marc Desperrier a écrit :

> What about making it a *priority* to remove the Image magic dependence
> in bugzilla ?

You are free to not install this package. I never had it installed, and
I'm using Bugzilla for years without any problem. This package is
optional, not required.

LpSolit
-
To view or change your list settings, click here:
<http://bugzilla.org/cgi-bin/mj_wwwusr?user=lists@...>
Reply | Threaded
Open this post in threaded view
|

Re: Image magic error in Bugzilla

Joel Peshkin
Frédéric Buclin wrote:

> Le 27. 02. 09 11:36, Jean-Marc Desperrier a écrit :
>
>> What about making it a *priority* to remove the Image magic dependence
>> in bugzilla ?
>
> You are free to not install this package. I never had it installed,
> and I'm using Bugzilla for years without any problem. This package is
> optional, not required.
>
> LpSolit
> -

 From the original post....

Checking for         Email-Reply (any)     ok: found v1.202
Checking for            mod_perl (v1.999022) ok: found v2.000002
&Image::Magick::constant not defined. The required ImageMagick
libraries are not installed or not installed properly.
...
END failed--call queue aborted, <DATA> line 225.

It looks like it is possible for a system where the Image::Magick module has been incorrectly installed to cause
checksetup to croak.  While it is true that users should not install CPAN modules without passing their tests,
we peobably don't ant bad system to crash checksetup (or other code that use-es the module) without catching the error.


-
To view or change your list settings, click here:
<http://bugzilla.org/cgi-bin/mj_wwwusr?user=lists@...>
Reply | Threaded
Open this post in threaded view
|

Re: Image magic error in Bugzilla

Jean-Marc Desperrier
In reply to this post by Jean-Marc Desperrier
Frédéric Buclin wrote:
> Le 27. 02. 09 11:36, Jean-Marc Desperrier a écrit :
>> What about making it a *priority* to remove the Image magic dependence
>> in bugzilla ?
>
> You are free to not install this package. I never had it installed, and
> I'm using Bugzilla for years without any problem. This package is
> optional, not required.

What you're writing here is the *very* reason *why* I'm angry that the
dependence exist.

You need to put yourself int he shoes of a new bugzilla users.
He does not know what is important or not to install, but he wants to be
able to test all features without having to come back to the install
stage later because he after all needs on of those optional packages.

So he starts with "install-module.pl", and tries to solve every problem
that he has, without spending spending time for each module to try to
understand why exactly it's needed. And most of the time he'll end up
stuck trying to make the Image magic package work without success.
_______________________________________________
dev-apps-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-bugzilla
-
To view or change your list settings, click here:
<http://bugzilla.org/cgi-bin/mj_wwwusr?user=lists@...>