I have an add on which was working with Thunderbird 52.0, while with Thunderbird 60.0 its not getting loaded.

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

I have an add on which was working with Thunderbird 52.0, while with Thunderbird 60.0 its not getting loaded.

wilsonrob867
Hi,
I have an add on which was working with Thunderbird 52.0, while with Thunderbird 60.0 its not getting loaded.I saw few support links that thunderbird 60.0 has lot of changes which may affect add-ons, could you please help me what I should do to debug as none of my product binaries are getting loaded under thunderbird?

How do I proceed to find what went wrong and what i should change?
_______________________________________________
dev-apps-thunderbird mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-thunderbird
Reply | Threaded
Open this post in threaded view
|

Re: I have an add on which was working with Thunderbird 52.0, while with Thunderbird 60.0 its not getting loaded.

Jörg Knobloch
On 21/09/2018 14:10, [hidden email] wrote:
> I have an add on which was working with Thunderbird 52.0, while with Thunderbird 60.0 its not getting loaded.I saw few support links that thunderbird 60.0 has lot of changes which may affect add-ons, could you please help me what I should do to debug as none of my product binaries are getting loaded under thunderbird?

Hi,

it's correct that between TB 52 and TB 60 many interfaces have changed.
We've tried to compile a list here:
https://wiki.mozilla.org/Thunderbird/Add-ons_Guide_57

What do you mean by "product binaries"? Binary add-ons were discontinued
in Firefox in version 41. They might still have worked in TB 52 (since
their removal apparently missed the deadline, further reading here [1]),
but TB 60 most certainly doesn't have support for binary extensions any
more.

Jörg.

[1] https://mail.mozilla.org/pipermail/tb-planning/2016-November/004964.html

_______________________________________________
dev-apps-thunderbird mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-thunderbird
Reply | Threaded
Open this post in threaded view
|

Re: I have an add on which was working with Thunderbird 52.0, while with Thunderbird 60.0 its not getting loaded.

wilsonrob867
On Friday, September 21, 2018 at 6:00:24 PM UTC+5:30, Jörg Knobloch wrote:

> On 21/09/2018 14:10, [hidden email] wrote:
> > I have an add on which was working with Thunderbird 52.0, while with Thunderbird 60.0 its not getting loaded.I saw few support links that thunderbird 60.0 has lot of changes which may affect add-ons, could you please help me what I should do to debug as none of my product binaries are getting loaded under thunderbird?
>
> Hi,
>
> it's correct that between TB 52 and TB 60 many interfaces have changed.
> We've tried to compile a list here:
> https://wiki.mozilla.org/Thunderbird/Add-ons_Guide_57
>
> What do you mean by "product binaries"? Binary add-ons were discontinued
> in Firefox in version 41. They might still have worked in TB 52 (since
> their removal apparently missed the deadline, further reading here [1]),
> but TB 60 most certainly doesn't have support for binary extensions any
> more.
>
> Jörg.
>
> [1] https://mail.mozilla.org/pipermail/tb-planning/2016-November/004964.html

Hello Jorg,

Thanks a lot for your response.

Our extension is a dll. It has c++ and JS code and will be complied to a dll. This .dll binary is loaded by Thunderbird. In Thunderbird 60, the dll is not even loaded. Are you saying this support is removed in Thunderbird 60?

Thanks,
Regards,
Wilson
_______________________________________________
dev-apps-thunderbird mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-thunderbird
Reply | Threaded
Open this post in threaded view
|

Re: I have an add on which was working with Thunderbird 52.0, while with Thunderbird 60.0 its not getting loaded.

Jörg Knobloch
The short answer is: yes, so-called binary add-ons are no longer supported
by the Mozilla platform. It is however still possible to install the
"binary component" separately. You might want to look at how Enigmail
installs and communicates with both GPG and the pEp engine.

Jörg.

Sent with AquaMail for Android
http://www.aqua-mail.com


_______________________________________________
dev-apps-thunderbird mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-thunderbird
Reply | Threaded
Open this post in threaded view
|

Re: I have an add on which was working with Thunderbird 52.0, while with Thunderbird 60.0 its not getting loaded.

wilsonrob867
In reply to this post by Jörg Knobloch
Hi,

We are able to install binary component. However, we are getting following error? Do you any idea on this?

Failed to load overlay from chrome://xyz/content/xyzOverlay.xul.

We have given this in chrome.manifest. While loading this XUL, I think we have some issue in TB 60.

Thanks,
Wilson.


On Friday, September 21, 2018 at 6:00:24 PM UTC+5:30, Jörg Knobloch wrote:

> On 21/09/2018 14:10, [hidden email] wrote:
> > I have an add on which was working with Thunderbird 52.0, while with Thunderbird 60.0 its not getting loaded.I saw few support links that thunderbird 60.0 has lot of changes which may affect add-ons, could you please help me what I should do to debug as none of my product binaries are getting loaded under thunderbird?
>
> Hi,
>
> it's correct that between TB 52 and TB 60 many interfaces have changed.
> We've tried to compile a list here:
> https://wiki.mozilla.org/Thunderbird/Add-ons_Guide_57
>
> What do you mean by "product binaries"? Binary add-ons were discontinued
> in Firefox in version 41. They might still have worked in TB 52 (since
> their removal apparently missed the deadline, further reading here [1]),
> but TB 60 most certainly doesn't have support for binary extensions any
> more.
>
> Jörg.
>
> [1] https://mail.mozilla.org/pipermail/tb-planning/2016-November/004964.html

_______________________________________________
dev-apps-thunderbird mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-thunderbird
Reply | Threaded
Open this post in threaded view
|

Re: I have an add on which was working with Thunderbird 52.0, while with Thunderbird 60.0 its not getting loaded.

wilsonrob867
In reply to this post by Jörg Knobloch
On Friday, September 21, 2018 at 6:00:24 PM UTC+5:30, Jörg Knobloch wrote:

> On 21/09/2018 14:10, [hidden email] wrote:
> > I have an add on which was working with Thunderbird 52.0, while with Thunderbird 60.0 its not getting loaded.I saw few support links that thunderbird 60.0 has lot of changes which may affect add-ons, could you please help me what I should do to debug as none of my product binaries are getting loaded under thunderbird?
>
> Hi,
>
> it's correct that between TB 52 and TB 60 many interfaces have changed.
> We've tried to compile a list here:
> https://wiki.mozilla.org/Thunderbird/Add-ons_Guide_57
>
> What do you mean by "product binaries"? Binary add-ons were discontinued
> in Firefox in version 41. They might still have worked in TB 52 (since
> their removal apparently missed the deadline, further reading here [1]),
> but TB 60 most certainly doesn't have support for binary extensions any
> more.
>
> Jörg.
>
> [1] https://mail.mozilla.org/pipermail/tb-planning/2016-November/004964.html

Hi,

We are able to install binary component. However, we are getting following error? Do you any idea on this?

Failed to load overlay from chrome://xyz/content/xyzOverlay.xul.

We have given this in chrome.manifest. While loading this XUL, I think we have some issue in TB 60.

Thanks,
Wilson.
_______________________________________________
dev-apps-thunderbird mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-apps-thunderbird