How to set the link flag?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

How to set the link flag?

Rongxin Wu
Hi. Is there any approach to set up the parameters for link when compiling the Mozilla Firefox? When I configure the LDFLAGS="-profile", this only appears in the commands where link.exe is with the cl.exe. However, when link command appears at the beginning, (for example, link -NOLOGO -OUT:nsinstall.exe -PDB:nsinstall.pdb host_nsinstall_win.obj), the LDFLAGS will have no effects. Can anybody know how to pass the link flag in that case?
_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds
Reply | Threaded
Open this post in threaded view
|

Re: How to set the link flag?

Frank Wein
Rongxin Wu wrote:
> Hi. Is there any approach to set up the parameters for link when
> compiling the Mozilla Firefox? When I configure the
> LDFLAGS="-profile", this only appears in the commands where link.exe
> is with the cl.exe. However, when link command appears at the
> beginning, (for example, link -NOLOGO -OUT:nsinstall.exe
> -PDB:nsinstall.pdb host_nsinstall_win.obj), the LDFLAGS will have no
> effects. Can anybody know how to pass the link flag in that case?

So you use the classic ./configure, make commands to compile Firefox?
How exactly did your command look like to pass the modified LDFLAGS to
the build system? I would have used "export LDFLAGS="..." " in the
.mozconfig file, but passing it directly to configure should work, too
(I think).

Frank

--
Es gibt viel zu tun, warten wir es ab!
_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds
Reply | Threaded
Open this post in threaded view
|

Re: How to set the link flag?

Rongxin Wu
On Saturday, November 3, 2012 6:19:51 PM UTC+8, Frank Wein wrote:
> Rongxin Wu wrote:
I just ran the command "make -f client.mk" and configure the LDFLAGS="-profile" in .mozconfig. I wrote "LDFLAGS="-profile"" instead of "EXPORT LDFLAGS="-profile"", maybe this is why it didn't work. I will try it. Thanks.



> > Hi. Is there any approach to set up the parameters for link when
>
> > compiling the Mozilla Firefox? When I configure the

>
> > LDFLAGS="-profile", this only appears in the commands where link.exe
>
> > is with the cl.exe. However, when link command appears at the
>
> > beginning, (for example, link -NOLOGO -OUT:nsinstall.exe
>
> > -PDB:nsinstall.pdb host_nsinstall_win.obj), the LDFLAGS will have no
>
> > effects. Can anybody know how to pass the link flag in that case?
>
>
>
> So you use the classic ./configure, make commands to compile Firefox?
>
> How exactly did your command look like to pass the modified LDFLAGS to
>
> the build system? I would have used "export LDFLAGS="..." " in the
>
> .mozconfig file, but passing it directly to configure should work, too
>
> (I think).
>
>
>
> Frank
>
>
>
> --
>
> Es gibt viel zu tun, warten wir es ab!
_______________________________________________
dev-builds mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-builds