Help with Active Directory as LDAP for Bugzilla 2.18.1

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Help with Active Directory as LDAP for Bugzilla 2.18.1

Tony-8

I have successfully built Bugzilla V 2.8.1 on a Windows 2003 server following the great set of instruction provided by Byron Jones at  http://www.bugzilla.org/docs/w­in32install.html

Now I'm trying to set it up to use our active directory for authentication using the instruction at: http://groups-beta.google.com/­group/netscape.public.mozilla.­webtools/...
and section 2.3.5 of the Bugzilla Guide - 2.18.1 Release. I have edited my data/params file with the following:

'LDAPBaseDN' =>
'CN=testuser,CN=Users,DC=edp,D­C=dolir,DC=state,DC=mo,DC=us:p­assword
'LDAPbinddn' => 'CN=Users,DC=edp,DC=dolir,DC=s­tate,DC=mo,DC=us',
'LDAPmailattribute' => 'mail',
'LDAPserver' => 'yellowpages.edp.dolir.state.m­o.us',
'LDAPuidattribute' => 'sAMAccountName',
'loginmethod' => 'LDAP',

 

I'm now getting the following error in my browser:

Can't locate Net/LDAP.pm in @INC (@INC contains: . c:/Perl/lib
c:/Perl/site/lib) at Bugzilla/Auth/LDAP.pm line 36.
BEGIN failed--compilation aborted at Bugzilla/Auth/LDAP.pm line 36.
Compilation failed in require at Bugzilla/Auth.pm line 38.
BEGIN failed--compilation aborted at Bugzilla/Auth.pm line 42.
Compilation failed in require at Bugzilla.pm line 27.
BEGIN failed--compilation aborted at Bugzilla.pm line 27.
Compilation failed in require at CGI.pl line 417.
BEGIN failed--compilation aborted at CGI.pl line 417.

Please help if you can.

Thanks to all for the great documentation :)

 

Respectfully

Tony R. Giboney, CIT III
Missouri Department of Labor and Industrial Relations
Office of Information Systems
[hidden email]
573-751-7389