Gopher support has to move back to core before Firefox 57 can be released

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Gopher support has to move back to core before Firefox 57 can be released

keiyakins
In Mozilla 2.0, Gopher support was removed from core with the promise that "Gopher will be an option as long as people are motivated to own its implementation."[1]. This was done, thanks mostly to the good work of Cameron Kaiser[2]. In fact, OverbiteFF actually improved on the already quite good support that was there before. For a time, everyone was happy, or at least no one was excessively unhappy.

However The new WebExtensions API cannot, by design, possibly implement a Gopher protocol handler. As Gopher was promised to remain an option, and the possibility of implementing it as an extension is being removed, it'll have to move back into core.

[1]: https://bugzilla.mozilla.org/show_bug.cgi?id=388195#c47 
[2]: http://gopher.floodgap.com/overbite/ 
_______________________________________________
general mailing list
[hidden email]
https://lists.mozilla.org/listinfo/general
Reply | Threaded
Open this post in threaded view
|

Re: Gopher support has to move back to core before Firefox 57 can be released

Mozilla - General mailing list
People still use Gopher?! Wow.

On 8/1/2017 11:53 AM, [hidden email] wrote:
> In Mozilla 2.0, Gopher support was removed from core with the promise that "Gopher will be an option as long as people are motivated to own its implementation."[1]. This was done, thanks mostly to the good work of Cameron Kaiser[2]. In fact, OverbiteFF actually improved on the already quite good support that was there before. For a time, everyone was happy, or at least no one was excessively unhappy.
>
> However The new WebExtensions API cannot, by design, possibly implement a Gopher protocol handler. As Gopher was promised to remain an option, and the possibility of implementing it as an extension is being removed, it'll have to move back into core.
>
> [1]: https://bugzilla.mozilla.org/show_bug.cgi?id=388195#c47
> [2]: http://gopher.floodgap.com/overbite/
>


--
"An ant hole may collapse an embankment." --Japanese
Note: A fixed width font (Courier, Monospace, etc.) is required to see
this signature correctly.
    /\___/\         Ant(Dude) @ http://antfarm.ma.cx (Personal Web Site)
   / /\ /\ \                Ant's Quality Foraged Links: http://aqfl.net
  | |o   o| |
     \ _ /        If crediting, then use Ant nickname and AQFL URL/link.
      ( )               Axe ANT from its address if e-mailing privately.
_______________________________________________
general mailing list
[hidden email]
https://lists.mozilla.org/listinfo/general
Reply | Threaded
Open this post in threaded view
|

Re: Gopher support has to move back to core before Firefox 57 can be released

keiyakins
On Tuesday, August 1, 2017 at 8:45:34 PM UTC-5, Ant wrote:
> People still use Gopher?! Wow.
>

Yes, people still use gopher. They did then, they do now.
_______________________________________________
general mailing list
[hidden email]
https://lists.mozilla.org/listinfo/general