Getting Older c++03 based Spidermonkey

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Getting Older c++03 based Spidermonkey

Masquerade
I want a version of Spidermonkey which is:
1) Using purely C++03 code (absolutely no C++11 features)
2) can be compiled into x64 binaries
which latest version should I use?


Also the official link to spidermonkey v31 seems broken:

https://people.mozilla.org/~sstangl/mozjs-31.2.0.rc0.tar.bz2

My browser keeps saying:

This site can’t be reached

people.mozilla.org refused to connect.
_______________________________________________
dev-tech-js-engine mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-js-engine
Reply | Threaded
Open this post in threaded view
|

Re: Getting Older c++03 based Spidermonkey

Nicolas B. Pierron
On 08/25/2017 10:36 AM, Masquerade wrote:
> I want a version of Spidermonkey which is:
> 1) Using purely C++03 code (absolutely no C++11 features)

Is that a compiler issue?

I do not think jsapi.h is using any C++11 features, or maybe a limited set
of features such as delegated constructors.  So you might be able to compile
SpiderMonkey with all of C++11, and only enable a few features for jsapi.h
to compile.

--
Nicolas B. Pierron
_______________________________________________
dev-tech-js-engine mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-js-engine