Quantcast

GD Install Trouble

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

GD Install Trouble

rickbryant
bugzilla 3.0.4 is installed and working great but we're having trouble
enabling charting/graphing. when installing the perl GD modules for
charting/graphing support after running the following command:
/usr/bin/perl -MCPAN -e 'install "GD"'

we get the following fatal error message:
**UNRECOVERABLE ERROR**
Could not find gdlib-config in the search path. Please install libgd
2.0.28 or higher.
If you want to try to compile anyway, please rerun this script with
the option --ignore_missing_gd.

we have the following GD 2.0.28 RPM packages installed:
[root@nemo bugzilla-3.0.4]# rpm -qa | grep "^gd-\|^gd-devel-"
gd-2.0.28-5.4E.el4_6.1
gd-devel-2.0.28-5.4E.el4_6.1

that include the following files:
[root@nemo bugzilla-3.0.4]# rpm -q gd -l
/usr/lib/libgd.so.2
/usr/lib/libgd.so.2.0.0
/usr/share/doc/gd-2.0.28
/usr/share/doc/gd-2.0.28/index.html
[root@nemo bugzilla-3.0.4]# rpm -q gd-devel -l
/usr/include/entities.h
/usr/include/gd.h
/usr/include/gd_io.h
/usr/include/gdcache.h
/usr/include/gdfontg.h
/usr/include/gdfontl.h
/usr/include/gdfontmb.h
/usr/include/gdfonts.h
/usr/include/gdfontt.h
/usr/include/gdfx.h
/usr/lib/libgd.a
/usr/lib/libgd.so

and we're running the following OS:
Red Hat Enterprise Linux AS release 4 (Nahant Update 6)
Kernel 2.6.9-67.0.7.ELsmp on an i686

so don't really understand what the perl install is asking for here as
it seems we have the correct RPM package installed. anyone have any
suggestions please?

thanks,
rick
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: GD Install Trouble

Tosh, Michael J
Quoting [hidden email]:
> so don't really understand what the perl install is asking for here as
> it seems we have the correct RPM package installed. anyone have any
> suggestions please?

It's looking for this file: gdlib-config
I don't know enough about this to know when you'd have that gdlib-config
file and when you wouldn't, but it is a starting point.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GD Install Trouble

rickbryant
In reply to this post by rickbryant
On Aug 12, 1:18 pm, "Tosh, Michael J" <[hidden email]> wrote:
> Quoting [hidden email]:
>
> > so don't really understand what the perl install is asking for here as
> > it seems we have the correct RPM package installed. anyone have any
> > suggestions please?
>
> It's looking for this file: gdlib-config
> I don't know enough about this to know when you'd have that gdlib-config
> file and when you wouldn't, but it is a starting point.

thanks Michael Tosh! this issue is resolved and here's the summary of
what we did in hopes it helps other Red Hat Linux users. gdlib-config
is a script file that has been included in the open source
distribution of the gd library since version 2.0.26. we have the Red
Hat gd library version 2.0.28 installed as an rpm however this
distribution (RHEL AS 4) does not include gdlib-config! contacted Red
Hat support about this and they confirmed that gdlib-config is not
part of their official 2.0.28 distribution and they only began
includin the script as part of RHEL AS 5. So to resolve this, we
downloaded the open source gd library from the following link:
http://www.boutell.com/gd/manual2.0.28.html#getgd
decompressed/untarred the file, and then ran ./configure from the
gd-2.0.28 directory. once the command had completed we copied the
newly created gdlib-config file from the gd-2.0.28/config directory to
the /usr/bin directory and made the file executable by running 'chmod
774 gdlib-config'. after that every one of the perl GD modules
installed without error.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

RE: GD Install Trouble

Tosh, Michael J
Quoting [hidden email]:

> distribution (RHEL AS 4) does not include gdlib-config! contacted Red
> Hat support about this and they confirmed that gdlib-config is not
> part of their official 2.0.28 distribution and they only began
> includin the script as part of RHEL AS 5.

Good, I was hoping it would be that easy!  I'm surprised that if you are
paying for support from them that they wouldn't have gotten the script
for you.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GD Install Trouble

cheesegrits
In reply to this post by rickbryant

rick.bryant wrote
here's the summary of
what we did in hopes it helps other Red Hat Linux users.
Thank you thank you thank you.

Your post and some google-fu were a life saver on a tight deadline.

   -- hugh

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GD Install Trouble

grimmdp
In reply to this post by rickbryant

rickbryant wrote
downloaded the open source gd library from the following link:
http://www.boutell.com/gd/manual2.0.28.html#getgd
decompressed/untarred the file, and then ran ./configure from the
gd-2.0.28 directory. once the command had completed we copied the
newly created gdlib-config file from the gd-2.0.28/config directory to
the /usr/bin directory and made the file executable by running 'chmod
774 gdlib-config'. after that every one of the perl GD modules
installed without error.
You nailed it. Thanks a bunch!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: GD Install Trouble

deadsea
In reply to this post by rickbryant
On Redhat and CentOS machines the gdlib-config file is not in the gd packages because it is in the gd-devel package.  To get gdlib-config installed run:

yum install gd-devel
Loading...