FT2LIB 2.60 Doesn't Work In SeaMonkey

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

FT2LIB 2.60 Doesn't Work In SeaMonkey

Felix Miata-2
Up to now I've been using FT2LIB 1.0 final in eCS 1.1. I just installed
2.60b1. It works fine in Firefox trunk and 1.5 and in Mozilla 1.7.12, but
not at all in the latest SeaMonkey 1.0b nightly (10 days old). How do I make
it work in SeaMonkey too? Is this a problem with a too long, non-8.3
filename in the registry? Where did the installer put a readme? I've been
going by the antique online readme for v2.40.

On a related note, when libc06 final came out several weeks ago I installed
it right away. Now that I've installed 2.60b1, I have both libc06.dll and
libc06b4.dll. Should I remove the beta dll?
--
"Blessed is the nation whose God is the Lord."        Psalm 33:12 NIV

  Team OS/2 ** Reg. Linux User #211409

Felix Miata  ***  http://mrmazda.no-ip.com/
_______________________________________________
Mozilla-os2 mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-os2
Reply | Threaded
Open this post in threaded view
|

Re: FT2LIB 2.60 Doesn't Work In SeaMonkey

Dave Yeo-2
Felix Miata wrote:
> Up to now I've been using FT2LIB 1.0 final in eCS 1.1. I just
> installed 2.60b1. It works fine in Firefox trunk and 1.5 and in
> Mozilla 1.7.12, but not at all in the latest SeaMonkey 1.0b nightly
> (10 days old). How do I make it work in SeaMonkey too? Is this a
> problem with a too long, non-8.3 filename in the registry? Where did
> the installer put a readme? I've been going by the antique online
> readme for v2.40.
You have to add seamonkey.exe to the registry (forget where, its in the
readme). Not sure where the readme is, you could always reinstall and
read the readme as its installing.
>
> On a related note, when libc06 final came out several weeks ago I
> installed it right away. Now that I've installed 2.60b1, I have both
> libc06.dll and libc06b4.dll. Should I remove the beta dll?

If you're sure you have no apps using libc06b4 you could remove it.
Personally with HD space so cheap I'd just leave it, there is still a
fair number of apps floating around that were buit with it
Dave
_______________________________________________
Mozilla-os2 mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-os2
Reply | Threaded
Open this post in threaded view
|

Re: FT2LIB 2.60 Doesn't Work In SeaMonkey

Heikki Kekki
Dave Yeo wrote:

> Felix Miata wrote:
>> Up to now I've been using FT2LIB 1.0 final in eCS 1.1. I just
>> installed 2.60b1. It works fine in Firefox trunk and 1.5 and in
>> Mozilla 1.7.12, but not at all in the latest SeaMonkey 1.0b nightly
>> (10 days old). How do I make it work in SeaMonkey too? Is this a
>> problem with a too long, non-8.3 filename in the registry? Where did
>> the installer put a readme? I've been going by the antique online
>> readme for v2.40.
> You have to add seamonkey.exe to the registry (forget where, its in the
> readme). Not sure where the readme is, you could always reinstall and
> read the readme as its installing.

[HKEY_LOCAL_MACHINE\SOFTWARE\InnoTek\InnoTek Font
Engine\Applications\seamonkey.exe]
Enabled=dword:00000001

Works here since last February.

--
Hessu
Feel free to correct my English :-)
_______________________________________________
Mozilla-os2 mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-os2
Reply | Threaded
Open this post in threaded view
|

Re: FT2LIB 2.60 Doesn't Work In SeaMonkey

Peter Weilbacher
In reply to this post by Felix Miata-2
Felix Miata wrote:
> Where did the installer put a readme? I've been
> going by the antique online readme for v2.40.

I was wondering that, too, so I restarted the 2.60 installer EXE again
which presents the readme. But it's really stupid not to find it! The
readme from 2.40 is probably wrong in that point.

Perhaps the demo included with
   http://hobbes.nmsu.edu/cgi-bin/h-search?key=feconfig
helps without using it as programming library? I still haven't
downloaded or tried...

> On a related note, when libc06 final came out several weeks ago I installed
> it right away. Now that I've installed 2.60b1, I have both libc06.dll and
> libc06b4.dll. Should I remove the beta dll?

No, it's most likely used by FT2LIB and loaded by that name.
--
Cheers, Peter.
                                               Please reply in newsgroup
    Unofficial Mozilla builds: http://weilbacher.org/Mozilla/builds.html
    Steve's Warpzilla Tips: http://www.os2bbs.com/os2news/Warpzilla.html
_______________________________________________
Mozilla-os2 mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-os2
Reply | Threaded
Open this post in threaded view
|

Re: FT2LIB 2.60 Doesn't Work In SeaMonkey

Felix Miata-2
In reply to this post by Heikki Kekki
On 06/01/18 04:03 Heikki Kekki apparently typed:

> Dave Yeo wrote:

>> Felix Miata wrote:

>>> Up to now I've been using FT2LIB 1.0 final in eCS 1.1. I just
>>> installed 2.60b1. It works fine in Firefox trunk and 1.5 and in
>>> Mozilla 1.7.12, but not at all in the latest SeaMonkey 1.0b nightly
>>> (10 days old). How do I make it work in SeaMonkey too? Is this a
>>> problem with a too long, non-8.3 filename in the registry? Where did
>>> the installer put a readme? I've been going by the antique online
>>> readme for v2.40.

>> You have to add seamonkey.exe to the registry (forget where, its in
>> the readme). Not sure where the readme is, you could always reinstall
>> and read the readme as its installing.

> [HKEY_LOCAL_MACHINE\SOFTWARE\InnoTek\InnoTek Font
> Engine\Applications\seamonkey.exe]
> Enabled=dword:00000001

> Works here since last February.

Not here. It did that before asking here, as none of Firefox or Mozilla
worked before I did that for them either, which is why I asked here:

[HKEY_LOCAL_MACHINE\SOFTWARE\InnoTek\InnoTek Font
Engine\Applications\firefox.exe] Enabled=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\InnoTek\InnoTek Font
Engine\Applications\mozilla.exe] Enabled=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\InnoTek\InnoTek Font
Engine\Applications\seamonkey.exe] Enabled=dword:00000001
[HKEY_LOCAL_MACHINE\SOFTWARE\InnoTek\InnoTek Font
Engine\Applications\thunderbird.exe] Enabled=dword:00000001
--
"Blessed is the nation whose God is the Lord."        Psalm 33:12 NIV

  Team OS/2 ** Reg. Linux User #211409

Felix Miata  ***  http://mrmazda.no-ip.com/
_______________________________________________
Mozilla-os2 mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-os2
Reply | Threaded
Open this post in threaded view
|

Re: FT2LIB 2.60 Doesn't Work In SeaMonkey

Felix Miata-2
In reply to this post by Peter Weilbacher
On 06/01/18 04:55 Peter Weilbacher apparently typed:

> Felix Miata wrote:

>> Where did the installer put a readme? I've been
>> going by the antique online readme for v2.40.

> I was wondering that, too, so I restarted the 2.60 installer EXE again
> which presents the readme. But it's really stupid not to find it! The
> readme from 2.40 is probably wrong in that point.

> Perhaps the demo included with
>    http://hobbes.nmsu.edu/cgi-bin/h-search?key=feconfig
> helps without using it as programming library? I still haven't
> downloaded or tried...

Nice tool. Here's its output:
Font Engine detected.
Font Engine is enabled.

Disabling Font Engine.
   -> disabled

Font Engine is disabled.

Enabling Font Engine.
   -> enabled

Font Engine is enabled.

Global hinting is enabled.

AntiAliasing is enabled.

SubPixel rendering is disabled.

Applications: 4

Application names:
    Name = mozilla.exe (Enabled = 1)
    Name = firefox.exe (Enabled = 1)
    Name = os2web.exe (Enabled = 1)
    Name = Thunderbird.exe (Enabled = 1)

I remember reading about the need to add seamonkey.exe someone once upon a
time, but couldn't find it anywhere, which is why I came here to ask. Except
for the memory, this last section made no sense to me, as I did not put
os2web.exe in there. I searched for it with regedit2, which is how I added
all 4 according to the online readme for 2.40, and it was found not in
HKEY_CURRENT_USER, but in HKEY_LCOAL_MACHINE, along with mozilla.exe and
firefox.exe but not seamonkey.exe. :-p I'll betcha it works when I restart
the suite I'm writing this with. ;-)

>> On a related note, when libc06 final came out several weeks ago I installed
>> it right away. Now that I've installed 2.60b1, I have both libc06.dll and
>> libc06b4.dll. Should I remove the beta dll?

> No, it's most likely used by FT2LIB and loaded by that name.

I since rebooted to maintenance, renamed the beta libc06b4dll, rebooted, and
nothing changed.
--
"Blessed is the nation whose God is the Lord."        Psalm 33:12 NIV

  Team OS/2 ** Reg. Linux User #211409

Felix Miata  ***  http://mrmazda.no-ip.com/
_______________________________________________
Mozilla-os2 mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-os2
Reply | Threaded
Open this post in threaded view
|

Re: FT2LIB 2.60 Doesn't Work In SeaMonkey

Felix Miata-2
In reply to this post by Felix Miata-2
On 06/01/18 05:21 Felix Miata apparently typed:

> On 06/01/18 04:03 Heikki Kekki apparently typed:

>> [HKEY_LOCAL_MACHINE\SOFTWARE\InnoTek\InnoTek Font
>> Engine\Applications\seamonkey.exe]
>> Enabled=dword:00000001

>> Works here since last February.
>
> Not here. It did that before asking here, as none of Firefox or Mozilla
> worked before I did that for them either, which is why I asked here:

> [HKEY_LOCAL_MACHINE\SOFTWARE\InnoTek\InnoTek Font
> Engine\Applications\firefox.exe] Enabled=dword:00000001
> [HKEY_LOCAL_MACHINE\SOFTWARE\InnoTek\InnoTek Font
> Engine\Applications\mozilla.exe] Enabled=dword:00000001
> [HKEY_LOCAL_MACHINE\SOFTWARE\InnoTek\InnoTek Font
> Engine\Applications\seamonkey.exe] Enabled=dword:00000001
> [HKEY_LOCAL_MACHINE\SOFTWARE\InnoTek\InnoTek Font
> Engine\Applications\thunderbird.exe] Enabled=dword:00000001

Oops. Above is what's there now, and SeaMonkey is working (and os2web.exe
gone). I added all 4 according to the online 2.4 readme to
HKEY_CURRENT_USER, not knowing about the HKEY_LOCAL_MACHINE entries put in
by the installer, which I didn't find because I was searching for ft2lib,
not innotek.
--
"Blessed is the nation whose God is the Lord."        Psalm 33:12 NIV

  Team OS/2 ** Reg. Linux User #211409

Felix Miata  ***  http://mrmazda.no-ip.com/
_______________________________________________
Mozilla-os2 mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-os2
Reply | Threaded
Open this post in threaded view
|

Re: FT2LIB 2.60 Doesn't Work In SeaMonkey

Felix Miata-2
In reply to this post by Peter Weilbacher
On 06/01/18 04:55 Peter Weilbacher apparently typed:

> Felix Miata wrote:

>> Where did the installer put a readme? I've been
>> going by the antique online readme for v2.40.

> I was wondering that, too, so I restarted the 2.60 installer EXE again
> which presents the readme. But it's really stupid not to find it! The
> readme from 2.40 is probably wrong in that point.

I used the fc/2 viewer on the exe file and found the readme inside is
different from the online v2.40 readme. Never did find it extracted
anywhere, but 2.60 is after all still a beta. :-p
--
"Blessed is the nation whose God is the Lord."        Psalm 33:12 NIV

  Team OS/2 ** Reg. Linux User #211409

Felix Miata  ***  http://mrmazda.no-ip.com/
_______________________________________________
Mozilla-os2 mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-os2
Reply | Threaded
Open this post in threaded view
|

Re: FT2LIB 2.60 Doesn't Work In SeaMonkey

Chuck McKinnis
In reply to this post by Felix Miata-2
On Wed, 18 Jan 2006 07:15:18 UTC, Felix Miata
<[hidden email]> wrote:

> Up to now I've been using FT2LIB 1.0 final in eCS 1.1. I just installed
> 2.60b1. It works fine in Firefox trunk and 1.5 and in Mozilla 1.7.12, but
> not at all in the latest SeaMonkey 1.0b nightly (10 days old). How do I make
> it work in SeaMonkey too? Is this a problem with a too long, non-8.3
> filename in the registry? Where did the installer put a readme? I've been
> going by the antique online readme for v2.40.

Should nvu.exe also be in the font engine registry as well as the
various run!.exe variants?

--
Chuck McKinnis
[hidden email]
Covenant Solutions
http://7cities.net/~mckinnis/
_______________________________________________
Mozilla-os2 mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-os2
Reply | Threaded
Open this post in threaded view
|

Re: FT2LIB 2.60 Doesn't Work In SeaMonkey

Steve Wendt
Chuck McKinnis wrote:

> Should nvu.exe also be in the font engine registry as well as the
> various run!.exe variants?

I suppose nvu.exe should be there if you want it to benefit from the
font engine.  The run!.exe programs are just launchers, so those should
be irrelevant (they never show any fonts!).
_______________________________________________
Mozilla-os2 mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-os2
Reply | Threaded
Open this post in threaded view
|

Re: FT2LIB 2.60 Doesn't Work In SeaMonkey

Chuck McKinnis
On Wed, 18 Jan 2006 23:17:01 UTC, Steve Wendt <[hidden email]>
wrote:

> Chuck McKinnis wrote:
>
> > Should nvu.exe also be in the font engine registry as well as the
> > various run!.exe variants?
>
> I suppose nvu.exe should be there if you want it to benefit from the
> font engine.  The run!.exe programs are just launchers, so those should
> be irrelevant (they never show any fonts!).

That is what I thought, but I was just checking.  Thanks.

--
Chuck McKinnis
[hidden email]
Covenant Solutions
http://7cities.net/~mckinnis/
_______________________________________________
Mozilla-os2 mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-os2
Reply | Threaded
Open this post in threaded view
|

Re: FT2LIB 2.60 Doesn't Work In SeaMonkey

Robert Henschel
In reply to this post by Peter Weilbacher
Peter Weilbacher wrote:

> Felix Miata wrote:
>
>>Where did the installer put a readme? I've been
>>going by the antique online readme for v2.40.
>
>
> I was wondering that, too, so I restarted the 2.60 installer EXE again
> which presents the readme. But it's really stupid not to find it! The
> readme from 2.40 is probably wrong in that point.
>
> Perhaps the demo included with
>    http://hobbes.nmsu.edu/cgi-bin/h-search?key=feconfig
> helps without using it as programming library? I still haven't
> downloaded or tried...
The "demo application" that is included with the library does only
display the current settings for the font engine. To add an application
you would have to write an new application that uses the feconfig.dll.

However, you can use the current "beta tested" GUI application from an
os2world bounty:
http://www.os2world.com/cgi-bin/forum/UltraBoard.cgi?action=Read&BID=83&TID=29&P=1#ID29

Scroll down and download the "feffer" application. You can use it to add
seamonkey.exe to the registry. (but be sure to read the readme before
starting the application!)


Regards,

Robert

--
Robert Henschel

--
OS/2 User Group Dresden
http://warp5.dyndns.org:8080/OS2Dresden
_______________________________________________
Mozilla-os2 mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-os2