FF17 svg clip-path calculated incorrectly

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

FF17 svg clip-path calculated incorrectly

Andrew Inscore
I have run into an issue where a rectangle element with a clip-path applied
does not respond correctly to mouse events.

Visually, the clip-path is applied correctly, however, the rectangle
element responds to mouse events as if the clip path were applied with
coordinates relative to the rectangle element.  Since this has only come up
since FF17, I'm assuming its a bug.

Here is a JSFiddle which reproduces this issue.

http://jsfiddle.net/xVkY3/


Thanks,
Andrew
_______________________________________________
dev-tech-svg mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-svg
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FF17 svg clip-path calculated incorrectly

Martijn-4
Can you file a bug?

Thanks,
Martijn
Op 18 dec. 2012 21:31 schreef "Andrew Inscore" <[hidden email]>
het volgende:

> I have run into an issue where a rectangle element with a clip-path applied
> does not respond correctly to mouse events.
>
> Visually, the clip-path is applied correctly, however, the rectangle
> element responds to mouse events as if the clip path were applied with
> coordinates relative to the rectangle element.  Since this has only come up
> since FF17, I'm assuming its a bug.
>
> Here is a JSFiddle which reproduces this issue.
>
> http://jsfiddle.net/xVkY3/
>
>
> Thanks,
> Andrew
> _______________________________________________
> dev-tech-svg mailing list
> [hidden email]
> https://lists.mozilla.org/listinfo/dev-tech-svg
>
_______________________________________________
dev-tech-svg mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-svg
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: FF17 svg clip-path calculated incorrectly

Andrew Inscore
Filed, thanks!

https://bugzilla.mozilla.org/show_bug.cgi?id=823179

On Wed, Dec 19, 2012 at 2:44 AM, Martijn <[hidden email]> wrote:

> Can you file a bug?
>
> Thanks,
> Martijn
> Op 18 dec. 2012 21:31 schreef "Andrew Inscore" <[hidden email]>
> het volgende:
>
>> I have run into an issue where a rectangle element with a clip-path
>> applied
>> does not respond correctly to mouse events.
>>
>> Visually, the clip-path is applied correctly, however, the rectangle
>> element responds to mouse events as if the clip path were applied with
>> coordinates relative to the rectangle element.  Since this has only come
>> up
>> since FF17, I'm assuming its a bug.
>>
>> Here is a JSFiddle which reproduces this issue.
>>
>> http://jsfiddle.net/xVkY3/
>>
>>
>> Thanks,
>> Andrew
>> _______________________________________________
>> dev-tech-svg mailing list
>> [hidden email]
>> https://lists.mozilla.org/listinfo/dev-tech-svg
>>
>
_______________________________________________
dev-tech-svg mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-tech-svg
Loading...