Error while trying to send mails using smtp option

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Error while trying to send mails using smtp option

Abdullah Al-Darmaki
Dear support,

Can you please share me the right configuration to configure the smtp feature for sending mails in bugzilla, because after I did all the configuration I am getting error that unable to establish the connection also note that we using exchange server (smtp.domain.com)


Regard,
Abdullah


_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Fwd: Error while trying to send mails using smtp option

Abdullah Al-Darmaki


Sent from my HTC

----- Forwarded message -----
From: "Abdullah Al-Darmaki" <[hidden email]>
To: "[hidden email]" <[hidden email]>
Subject: Error while trying to send mails using smtp option
Date: Thu, Jul 12, 2018 3:03 PM

Dear support,

Can you please share me the right configuration to configure the smtp feature for sending mails in bugzilla, because after I did all the configuration I am getting error that unable to establish the connection also note that we using exchange server (smtp.domain.com)


Regard,
Abdullah


_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Error while trying to send mails using smtp option

Abdullah Al-Darmaki
In reply to this post by Abdullah Al-Darmaki
Dear Therostan,

Thanks for reply,
the error message is "unable to establish smtp connection".
Also note that bugzilla server already added in exchange settings also its allowed in firewall,  so everything is done on that side so nothing is blocked.
My configration in bugzilla like the follow:
1-sending type i choice (smtp).
2-I put the email address that we use for send([hidden email]).
3-I put the user name and password.
4-ssl is on.

I hope to guide me to solve this

Thanks & Regard,

Abdullah


----- Reply message -----
From: "Thorsten Schöning" <[hidden email]>
To: "[hidden email]" <[hidden email]>
Subject: Error while trying to send mails using smtp option
Date: Thu, Jul 12, 2018 4:34 PM

Guten Tag Abdullah Al-Darmaki,
am Donnerstag, 12. Juli 2018 um 13:03 schrieben Sie:

> Can you please share me the right configuration to configure the
> smtp feature for sending mails in bugzilla, because after I did all
> the configuration I am getting error that unable to establish the
> connection also note that we using exchange server (smtp.domain.com)

Please provide exact error messages and what you have done to debug
this problem on your own already. The message might simply be correct
because of wrong firewall settings or you are missing required
libraries to use TLS whatever. How can anyone know with the facts you
provided?

Mit freundlichen Grüßen,

Thorsten Schöning

--
Thorsten Schöning       E-Mail: [hidden email]
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Fwd: Error while trying to send mails using smtp option

Abdullah Al-Darmaki
Dear Therostan,

Thanks for reply,
the error message is "unable to establish smtp connection".
Also note that bugzilla server already added in exchange settings also its allowed in firewall,  so everything is done on that side so nothing is blocked.
My configration in bugzilla like the follow:
1-sending type i choice (smtp).
2-I put the email address that we use for send([hidden email]).
3-I put the user name and password.
4-ssl is on.

I hope to guide me to solve this

Thanks & Regard,

Abdullah

----- Forwarded message -----
From: "Abdullah Al-Darmaki" <[hidden email]>
To: "Thorsten Schöning" <[hidden email]>, "[hidden email]" <[hidden email]>
Subject: Error while trying to send mails using smtp option
Date: Thu, Jul 12, 2018 4:48 PM

Dear Therostan,

Thanks for reply,
the error message is "unable to establish smtp connection".
Also note that bugzilla server already added in exchange settings also its allowed in firewall,  so everything is done on that side so nothing is blocked.
My configration in bugzilla like the follow:
1-sending type i choice (smtp).
2-I put the email address that we use for send([hidden email]).
3-I put the user name and password.
4-ssl is on.

I hope to guide me to solve this

Thanks & Regard,

Abdullah


----- Reply message -----
From: "Thorsten Schöning" <[hidden email]>
To: "[hidden email]" <[hidden email]>
Subject: Error while trying to send mails using smtp option
Date: Thu, Jul 12, 2018 4:34 PM

Guten Tag Abdullah Al-Darmaki,
am Donnerstag, 12. Juli 2018 um 13:03 schrieben Sie:

> Can you please share me the right configuration to configure the
> smtp feature for sending mails in bugzilla, because after I did all
> the configuration I am getting error that unable to establish the
> connection also note that we using exchange server (smtp.domain.com)

Please provide exact error messages and what you have done to debug
this problem on your own already. The message might simply be correct
because of wrong firewall settings or you are missing required
libraries to use TLS whatever. How can anyone know with the facts you
provided?

Mit freundlichen Grüßen,

Thorsten Schöning

--
Thorsten Schöning       E-Mail: [hidden email]
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Error while trying to send mails using smtp option

Abdullah Al-Darmaki
In reply to this post by Abdullah Al-Darmaki



________________________________
From: support-bugzilla <support-bugzilla-bounces+a.darmaki-it=[hidden email]> on behalf of Thorsten Schöning <[hidden email]>
Sent: Thursday, July 12, 2018 6:04 PM
To: [hidden email]
Subject: Re: Error while trying to send mails using smtp option

Guten Tag Abdullah Al-Darmaki,
am Donnerstag, 12. Juli 2018 um 14:48 schrieben Sie:

> the error message is "unable to establish smtp connection".

That might be the following:

https://bugzilla.mozilla.org/show_bug.cgi?id=1182445
https://groups.google.com/forum/#!topic/mozilla.support.bugzilla/xFqK7S3h25g

There's a debug setting for SMTP, enable that, trigger the error and
have a look at the log of your web server for additional details.

> Also note that bugzilla server already added in exchange settings
> also its allowed in firewall,  so everything is done on that side so nothing is blocked.

You could have made a mistake, so try to send mails using SMTP
manually from the server hosting Bugzilla using telnet or such. There
are plenty of tutorials how to do that in the net:

https://www.port25.com/how-to-check-an-smtp-connection-with-a-manual-telnet-session-2/

> My configration in bugzilla like the follow:
> 1-sending type i choice (smtp).
> 2-I put the email address that we use for send([hidden email]).
> 3-I put the user name and password.
> 4-ssl is on.

Doesn't read that wrong, trying without SSL is always a good idea as
well. Not only the flag off of course, but the mail server configured
to not require it as well. This way you can check if all TLS only is
the problem, e.g. because of missing dependencies.

Mit freundlichen Grüßen,

Thorsten Schöning

--
Thorsten Schöning       E-Mail: [hidden email]
AM-SoFT IT-Systeme      http://www.AM-SoFT.de/

Telefon...........05151-  9468- 55
Fax...............05151-  9468- 88
Mobil..............0178-8 9468- 04

AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Error while sending mails using smtp method in bugzilla

Abdullah Al-Darmaki
Dear Thorsten,


Any chance to use send mail method instead of SMTP method for sending mails in Bugzilla as I explained to you last time I was using SMTP method and I got an error "unable to establish SMTP connection" you gave me some solutions I tried that but I was getting the same error every time, so please guide me to use send mail method as I already installed that application but I am not sure from the details which I put in sendmail.ini file, because after I test that also I got this error " error when closing pipe to sendmail: Inappropriate I/O control operation " so please can you guide me step by step to do that and send me the sendmail.ini file so I can know if there is any mistake I did, waiting for your reply ASAP.



Thanks & Regard,


Abdullah
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.