Error while SMTP setup

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Error while SMTP setup

Merlin Timm
Hello everybody,

I installed myself the latest version of Bugzilla (5.0.2) and just
trying to set up the SMTP, but unfortunately I get the following error
when I want to confirm the information contained within:

"Software error:

Can not locate object method "quit" via package "Net :: SMTP :: SSL" at
Bugzilla / config / Common.pm line 370

For help, please send mail to the webmaster (webmaster @ localhost),
giving this error message and the time and date of the error."

Maybe one of you can help me. Thank you!

greeting
Merlin

--
--------------------------------------------------------
Merlin Timm
IT/EDV

Scienlab electronic systems GmbH
Lise-Meitner-Allee 27 — 44801 Bochum — Germany
phone +49 (0)234 41 75 78 -187
fax +49 (0)234 41 75 78 -10
web www.scienlab.de
---------------------------------------------------------
Kennen Sie schon unseren neuen Webauftritt?
www.scienlab.de
---------------------------------------------------------
Amtsgericht Bochum 14 HRB 7272
Geschäftsführer:
Dr.-Ing. Christoph Dörlemann, Dr.-Ing. Peter Muß,
Dr.-Ing. Michael Schugt, Dr.-Ing. Roger Uhlenbrock

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error while SMTP setup

merlintimm90
Am Dienstag, 10. Mai 2016 19:43:21 UTC+2 schrieb Thorsten Schöning:

> Guten Tag Merlin Timm,
> am Dienstag, 10. Mai 2016 um 10:36 schrieben Sie:
>
> > Can not locate object method "quit" via package "Net :: SMTP :: SSL" at
> > Bugzilla / config / Common.pm line 370
>
> Sounds like you are missing SSL libs, openssl-dev packages or such.
> Check that using your package manager. Additionally/else activate
> debugging for SMTP in the admin mail settings of Bugzilla and look in
> the log of your web server.
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

Hi Thorsten,

this is the only thing i found in the error.log of my Apache:
[Thu Jun 09 09:50:10 2016] [error] [client 192.168.100.82] [Thu Jun  9 09:50:10 2016] editparams.cgi: Can't locate object method "quit" via package "Net::SMTP::SSL" at Bugzilla/Config/Common.pm line 370., referer: http://192.168.100.14/bugzilla/editparams.cgi?section=mta

this is the same message that i got from Bugzilla Webinterface :(
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error while SMTP setup

merlintimm90
Am Donnerstag, 9. Juni 2016 10:46:14 UTC+2 schrieb Thorsten Schöning:

> Guten Tag [hidden email],
> am Donnerstag, 9. Juni 2016 um 10:04 schrieben Sie:
>
> > this is the only thing i found in the error.log of my Apache:
> > [Thu Jun 09 09:50:10 2016] [error] [client 192.168.100.82] [Thu Jun
> > 9 09:50:10 2016] editparams.cgi: Can't locate object method "quit"
> > via package "Net::SMTP::SSL" at Bugzilla/Config/Common.pm line 370.,
>
> Then debug further: Check the version of your installed
> Net::SMTP::SSL, have a look at the source if a "quit" method is
> available etc. There should be a file Net/SMTP/SSL.pm somewhere in your
> perl installation or wherever and however you install packages. If
> you have used install-module.pl, empty the bugzilla/lib folder and
> install missing packages again using your package manager.
>
> Additionally look at the mentioned line of the Bugzilla code to see
> what Bugzilla thinks: It thinks you have Net::SMTP::SSL available,
> expects an available method and that seems to be missing. You need to
> find the reason why because from my understanding it should be
> available.
>
> http://cpansearch.perl.org/src/RJBS/Net-SMTP-SSL-1.03/lib/Net/SMTP/SSL.pm
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

Hey Thorsten,

i have solved my problem with the SMTP entries moments ago! I just had
to (re?)install Net::SMTP::SSL via cpan console.

greetings
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Error while SMTP setup

smohamedyunus

> Hey Thorsten,
>
> i have solved my problem with the SMTP entries moments ago! I just had
> to (re?)install Net::SMTP::SSL via cpan console.
>
> greetings

Thanks it helped me as well.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Loading...