Duplicate Key error when attempting to create new product

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Duplicate Key error when attempting to create new product

Damon Hill
Good day.

Running Bugzilla 2.18.3 on Apache 2.0.52 and MySQL 4.1.10a.
I have been able to successfully add products since upgrading but now something
has changed causing all sorts of hell to happen on the server.
The error I receive is the following:

DBD::mysql::st execute failed: Duplicate entry '9-18-0' for key 1 [for Statement
"INSERT INTO group_group_map (member_id, grantor_id, isbless)
                  VALUES (9, 18, 1)"] at Bugzilla/DB.pm line 62
        Bugzilla::DB::SendSQL('INSERT INTO group_group_map (member_id, grantor_id,
isbless)\x{a}...') called at /var/www/bugzilla/editproducts.cgi line 385

If there is anyone that could lend me just a little insight into this, that
would be great.

After I recieve the error, if I return to the Products main page, and view the
list of products in the system, the one I added is listed. However, when I
attempt to add a new bug into the system, that new product is not listed as an
option to add bugs to.

Thanks,
~damon
_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: Duplicate Key error when attempting to create new product

A. Karl Kornel
In article <dc3jk2$[hidden email]>,
 Damon Hill <[hidden email]> wrote:

> Good day.
>
> Running Bugzilla 2.18.3 on Apache 2.0.52 and MySQL 4.1.10a.
> I have been able to successfully add products since upgrading but now
> something
> has changed causing all sorts of hell to happen on the server.
> The error I receive is the following:
>
> <<<snip>>>

   Do you get any error messages (or other unusual messages) when you
run checksetup.pl and the Sanity Check?
--
=============================
|   Alfred Karl Kornel
|   -- [hidden email]
|   Member- Europa Research Group
|   UNIX / RESOLVE Consultant
=============================

----== Posted via Newsfeeds.Com - Unlimited-Uncensored-Secure Usenet News==----
http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
----= East and West-Coast Server Farms - Total Privacy via Encryption =----
_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: Duplicate Key error when attempting to create new product

Damon Hill
A. Karl Kornel wrote:

> In article <dc3jk2$[hidden email]>,
>  Damon Hill <[hidden email]> wrote:
>
>
>>Good day.
>>
>>Running Bugzilla 2.18.3 on Apache 2.0.52 and MySQL 4.1.10a.
>>I have been able to successfully add products since upgrading but now
>>something
>>has changed causing all sorts of hell to happen on the server.
>>The error I receive is the following:
>>
>><<<snip>>>
>
>
>    Do you get any error messages (or other unusual messages) when you
> run checksetup.pl and the Sanity Check?

This is the output of my running checksetup.pl

******************************************************************************
Checking perl modules ...
Checking for       AppConfig (v1.52)   ok: found v1.56
Checking for             CGI (v2.93)   ok: found v3.10
Checking for    Data::Dumper (any)     ok: found v2.121
Checking for    Date::Format (v2.21)   ok: found v2.22
Checking for             DBI (v1.36)   ok: found v1.40
Checking for      DBD::mysql (v2.1010) ok: found v2.9004
Checking for      File::Spec (v0.82)   ok: found v0.87
Checking for      File::Temp (any)     ok: found v0.14
Checking for        Template (v2.08)   ok: found v2.14
Checking for      Text::Wrap (v2001.0131) ok: found v2001.09292

The following Perl modules are optional:
Checking for              GD (v1.20)    not found
Checking for     Chart::Base (v1.0)     not found
Checking for     XML::Parser (any)     ok: found v2.34
Checking for       GD::Graph (any)      not found
Checking for GD::Text::Align (any)      not found
Checking for     PatchReader (v0.9.4)   not found

If you you want to see graphical bug charts (plotting historical data over
time), you should install libgd and the following Perl modules:

GD:          /usr/bin/perl -MCPAN -e 'install "GD"'
Chart:       /usr/bin/perl -MCPAN -e 'install "Chart::Base"'

If you you want to see graphical bug reports (bar, pie and line charts of
current data), you should install libgd and the following Perl modules:

GD:              /usr/bin/perl -MCPAN -e 'install "GD"'
GD::Graph:       /usr/bin/perl -MCPAN -e 'install "GD::Graph"'
GD::Text::Align: /usr/bin/perl -MCPAN -e 'install "GD::Text::Align"'

If you want to see pretty HTML views of patches, you should install the
PatchReader module:
PatchReader: /usr/bin/perl -MCPAN -e 'install "PatchReader"'
Checking user setup ...

The $mysqlpath setting in your localconfig file is no longer required.
We recommend you remove it.
Removing existing compiled templates ...
Precompiling templates ...
Checking for    MySQL Server (v3.23.41) ok: found v4.1.10a
*******************************************************************************

I believe that everything there looks good, correct?

Sanity Check run produced these *red* values:

*******************************************************************************
Bug(s) found with invalid op_sys value: 3, 4, 6, 7, 9, 10, 12, 14, 16, 91, 103,
166, 180, 182, 187, 188, 208, 212, 220, 221, 234, 235, 253, 257, 258, 259, 260,
313, 373, 402, 403, 467, 490, 621 (as buglist)

Bug(s) found with invalid rep_platform value: 3, 4, 6, 7, 9, 10, 12, 14, 16,
103, 166, 180, 182, 188, 208, 212, 220, 221, 234, 235, 253, 257, 258, 259, 260,
313, 373, 402, 403, 467, 621, 622 (as buglist)

Bad value 1 found in longdescs.bug_id

Bad value 2 found in longdescs.bug_id

Bugs that have changes but no mail sent for at least half an hour: 4, 5, 7, 8,
10, 11, 13, 14, 16, 19, 20, 22, 23, 24, 25, 26, 28, 29, 30, 31, 32, 33, 35, 36,
37, 38, 39, 40, 41, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57, 59,
60, 61, 62, 63, 64, 65, 94, 95, 150 (as buglist)
********************************************************************************

There doesn't appear to be anything wrong their either. But I am very new to the
product.

Thanks,
~damon


_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: Duplicate Key error when attempting to create new product

A. Karl Kornel
In article <dc59hc$[hidden email]>,
 Damon Hill <[hidden email]> wrote:

> <<<snip>>>
>
> This is the output of my running checksetup.pl
>
> <<<snip>>>
> Checking user setup ...
>
> The $mysqlpath setting in your localconfig file is no longer required.
> We recommend you remove it.
> Removing existing compiled templates ...
> Precompiling templates ...
> Checking for    MySQL Server (v3.23.41) ok: found v4.1.10a
> ******************************************************************************
> *
>
> I believe that everything there looks good, correct?

   Yes.  Although you could install a couple of extra Perl modules, and
there is one variable in your localconfig file that can be deleted,
checksetup did not report any problems.

> Sanity Check run produced these *red* values:

   Red values are bad.

> ******************************************************************************
> *
> Bug(s) found with invalid op_sys value: 3, 4, 6, 7, 9, 10, 12, 14, 16, 91,
> 103,
> 166, 180, 182, 187, 188, 208, 212, 220, 221, 234, 235, 253, 257, 258, 259,
> 260,
> 313, 373, 402, 403, 467, 490, 621 (as buglist)

   At some point in the life of your Bugzilla installation, either you
(or checksetup) did something that accidentally deleted one or more
operating system field values.

   To repair this, for each bug listed above change the operating system
field to a valid value.  Valid values are defined in localconfig (in
2.18.* and earlier) or in the 'Field Values' prefs page (in 2.20.*).

> Bug(s) found with invalid rep_platform value: 3, 4, 6, 7, 9, 10, 12, 14, 16,
> 103, 166, 180, 182, 188, 208, 212, 220, 221, 234, 235, 253, 257, 258, 259,
> 260,
> 313, 373, 402, 403, 467, 621, 622 (as buglist)

   This needs to be handled using the procedure described above.

> Bad value 1 found in longdescs.bug_id
>
> Bad value 2 found in longdescs.bug_id

   Did you end up deleting a bug or two somewhere?  There are two bug
comments that are not associated with actual bugs.

> Bugs that have changes but no mail sent for at least half an hour: 4, 5, 7,
> 8,
> 10, 11, 13, 14, 16, 19, 20, 22, 23, 24, 25, 26, 28, 29, 30, 31, 32, 33, 35,
> 36,
> 37, 38, 39, 40, 41, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57,
> 59,
> 60, 61, 62, 63, 64, 65, 94, 95, 150 (as buglist)
> ******************************************************************************
> **

   You will need to check your mail configuration, because mail should
be sent immediately (or at least within 30 minutes).  Go ahead and tell
Sanity Check to send those; take a look at your mail-related Bugzilla
parameters and your mail setup.  If you still have problems with this,
start a new thread to address it (make a new post instead of replying to
this one).  Unfortunately, I can't help you in this area.

> There doesn't appear to be anything wrong their either. But I am very new to
> the
> product.

   There are a number of things that need to be addressed, but I did not
see anything that would explain the error you received.  Fix the errors
above & see if it fixes your problem.  If not, post again.

   Good luck!
--
=============================
|   Alfred Karl Kornel
|   -- [hidden email]
|   Member- Europa Research Group
|   UNIX / RESOLVE Consultant
=============================

----== Posted via Newsfeeds.Com - Unlimited-Uncensored-Secure Usenet News==----
http://www.newsfeeds.com The #1 Newsgroup Service in the World! 120,000+ Newsgroups
----= East and West-Coast Server Farms - Total Privacy via Encryption =----
_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools
Reply | Threaded
Open this post in threaded view
|

Re: Duplicate Key error when attempting to create new product

Damon Hill
A. Karl Kornel wrote:
> In article <dc59hc$[hidden email]>,
>  Damon Hill <[hidden email]> wrote:
>

>
>    You will need to check your mail configuration, because mail should
> be sent immediately (or at least within 30 minutes).  Go ahead and tell
> Sanity Check to send those; take a look at your mail-related Bugzilla
> parameters and your mail setup.  If you still have problems with this,
> start a new thread to address it (make a new post instead of replying to
> this one).  Unfortunately, I can't help you in this area.
>
>
>>There doesn't appear to be anything wrong their either. But I am very new to
>>the
>>product.
>
>
>    There are a number of things that need to be addressed, but I did not
> see anything that would explain the error you received.  Fix the errors
> above & see if it fixes your problem.  If not, post again.
>
>    Good luck!

Thank you for the reply Karl.
I did indeed send the emails immediately.
I then repaired every problem shown in the sanitycheck.cgi script, however, I
still get the following error when attempting to add new products. A little more
information might be helpful. I have attempted to add this product in the past,
and when I do, I get the duplicate bug, but when I then view the products page,
I can see the new listing, but when I attempt to enter a new bug the newly added
product is not available for me to assign the bug to. I then delete the new
product from the product listing page and attempt to add it again and we are
back in the same cycle.

My thought is one of two things:
        1) when removing the product, not all tables are updated correctly.
        2) when adding the product, bugzilla is attempting to add it into the
group_group_map table on two separate occasions and is thusly blowing up on
the second attempt to add.

Thoughts?

Thanks again for all of the help.

~damon
_______________________________________________
mozilla-webtools mailing list
[hidden email]
http://mail.mozilla.org/listinfo/mozilla-webtools