Custom Status in Buglist doesn't show in "Status" [bug_status] column

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Custom Status in Buglist doesn't show in "Status" [bug_status] column

jdpond
This could well be my problem because of extensive customizations, but
craving your collective indulgence . . .
 
When we add a custom status, it works perfectly - except - in the buglist,
the status will display as empty unless I also define it in the status_descs
array, something that is normally done in global/field-descs.none.tmpl.
 
I can make the field display properly if I add a hook in
BUGZILLA_ROOT/template/en/custom/hook/global/field-descs.none.tmpl/end/ that
contains (for example):
 
[% status_descs.AWTAPRV = "AWTAPRV"  %]
 
But otherwise, when in a custom status, that column in the row remains
blank.
 
Should I submit as bug or is it just a local anomaly?
 
The County of Montgomery, PA (Shield) <http://www.montcopa.org/>
Jack D. Pond
CIO
Montgomery County, PA
(610)278-5200
 
 
 
 
 
 
"The dogmatist within is always worse than the enemy without". -- S.J. Gould

 

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Custom Status in Buglist doesn't show in "Status" [bug_status] column

Max Kanat-Alexander
On Fri, 30 Jan 2009 20:39:39 -0500 "Jack D. Pond"
<[hidden email]> wrote:
> This could well be my problem because of extensive customizations, but
> craving your collective indulgence . . .
>  
> When we add a custom status, it works perfectly - except - in the
> buglist, the status will display as empty unless I also define it in
> the status_descs array, something that is normally done in
> global/field-descs.none.tmpl.

        Yes, that's because of your customizations. You should be using
get_status() in your templates instead of accessing status_descs
directly.

        -Max
--
http://www.everythingsolved.com/
Competent, Friendly Bugzilla and Perl Services. Everything Else, too.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

RE: Custom Status in Buglist doesn't show in "Status" [bug_status]column

jdpond
Thanks Max, you were absolutely correct!

> -----Original Message-----
> From:
> support-bugzilla-bounces+jack.pond=[hidden email]
g [mailto:support-bugzilla-> bounces+jack.pond=[hidden email]]
On Behalf Of

> Max Kanat-Alexander
> Sent: Friday, January 30, 2009 10:18 PM
> To: [hidden email]
> Subject: Re: Custom Status in Buglist doesn't show in
> "Status" [bug_status]column
>
> On Fri, 30 Jan 2009 20:39:39 -0500 "Jack D. Pond"
> <[hidden email]> wrote:
> > This could well be my problem because of extensive
> customizations, but
> Yes, that's because of your customizations. You should be using
> get_status() in your templates instead of accessing
> status_descs directly.
>
> -Max
> --
> http://www.everythingsolved.com/
> Competent, Friendly Bugzilla and Perl Services. Everything Else, too.
> _______________________________________________
> support-bugzilla mailing list
> [hidden email]
> https://lists.mozilla.org/listinfo/support-bugzilla
> PLEASE put [hidden email] in the To:
> field when you reply.
>

_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.