Cross-Compilation of NSS for MIPS platform fails.

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Cross-Compilation of NSS for MIPS platform fails.

ramyasivanesan36
Hi,
 I have been trying to cross compile NSS 3.21 for MIPS-Linux platform, but am facing a lot of build issues. First I built nspr with mipsel toolchain and it compiled without any errors.
 While compiling NSS , I am getting the following error :

{standard input}: Assembler messages:
{standard input}:79: Error: unrecognized opcode `bswap $2'
make[3]: *** [mipsel-linux3.13_x86_glibc_PTH_DBG.OBJ/mipsel-linux_SINGLE_SHLIB/sha_fast.o] Error 1
 
 Hence, I would like to know whether cross-compilation of NSS is supported for MIPS. If so, kindly give the links of the documentation.
 
 Also, after some modifications, I was able to build NSS, but while running I am getting errors related to database. Error log is as follows :

 Error initializing NSS without a persistent database: NSS error code: -5925

 So, how shall I proceed to rectify this error?
_______________________________________________
dev-security mailing list
[hidden email]
https://lists.mozilla.org/listinfo/dev-security
Loading...