Configuring Bugzilla, "Table doesn't exist"

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Configuring Bugzilla, "Table doesn't exist"

RusskiyAvos'
Hi!

I'm installing Bugzilla 2.22.

I already installed Apache 2.2.4, replaced files from C:\Program Files\Apache Software Foundation\Apache2.2\htdocs by files from Bugzilla folder.
Installed Perl, installation file named 'ActivePerl-5.8.7.813-MSWin32-x86-148120.msi'. Then I downloaded and installed some PPM modules.
Installed MySQL 5.0.27(standard)

This is a part of my C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\localconfig file(link for this file is below):
[quote]
$db_host = 'localhost';         # where is the database?
$db_name = 'bugs';              # name of the SQL database
$db_user = 'root';              # user to attach to the SQL database
$db_port = 3306;
$db_pass = 'root';
[/quote]

I created database like this:

[quote]
mysql -u root -p
     create database bugs;
     GRANT SELECT, INSERT, UPDATE, DELETE, INDEX, ALTER, CREATE, LOCK TABLES,              
     CREATE TEMPORARY TABLES, DROP, REFERENCES ON bugs.* TO root@localhost
     IDENTIFIED BY 'root';
     FLUSH PRIVILEGES;
     \q[/quote]

after loading checksetup.pl i've got "Client doesn't support authentification.." I resolved this problem like this:

[quote]
mysql> SET PASSWORD FOR
    -> 'root'@'localhost' = OLD_PASSWORD('root');[/quote]

When I enter _http://localhost I see Bugzilla home page, but when I'm trying to log in, I get this error:
[quote]
Software error:
DBD::mysql::db selectrow_array failed: Table 'bugs.profiles' doesn't exist [for Statement "SELECT userid FROM profiles WHERE login_name = ?"] at Bugzilla/User.pm line 1399
        Bugzilla::User::login_to_id('root') called at Bugzilla/Auth/Verify/DB.pm line 56
        Bugzilla::Auth::Verify::DB::authenticate('Bugzilla::Auth::Verify::DB', 'root', 'root') called at Bugzilla/Auth.pm line 90
        Bugzilla::Auth::authenticate('Bugzilla::Auth', 'root', 'root') called at Bugzilla/Auth/Login/WWW/CGI.pm line 58
        Bugzilla::Auth::Login::WWW::CGI::login('Bugzilla::Auth::Login::WWW::CGI', 2) called at Bugzilla/Auth/Login/WWW.pm line 64
        Bugzilla::Auth::Login::WWW::login('Bugzilla::Auth::Login::WWW', 0) called at Bugzilla.pm line 162
        Bugzilla::login('Bugzilla', 0) called at C:/Program Files/Apache Software Foundation/Apache2.2/htdocs/index.cgi line 37

For help, please send mail to the webmaster (localhost@localhost), giving this error message and the time and date of the error.
[/quote]

What should I do to resolve this problem:

Here are some links to my config files:

C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\localconfig:
http://slil.ru/24154501
C:\Program Files\Apache Software Foundation\Apache2.2\conf\httpd.conf:
http://slil.ru/24154648
C:\Program Files\MySQL\MySQL Server 5.0\my.ini:
http://slil.ru/24154653