Cannot login Bugzilla

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot login Bugzilla

Bugslayer
I am the administrator of Bugzilla at my company. I updated the software to the latest version 5.1.1 on Windows 7. Everything works fine. There are some perl modules not found during Checksetup.pl run, and then I installed majority of them in last few days. However. it is strange that I cannot log in Bugzilla from my PC using any account. I can log in Bugzilla on my notebook PC. Everyone's PC works fine for Bugzilla. Every time I tried to log in, I saw the error message.

"Bugzilla needs a legitimate login and password to continue".

I thought there were some cookies, temp files, caches that may effect my Bugzilla log in. So I did some cleanup. So far, I still cannot login.

I have two Bugzilla websites, one for testing and one for production.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot login Bugzilla

Bugslayer
On Friday, February 24, 2017 at 12:54:56 PM UTC-7, Thorsten Schöning wrote:

> Guten Tag Bugslayer,
> am Freitag, 24. Februar 2017 um 20:44 schrieben Sie:
>
> > I am the administrator of Bugzilla at my company. I updated the
> > software to the latest version 5.1.1 on Windows 7.
> [...]
> > I have two Bugzilla websites, one for testing and one for production.
>
> 5.1.1 is an unstable development release, so you upgraded your testing
> installation? And all your other users and from your notebook you can
> login to that testing installation of 5.1.1, but only not from one of
> your PCs?
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

Both production and test websites are in 5.1.1. It worked for all accounts on PCs for 5.1.1 on the production website after I installed.

Then I tried to use the new chart for bug reports in this version, but there were some problems.

Since I installed the Bugzilla software several years ago, some of the product names have been changed. Furthermore, the bug chart created with the old names was incorrect, and the bug count for the product with changed names is wrong. There may be a bug in Bugzilla that didn't account for the product name changes.

After I select the "New Charts" Change over Time, "Category list" should display products I defined. However, this list displays old product names instead of the current names. The "Old Charts" option displays the products correctly.

To fix the problem, I installed a test website.  
 
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot login Bugzilla

Bugslayer
In reply to this post by Bugslayer
On Friday, February 24, 2017 at 12:54:56 PM UTC-7, Thorsten Schöning wrote:

> Guten Tag Bugslayer,
> am Freitag, 24. Februar 2017 um 20:44 schrieben Sie:
>
> > I am the administrator of Bugzilla at my company. I updated the
> > software to the latest version 5.1.1 on Windows 7.
> [...]
> > I have two Bugzilla websites, one for testing and one for production.
>
> 5.1.1 is an unstable development release, so you upgraded your testing
> installation? And all your other users and from your notebook you can
> login to that testing installation of 5.1.1, but only not from one of
> your PCs?
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

Right now, I couldn't log in the production Bugzilla from both my desktop and notebook PCs. However, I can still log in from a virtual PC where production Bugzilla is hosted. A test Bugzilla website is hosted on the notebook PC. I can still login on test website from any PC.

I wonder if some temp internet files saved for the test website screwed up the production website log in.
 


_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot login Bugzilla

Bugslayer
In reply to this post by Bugslayer
On Friday, February 24, 2017 at 12:54:56 PM UTC-7, Thorsten Schöning wrote:

> Guten Tag Bugslayer,
> am Freitag, 24. Februar 2017 um 20:44 schrieben Sie:
>
> > I am the administrator of Bugzilla at my company. I updated the
> > software to the latest version 5.1.1 on Windows 7.
> [...]
> > I have two Bugzilla websites, one for testing and one for production.
>
> 5.1.1 is an unstable development release, so you upgraded your testing
> installation? And all your other users and from your notebook you can
> login to that testing installation of 5.1.1, but only not from one of
> your PCs?
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

I am a software developer and trying to solve this problem myself. Can I enable some log files that records the failure of the log in?
 
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot login Bugzilla

Bugslayer
On Friday, February 24, 2017 at 1:45:21 PM UTC-7, Bugslayer wrote:

> On Friday, February 24, 2017 at 12:54:56 PM UTC-7, Thorsten Schöning wrote:
> > Guten Tag Bugslayer,
> > am Freitag, 24. Februar 2017 um 20:44 schrieben Sie:
> >
> > > I am the administrator of Bugzilla at my company. I updated the
> > > software to the latest version 5.1.1 on Windows 7.
> > [...]
> > > I have two Bugzilla websites, one for testing and one for production.
> >
> > 5.1.1 is an unstable development release, so you upgraded your testing
> > installation? And all your other users and from your notebook you can
> > login to that testing installation of 5.1.1, but only not from one of
> > your PCs?
> >
> > Mit freundlichen Grüßen,
> >
> > Thorsten Schöning
> >
> > --
> > Thorsten Schöning       E-Mail: [hidden email]
> > AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
> >
> > Telefon...........05151-  9468- 55
> > Fax...............05151-  9468- 88
> > Mobil..............0178-8 9468- 04
> >
> > AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> > AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow
>
> I am a software developer and trying to solve this problem myself. Can I enable some log files that records the failure of the log in?

I didn't realize the 5.1.1 is not a stable release. Is there anyway to downgrade the version to 5.0.3?
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot login Bugzilla

Gervase Markham
On 24/02/17 12:55, Bugslayer wrote:
> I didn't realize the 5.1.1 is not a stable release. Is there anyway to downgrade the version to 5.0.3?

Not easily, no. Do you have a backup of your database from before you
upgraded to 5.1.1? That's basically the only way. Otherwise, you'd have
to try and reverse all of the database changes by hand, which would be a
scary prospect.

Gerv
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot login Bugzilla

Bugslayer
On Friday, February 24, 2017 at 4:31:14 PM UTC-7, Gervase Markham wrote:
> On 24/02/17 12:55, Bugslayer wrote:
> > I didn't realize the 5.1.1 is not a stable release. Is there anyway to downgrade the version to 5.0.3?
>
> Not easily, no. Do you have a backup of your database from before you
> upgraded to 5.1.1? That's basically the only way. Otherwise, you'd have
> to try and reverse all of the database changes by hand, which would be a
> scary prospect.
>
> Gerv

I have a backup for the database. However, a lot of bug entries have been put into the database. I am stuck with 5.1.1. Fortunately, it is still working for all other people.

What is the release date for the next stable version?

Thank you.


_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot login Bugzilla

Bugslayer
In reply to this post by Bugslayer
On Friday, February 24, 2017 at 2:17:40 PM UTC-7, Thorsten Schöning wrote:

> Guten Tag Bugslayer,
> am Freitag, 24. Februar 2017 um 21:25 schrieben Sie:
>
> > Both production and test websites are in 5.1.1.
>
> That's a pretty bad idea, 5.1.1 is unstable and a development branch
> and shouldn't be used in production.
>
> > Since I installed the Bugzilla software several years ago, some of
> > the product names have been changed. Furthermore, the bug chart
> > created with the old names was incorrect, and the bug count for the
> > product with changed names is wrong. There may be a bug in Bugzilla
> > that didn't account for the product name changes.
>
> https://bugzilla.mozilla.org/show_bug.cgi?id=267240
>
> > I wonder if some temp internet files saved for the test website
> > screwed up the production website log in.
>
> Surely no files, cookies might be, but you already said to have them
> cleared. So I suggest checking your browser development tools to see
> where actual requests are going and how the responses look like.
> Additionally, raise the log level of your web server and have a look
> there.
>
> > "Bugzilla needs a legitimate login and password to continue".
>
> This is no error, just a normal textual message. You might request
> wrong URLs, which might be valid in your older version, but not
> anymore. So start with things like index.cgi and the short login form
> on the upper right or click the login links for a full page login
> form.
>
> > Can I enable some log files that records the failure of the log in?
>
> Not really, there was some old logging mechanism, but I guess it's
> almost useless these days.
>
> https://bugzilla.mozilla.org/show_bug.cgi?id=426463
> https://www.bugzilla.org/docs/2.20/html/general-advice.html
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

I am still try to figure out the problem. Here is the header sent out from my PC.
Remote Address:192.168.100.162:8080
Request URL:http://eng1108:8080/index.cgi
Request Method:POST
Status Code:200 OK
Response Headers
view source
Connection:Keep-Alive
Content-Type:text/html; charset=UTF-8
Date:Tue, 28 Feb 2017 22:03:20 GMT
Keep-Alive:timeout=5, max=100
Server:Apache/2.2.25 (Win32)
Set-Cookie:Bugzilla_login_request_cookie=7E08NfI8yS; domain=eng1108; path=/; HttpOnly
Transfer-Encoding:chunked
X-content-type-options:nosniff
X-frame-options:SAMEORIGIN
X-xss-protection:1; mode=block
Request Headers
view source
Accept:text/html,application/xhtml+xml,application/xml;q=0.9,image/webp,*/*;q=0.8
Accept-Encoding:gzip, deflate
Accept-Language:en-US,en;q=0.8
Cache-Control:max-age=0
Connection:keep-alive
Content-Length:156
Content-Type:application/x-www-form-urlencoded
Host:eng1108:8080
Origin:http://eng1108:8080
Referer:http://eng1108:8080/index.cgi
User-Agent:Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/43.0.2357.124 Safari/537.36
Form Data
view source
view URL encoded
Bugzilla_login:[hidden email]
Bugzilla_password:userpassword
Bugzilla_restrictlogin:on
GoAheadAndLogIn:Log In
GoAheadAndLogIn:Log in
Bugzilla_login_token:

Response from Bugzilla server

<!DOCTYPE html>
<html lang="en">
  <head>
    <title>Log in to Bugzilla</title>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">

<link href="data/assets/5c72e9e6afb71ddcdaa88d7deaa6b8a7.css" rel="stylesheet" type="text/css">



     

   
<script type="text/javascript" src="data/assets/ebf7f6a1b777bdc4cdb7c5177ccfd887.js"></script>

    <script type="text/javascript">
    <!--
          YAHOO.namespace('bugzilla');
          YAHOO.util.Event.addListener = function (el, sType, fn, obj, overrideContext) {
              if ( ("onpagehide" in window || YAHOO.env.ua.gecko) && sType === "unload") { sType = "pagehide"; };
              var capture = ((sType == "focusin" || sType == "focusout") && !YAHOO.env.ua.ie) ? true : false;
              return this._addListener(el, this._getType(sType), fn, obj, overrideContext, capture);
          };
          if ( "onpagehide" in window || YAHOO.env.ua.gecko) {
              YAHOO.util.Event._simpleRemove(window, "unload",
                                             YAHOO.util.Event._unload);
          }

       
        function unhide_language_selector() {
            $('#lang_links_container').removeClass('bz_default_hidden');
        }
        $(document).ready(unhide_language_selector);

        // This sets the default parameters for all calendar fields.
        $.datepicker.setDefaults({
            dateFormat: "yy-mm-dd", // this is the YYYY-MM-DD format
            showButtonPanel: true,  // permits to easily select "Today"
            // These 3 parameters are useful for localization.
            firstDay: 0,            // 0 = Sunday, 1 = Monday, etc...
            dayNamesMin: [ "Su", "Mo", "Tu", "We", "Th", "Fr", "Sa" ],
            monthNames: [ "January", "February", "March", "April", "May", "June", "July", "August", "September", "October", "November", "December" ]
        });

       
        var BUGZILLA = {
            param: {
                maxusermatches: 1000
            },
            constant: {
                COMMENT_COLS: 80
            },
            string: {
               

                attach_desc_required:
                    "You must enter a Description for this attachment.",
                component_required:
                    "You must select a Component for this bug.",
                description_required:
                    "You must enter a Description for this bug.",
                short_desc_required:
                    "You must enter a Summary for this bug.",
                version_required:
                    "You must select a Version for this bug."
            }
        };


    // -->
    </script>
<script type="text/javascript" src="data/assets/d41d8cd98f00b204e9800998ecf8427e.js"></script>

   
    <!--[if lt IE 9]>
      <script>
        document.createElement('header');
        document.createElement('nav');
        document.createElement('main');
        document.createElement('footer');
      </script>
    <![endif]-->

   

   
    <link rel="search" type="application/opensearchdescription+xml"
                       title="Bugzilla" href="./search_plugin.cgi">
    <link rel="shortcut icon" href="images/favicon.ico">
  </head>

  <body
        class="Eng1108-8080 yui-skin-sam">

  <header id="header"><div id="banner">
  </div>

    <div id="titles">
      <span id="title">Bugzilla &ndash; Log in to Bugzilla</span>


    </div>


    <nav id="common_links"><ul class="links">
  <li><a href="./">Home</a></li>
  <li><span class="separator">| </span><a href="enter_bug.cgi">New</a></li>
  <li><span class="separator">| </span><a href="describecomponents.cgi">Browse</a></li>
  <li><span class="separator">| </span><a href="query.cgi">Search</a></li>

  <li class="form">
    <span class="separator">| </span>
    <form action="buglist.cgi" method="get"
        onsubmit="if (this.quicksearch.value == '')
                  { alert('Please enter one or more search terms first.');
                    return false; } return true;">
    <input type="hidden" id="no_redirect_top" name="no_redirect" value="0">
    <script type="text/javascript">
      if (history && history.replaceState) {
        var no_redirect = document.getElementById("no_redirect_top");
        no_redirect.value = 1;
      }
    </script>
    <input class="txt" type="text" id="quicksearch_top" name="quicksearch"
           title="Quick Search" value="">
    <input class="btn" type="submit" value="Search"
           id="find_top"></form>
  <a href="page.cgi?id=quicksearch.html" title="Quicksearch Help">[?]</a></li>

  <li><span class="separator">| </span><a href="report.cgi">Reports</a></li>

  <li></li>


 
   
      <li id="new_account_container_top">
        <span class="separator">| </span>
        <a href="createaccount.cgi">New&nbsp;Account</a>
      </li>

   
</ul>
    </nav>
  </header>

  <main role="main" id="bugzilla-body">


<h2 class="center">Bugzilla needs a legitimate login and password to continue
</h2>

<form id="login_form" name="login" action="http://Eng1108:8080/index.cgi"
      method="POST" >
  <table>
    <tr>
      <th>
        <label for="Bugzilla_login">
            Login:
        </label>
      </th>
      <td>
        <input id="Bugzilla_login" name="Bugzilla_login" autofocus required>
      </td>
    </tr>

    <tr>
      <th><label for="Bugzilla_password">Password:</label></th>
      <td>
        <input type="password" id="Bugzilla_password" name="Bugzilla_password" required>
      </td>
    </tr>


    <tr>
      <th>
        <input type="checkbox" id="Bugzilla_restrictlogin" name="Bugzilla_restrictlogin"
               checked="checked">
      </th>
      <td>
        <label for="Bugzilla_restrictlogin">Restrict this session to this IP address
        (using this option improves security)</label>
      </td>
    </tr>

    <tr>
      <th>&nbsp;</th>
      <td>
        <input type="submit" name="GoAheadAndLogIn" value="Log In" id="log_in">
      </td>
    </tr>
  </table>
<input type="hidden" name="GoAheadAndLogIn"
             value="Log In">
      <input type="hidden" name="GoAheadAndLogIn"
             value="Log in">

  <input type="hidden" name="Bugzilla_login_token"
         value="">


  <div class="links">
      <span><a href="createaccount.cgi">Create a New Account</a></span>
|
      <span><a href="createaccount.cgi?request_new_password=1">Forgot Password</a></span>
  </div>

  <hr>
  <div class="info">
    <p>
      Note: you should make sure cookies are enabled for this site.
      Otherwise, you will be required to log in frequently.
    </p>

      <p>
      </p>
  </div>
</form>
</main>

    <footer id="footer">
      <div class="intro"></div>

      <nav><ul id="useful-links">
  <li id="links-actions"><ul class="links">
  <li><a href="./">Home</a></li>
  <li><span class="separator">| </span><a href="enter_bug.cgi">New</a></li>
  <li><span class="separator">| </span><a href="describecomponents.cgi">Browse</a></li>
  <li><span class="separator">| </span><a href="query.cgi">Search</a></li>

  <li class="form">
    <span class="separator">| </span>
    <form action="buglist.cgi" method="get"
        onsubmit="if (this.quicksearch.value == '')
                  { alert('Please enter one or more search terms first.');
                    return false; } return true;">
    <input type="hidden" id="no_redirect_bottom" name="no_redirect" value="0">
    <script type="text/javascript">
      if (history && history.replaceState) {
        var no_redirect = document.getElementById("no_redirect_bottom");
        no_redirect.value = 1;
      }
    </script>
    <input class="txt" type="text" id="quicksearch_bottom" name="quicksearch"
           title="Quick Search" value="">
    <input class="btn" type="submit" value="Search"
           id="find_bottom"></form>
  <a href="page.cgi?id=quicksearch.html" title="Quicksearch Help">[?]</a></li>

  <li><span class="separator">| </span><a href="report.cgi">Reports</a></li>

  <li></li>


 
   
      <li id="new_account_container_bottom">
        <span class="separator">| </span>
        <a href="createaccount.cgi">New&nbsp;Account</a>
      </li>

   
</ul>
  </li>

 




 
</ul>
      </nav>

      <div class="outro"></div>
    </footer>

  </body>
</html>


_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.
Reply | Threaded
Open this post in threaded view
|

Re: Cannot login Bugzilla

Bugslayer
On Wednesday, March 1, 2017 at 1:20:42 AM UTC-7, Thorsten Schöning wrote:

> Guten Tag Bugslayer,
> am Dienstag, 28. Februar 2017 um 23:17 schrieben Sie:
>
> > I am still try to figure out the problem. Here is the header sent out from my PC.
>
> Please describe exactly what you have configured in Bugzilla regarding
> login requirements, e.g. "requirelogin", you can see that in
> data/params.json. Additionally describe exactly how you access your
> Bugzilla and what happens if you click what, when the login form is
> presented, where you input your credentials etc. Step by step!
>
> The main login form as you have posted in my case e.g. only comes
> after I have logged out and when I want to create a new bug. I have
> "requirelogin" "off" for example. If I then input wrong credentials, I
> get an error message about wrong credentials, I don't get the login
> form again right away and such. From your description it reads like
> you don't get an error message about wrong credentials, else your
> problem would be pretty clear :-), so if you are redirected to the
> login form over and over again, without actually Bugzilla trying to
> login, this needs to be debugged differently of course.
>
> You request looks exactly like that:
>
> > GoAheadAndLogIn:Log In
> > GoAheadAndLogIn:Log in
> > Bugzilla_login_token:
>
> The template contains code to simply input all hidden forms provided
> to a former request back into the template, that would explain the
> multiple "GoAheadAndLogIn". On the other hand, "Bugzilla_login_token"
> should not be empty in this case, because it is created whenever the
> form is shown:
>
> > auth/login.html/tmpl:
>
> >   [% PROCESS "global/hidden-fields.html.tmpl"
> >      exclude="^Bugzilla_(login|password|restrictlogin)$" %]
> >
> >   <input type="hidden" name="Bugzilla_login_token"
> >          value="[% get_login_request_token() FILTER html %]">
>
> So in my case I'm not redirected to the login form over and over
> again, but get a message about unsuccessful authentication of so,
> "GoAheadAndLogIn" is only present once in the request and
> "Bugzilla_login_token" has a value.
>
> So I would focus on when the login form is presented why, what happens
> after you send the login request to the server on the server etc.
> Increase your web server log and such.
>
> Mit freundlichen Grüßen,
>
> Thorsten Schöning
>
> --
> Thorsten Schöning       E-Mail: [hidden email]
> AM-SoFT IT-Systeme      http://www.AM-SoFT.de/
>
> Telefon...........05151-  9468- 55
> Fax...............05151-  9468- 88
> Mobil..............0178-8 9468- 04
>
> AM-SoFT GmbH IT-Systeme, Brandenburger Str. 7c, 31789 Hameln
> AG Hannover HRB 207 694 - Geschäftsführer: Andreas Muchow

I was able to downgrade the Bugzilla install from 5.1.1 to 5.0.3. All users on all computers work now.

Thank you for your help.
_______________________________________________
support-bugzilla mailing list
[hidden email]
https://lists.mozilla.org/listinfo/support-bugzilla
PLEASE put [hidden email] in the To: field when you reply.